Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 5800-24G Switch (JC100A) IPv6 policy based routing with link local addresses

ThomasGlanzmann
Frequent Advisor

HP 5800-24G Switch (JC100A) IPv6 policy based routing with link local addresses

Hello,

when I try to set a IPv6 policy based route based on a link local address and an interface, I get the error message 'not supported' by hardware. Setting the next hop by a global IPv6 address works. However this might become a problem later for me when my provider uses link local addresses to provide IPv6 address spaces. Is there a workaround for this or other Layer 3 switches which support this feature?

 

Works:

acl ipv6 number 2101 name Rack-2-8-5-IPv6-nets
        rule permit source 2A01:x:y:z::/56
        quit
traffic classifier Rack-2-8-5-IPv6-nets
        if-match acl ipv6 2101
        quit
traffic behavior Rack-2-8-5-IPv6-nets
        redirect next-hop 2A01:x1:y1:z1::1
        quit
qos policy Rack-2-8-5-IPv6-nets
        classifier Rack-2-8-5-IPv6-nets behavior Rack-2-8-5-IPv6-nets
        quit
qos vlan-policy Rack-2-8-5-IPv6-nets vlan 107 inbound

Fails:

acl ipv6 number 2101 name Rack-2-8-5-IPv6-nets
        rule permit source 2A01:x:y:z::/56
        quit
traffic classifier Rack-2-8-5-IPv6-nets
        if-match acl ipv6 2101
        quit
traffic behavior Rack-2-8-5-IPv6-nets
        redirect next-hop fe80::1 GigabitEthernet 1/0/23
        quit
qos policy Rack-2-8-5-IPv6-nets
        classifier Rack-2-8-5-IPv6-nets behavior Rack-2-8-5-IPv6-nets
        quit
qos vlan-policy Rack-2-8-5-IPv6-nets vlan 107 inbound

 

 

 

Cheers,

      Thomas

1 REPLY
Apachez-
Trusted Contributor

Re: HP 5800-24G Switch (JC100A) IPv6 policy based routing with link local addresses

Doesnt answer your question but make sure that you use the latest firmware available.

 

Not too long ago one couldnt set global ipv6 addresses as manual address on an interface in A5820 (was forced to use link-local or some other, dont remember the exact error message). This was fixed in a firmware update that came about 2 years ago.