Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP A5500 EI Console terminal Access via Cisco 2811 router

ayush_gupta
Occasional Visitor

HP A5500 EI Console terminal Access via Cisco 2811 router

Hi,

I am trying to setup access on the console port of HP A5500 switch from a Cisco 2811 router terminal line.
The switch is connected on line 1/21 of the router. 

line configuration on the cisco router is as follows:

line 1/21
no history
no editing
transport preferred none
transport input telnet
transport output none
autohangup
stopbits 1

bmmebb0rt02#show line 1/21
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
   1/21   87 TTY   9600/9600  -    -      -    -    -    55      0    0/0      -

Line 1/21, Location: "", Type: ""
Length: 24 lines, Width: 80 columns
Baud rate (TX/RX) is 9600/9600, no parity, 1 stopbits, 8 databits
Status: Ready
Capabilities: none
Modem state: Ready
Modem hardware state: noCTS noDSR  DTR RTS
Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                ^^x    none   -     -       none
Timeouts:      Idle EXEC    Idle Session   Modem Answer  Session   Dispatch
               00:10:00        never                        none     not set
                            Idle Session Disconnect Warning
                              never
                            Login-sequence User Response
                             00:00:30
                            Autoselect Initial Wait
                              not set
Modem type is unknown.
Session limit is not set.
Time since activation: never
Editing is enabled.
History is enabled, history size is 20.
DNS resolution in show commands is enabled
Full user help is disabled
Allowed input transports are telnet.
Allowed output transports are none.
Preferred transport is none.
No output characters are padded
No special data dispatching characters

Access to the console is through a menu created on the router.

ip host bmmemm1sw01-console 2087 192.168.254.2

menu solution text 19 "(bmmemm1sw01-console HP A5500)"
menu solution command 19 resume bmmemm1sw01-console /connect telnet bmmemm1sw01-console

 

The HP A5500 switch configuration is as below:

<bmmemm1sw01>display current-configuration
#
 version 5.20.99, Release 2221P05
#
 sysname bmmemm1sw01
#
 super password level 3 cipher $c$3$hKAAqeDpvwDFJYNIIElRhMDfSOlcw=
#
 undo copyright-info enable
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
#
 domain default enable system
#
 telnet server enable
#
 lacp system-priority 8192
 link-aggregation load-sharing mode destination-ip source-ip
#
 password-recovery enable
#
vlan 1
#
vlan 6
 description Uplink
#
vlan 8
 name Sigtran1
#
vlan 9
 name Sigtran2
#
vlan 16
 name traffic
#
vlan 921
 name OAM
#
vlan 1205
 description sigtran1 uplink to BM0NX701
#
radius scheme system
 primary authentication 127.0.0.1 1645
 primary accounting 127.0.0.1 1646
 user-name-format without-domain
#
domain system
 access-limit disable
 state active
 idle-cut disable
 self-service-url disable
#
user-group system
 group-attribute allow-guest
#
local-user admin
 password cipher $c$3$BCqgdRwxTIFoRCdiKWurYclihGVk3A=
 authorization-attribute level 1
 service-type ssh terminal
#
 stp mode pvst
 stp pathcost-standard dot1t
 stp vlan 1205 root secondary
 stp vlan 8 to 9 16 root primary
 stp enable
#
interface Bridge-Aggregation1
 description "link to bmmemm1sw02"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
#
interface Bridge-Aggregation2
 description bmmemm1sw01_p1,P2,P3,P4 to bmmeen3sw03_P19,20,21,22 enclosure traffic switch"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 link-aggregation mode dynamic
#
interface Bridge-Aggregation3
 description bmmemm1sw01_P5,P6,P7,P8 bmmemm1b01-P1.1,P1.2,P1.3,P1.4 F5
 link-aggregation mode dynamic
#
interface Bridge-Aggregation4
 description Uplink ports Gi1/0/21,Gi1/0/22,Gi1/0/23,Gi1/0/24 to bm0osr03
 port access vlan 6
 link-aggregation mode dynamic
 stp disable
 stp edged-port enable
#
interface NULL0
#
#VLAN configuration removed for posting on internet
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 description "bmmeen3sw03_P19 enclosure traffic switch"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 2
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 description "bmmeen3sw03_P20 enclosure traffic switch"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 2
#
interface GigabitEthernet1/0/3
 port link-mode bridge
 description "bmmeen3sw03_P21 enclosure traffic switch"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 2
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 description "bmmeen3sw03_P22 enclosure traffic switch"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 2
#
interface GigabitEthernet1/0/5
 port link-mode bridge
 description "Bridge1 to F5 bmmemm1b01-P1.1"
 port access vlan 16
#
interface GigabitEthernet1/0/6
 port link-mode bridge
 description "Bridge1 to F5 bmmemm1b01-P1.2"
 port access vlan 16
#
interface GigabitEthernet1/0/7
 port link-mode bridge
 description Bridge1 to F5 bmmemm1b01-P1.3
 port access vlan 16
#
interface GigabitEthernet1/0/8
 port link-mode bridge
 description Bridge1 to F5 bmmemm1b01-P1.4
 port access vlan 16
#
interface GigabitEthernet1/0/9
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/10
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/11
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/12
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/13
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/14
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/15
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/16
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/17
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/18
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/19
 port link-mode bridge
 description SIGTRAN to ZSR701Fex101/19
 port access vlan 1205
 stp disable
 stp edged-port enable
#
interface GigabitEthernet1/0/20
 port link-mode bridge
 description "OAM to bmmeen3sw02_p20 encl cisco 3020"
 port access vlan 921
#
interface GigabitEthernet1/0/21
 port link-mode bridge
 description BridgeGRP_4_to_OSR_3_p8
 port access vlan 6
 stp edged-port enable
 port link-aggregation group 4
#
interface GigabitEthernet1/0/22
 port link-mode bridge
 description BridgeGRP_4_to_OSR_3_p11
 port access vlan 6
 stp edged-port enable
 port link-aggregation group 4
#
interface GigabitEthernet1/0/23
 port link-mode bridge
 description BridgeGRP_4_to_OSR_3_p12
 port access vlan 6
 stp edged-port enable
 port link-aggregation group 4
#
interface GigabitEthernet1/0/24
 port link-mode bridge
 description BridgeGRP_4_to_OSR_3_p14
 port access vlan 6
 stp edged-port enable
 port link-aggregation group 4
#
interface GigabitEthernet1/0/25
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/26
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/27
 port link-mode bridge
 shutdown
#
interface GigabitEthernet1/0/28
 port link-mode bridge
 shutdown
#
interface Ten-GigabitEthernet1/1/1
 port link-mode bridge
 description "bmmemm1sw02 port interface Ten-GigabitEthernet2/2/1 HP A5500 Trunk"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 1
#
interface Ten-GigabitEthernet1/1/2
 port link-mode bridge
 shutdown
#
interface Ten-GigabitEthernet1/2/1
 port link-mode bridge
 description "bmmemm1sw02 port interface Ten-GigabitEthernet2/1/1 HP A5500 Trunk"
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 8 to 9 16
 port link-aggregation group 1
#
interface Ten-GigabitEthernet1/2/2
 port link-mode bridge
 shutdown
#
 ### Routes removed for posting
 ip route-static 192.168.0.0 255.255.0.0 192.168.116.252
#
 snmp-agent
 snmp-agent local-engineid 800063A203CC3E5F1E1039
 snmp-agent community read Uh1RjWY9
 snmp-agent sys-info version all
 snmp-agent target-host trap address udp-domain 192.168.96.3 params securityname ProdHg3835027rewroew
 snmp-agent trap enable default-route
#
 header motd %
 ************************************
 *                       *
 *           bmmemm1sw01            *
 *        BB2.1 HPA5500-VRRF        *
*        VM Cabinet 2, U40         *
 *                                  *
 ************************************
--- Unauthorised access prohibited ---
This is a closed-access system. If you do not have permission
to access this system, then log off now. If you remain logged on
you consent to monitoring of your actions.
%
#
 ntp-service unicast-server 192.168.116.250
 ntp-service unicast-peer 192.168.116.250 priority
 ntp-service unicast-peer 192.168.116.251
#
 ssh server enable
 ssh user admin service-type stelnet authentication-type password
#
 load xml-configuration
#
 load tr069-configuration
#
user-interface aux 0
 authentication-mode scheme
user-interface vty 0 15
 authentication-mode scheme
#
return
<bmmemm1sw01>

When i connect to the router; the menu opens up. I choose Menu option 19. Once i do that there is no output at all on terminal even after pressing Enter key. 

Using username "admin".
Using keyboard-interactive authentication.
Password:

 ************************************
 *                                  *
 *            bmmebb0rt02            *
 *             BB 2811              *
 *          Cabinet 2, U42          *
 *                                  *
 ************************************

--- Unauthorised access prohibited ---
This is a closed-access system. If you do not have permission
to access this system, then log off now. If you remain logged on
you consent to monitoring of your actions.
C
********************** 

                      MAIN MENU
*******************************************************

    1          "bmmeen2sw01 (bmmeen2sw01-Console)"
    2          "bmmeen2sw02 (bmmeen2sw02-Console)"
    3          "bmmeen2sw03 (bmmeen2sw03-Console)"
    4          "bmmeen2sw04 (bmmeen2sw04-Console)"
    5          "bmmeen2sw05 (bmmeen2sw05-Console)"
    6          "bmmeen2sw06 (bmmeen2sw06-Console)"
    7          "bmmeen2mn01 (bmmeen2mn01-Console)"
    8          "bmmeen2mn02 (bmmeen2mn02-Console)"
    9          "bmmeen3sw01 (bmmeen3sw01-Console)"
    10         "bmmeen3sw02 (bmmeen3sw02-Console)"
    11         "bmmeen3sw03 (bmmeen3sw03-Console)"
    12         "bmmeen3sw04 (bmmeen3sw04-Console)"
    13         "bmmeen3sw05 (bmmeen3sw05-Console)"
    14         "bmmeen3sw06 (bmmeen3sw06-Console)"
    15         "bmmeen3mn01 (bmmeen3mn01-Console)"
    16         "bmmeen3mn02 (bmmeen3mn02-Console)"
    17         "bmmebb0lb02 (bmmebb0lb02-Console F5)"
    18         "bmmebb0lb01 (bmmebb0lb01-Console F5)"
    19         "(bmmemm1sw01-console HP A5500)"
    20         "(bmmemm1sw02-console HP A5500)"
    x          Exit

C
Please enter your selection:19
Trying bmmemm1sw01-console (192.168.254.2, 2087)... Open

 ************************************
 *                                  *
 *           bmmebb0rt02            *
 *             BB 2811              *
 *          Cabinet 2, U42          *
 *                                  *
 ************************************

--- Unauthorised access prohibited ---
This is a closed-access system. If you do not have permission
to access this system, then log off now. If you remain logged on
you consent to monitoring of your actions.

I have tried multiple configuration changes with the little undestanding i have about the switch and router.
Please help me in identifying what i am doing incorrect in the configuration and how i can troubleshoot this issue.

2 REPLIES
VoIP-Buddy
Trusted Contributor

Re: HP A5500 EI Console terminal Access via Cisco 2811 router

Ayush,

You should use the blue console cable that ships with every HPE switch and then use adapters, null-modem or gender-changers as needed, to adapt the DB9 end to the type of connector that the Cisco requires.

Regards,

David

ayush_gupta
Occasional Visitor

Re: HP A5500 EI Console terminal Access via Cisco 2811 router

The cables are correctly in place. 

Please check if the configuration is correct.