HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP2920-24G setting the openflow version

 
SOLVED
Go to solution
wfrabbit
Occasional Visitor

HP2920-24G setting the openflow version

Hi, 

 

I am using the HP2920-24G switch. I can not configure the openflow version with the following command:

 

"openflow instance test1 1.3"

 

(by referring to the openflow v1.3 administrator guide)

 

I get the following error:

 

" invalid input:1.3"

 

How could I configure the openflow version correctly?  

 

Thank you so much.

 

Regards,

4 REPLIES
wfrabbit
Occasional Visitor

Re: HP2920-24G setting the openflow version

By the way, I also find some commands are missing from my switch, such as "auxiliary-connection " command. Do I need to update my firmware? How to check the version of my firmware? Thanks.

EricAtHP
Esteemed Contributor
Solution

Re: HP2920-24G setting the openflow version

Here is a sample config of OpenFlow on a 2920:

 

openflow
   controller-id 1 ip 192.168.111.2 controller-interface vlan 3
   instance "visualizer"
      member vlan 1
      controller-id 1
      version 1.3 only
      enable
      exit
   enable
   exit

 

In this case, the controller is connected to the switch in VLAN 3 and VLAN 1 is being controlled by OpenFlow 1.3.

 

You will see that the OpenFlow version is specified once in the instance context, not when creating the instance. And OpenFlow 1.3 was introduced in WB.15.14. So upgrading may be required. I am running WB.15.16. You can view your software version with the "show version" command.

 

Go here to download software for the 2920. The release notes should help you with upgrading.

 

https://h10145.www1.hp.com/Downloads/SoftwareReleases.aspx?ProductNumber=J9726A&lang=en,en&cc=us,us&prodSeriesId=5354494

wfrabbit
Occasional Visitor

Re: HP2920-24G setting the openflow version

Hi Eric, 

 

Thank you so much. After updating the firmware, I could configure the openflow version 1.3. But there is another problem,  the hosts connected to the openflow network of the switch cannot communicate with each other (tested with ping) when I configure the openflow version as 1.3. But when configured as openflow 1.0, the hosts could communicate with each other. I am using the floodlight1.0 as the controller. Besides, I also triy to add the static rule using REST api, but it does not work for the openflow 1.3. Is there anything else I should configure when trying to use openflow 1.3? Or the HP2920 does not work well when using the floodligh controller? Thanks

EricAtHP
Esteemed Contributor

Re: HP2920-24G setting the openflow version

It has been years since i have played with the Floodlight controller. The last time I did, it was only OpenFlow 1.0. Based on your description, it sounds like Floodlight isn't programming the right flows. I would recommend bringing this up on the Floodlight forums.

 

Another option would be to use the HP controller: hp.com/go/sdn. There are also forums specifically for sdn. Start here: sdndevcenter.hp.com.