Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP5130 can not receive ip from DHCP server

SOLVED
Go to solution
chifra-boss
Visitor

HP5130 can not receive ip from DHCP server

Hi all.
I have big problem with new HP 5130 with new version Comware 7.
Switch can not receive ip from DHCP server.
HP 5130 site settings:

interface Vlan-interface10
ip address dhcp-alloc
#
interface Vlan-interface11
ip address dhcp-alloc
#
interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan 1 10 to 11 18
port trunk pvid vlan 10

other side have settings:

interface Ethernet1/0/20
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 10

But If I am change link-type of port on other side to access

interface Ethernet1/0/20
port access vlan 11

Interface Vlan 10 starting work, receive ip from dhcp, interface vlan 11 not receive ip :-(
If I change setting on HP5130 port trunk pvid vlan 11

interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan 1 10 to 11 18
port trunk pvid vlan 11

Interface Vlan 11 starting work, receive ip from dhcp, interface vlan 10 not receive ip :-(
Why getting ip through TRUNK does not work? If I set a static IP ping through TRUNK not work too.

4 REPLIES
Vince-Whirlwind
Honored Contributor

Re: HP5130 can not receive ip from DHCP server

My first guess would be that you have no active devices on ports assigned to the VLANs, so the VLAN interface isn't up.

chifra-boss
Visitor

Re: HP5130 can not receive ip from DHCP server

Of course you are wrong. Vlan interface UP because port interface GigabitEthernet1/0/1  enters into trunk vlan. And only change the settings on the other side from trunk to access port my Vlan interface receive ip.

chifra-boss
Visitor
Solution

Re: HP5130 can not receive ip from DHCP server

Self asked himself answered.
Root of the problem was that STP protocol did not give work trunk interface.
After "undo stp global enable" everything starting working like charm.
Very strange that the default settings are not allowed to work. Working for common settings.

16again
Respected Contributor

Re: HP5130 can not receive ip from DHCP server

I wouldn't disable STP for something like that.

STP can work in classic mode, i  which it takes 30...50 seconds for a link to become functional.  Some DHCP clients already have given up hope during that interval.  I prefer static IP for switches, also you could look into STP mode  (proper functioning MSTP or RSTP  has way lower times for link to become active)