Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP5900 IRF CONFIGURATION WITH 40GB PORT

Adriano-Pellegr
Occasional Advisor

HP5900 IRF CONFIGURATION WITH 40GB PORT

Hi There,

I´m trying to setup an IRF Cluster with 2 devices HP5900 using 40G Interface (40Gps QSFP Cable) but without sucess.

Firt I shut all the interfaces that will be add do the port group, after that I created the irf-port n/1 i.e , after I add the 40G interface using port group interface..... After this step when I execute the command undo shut under the 40G interface, the interface remains down.

Is anybody here once use this 40GB interface with DAC Cable in order to setup the IRF Cluster.  The same device i used Fiber to to this without problem,

Any tips?

Regards

Adriano

 

 

 

9 REPLIES
sdmitriev1
Valued Contributor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

I'm using 40Gps QSFP Cable, my config:

#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 32
irf member 2 priority 30
irf mode normal

#
irf-port 1/1
port group interface FortyGigE1/0/51
#
irf-port 1/2
port group interface FortyGigE1/0/52
#
irf-port 2/1
port group interface FortyGigE2/0/51
#
irf-port 2/2
port group interface FortyGigE2/0/52

 

Adriano-Pellegr
Occasional Advisor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

Thank for the conf, is the same that I did here...but in fact, my interface is a 100G not a 40G,  but i´m using DAC cable for 40Gb. I think that could be something with this DAC Cable.

I tried to execute the command using forty and ten but retursn the message the operation isn´t suported .

My Device is a HP5940.

Thank you again.

 

 

sdmitriev1
Valued Contributor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

"I tried to execute the command using forty and ten" - what is the command?

parnassus
Honored Contributor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

Adriano-Pellegr wrote: ...but in fact, my interface is a 100G not a 40G,  but i´m using DAC cable for 40Gb. I think that could be something with this DAC Cable.

It's unclear...are your working with two HPE FlexFabric 5940 with SKUs JH390A (48SFP+ 6QSFP28 ports) or JH391A (48XGT+6QSFP28 ports)?

Those models are the only ones equipped with 100GbE ports (6QSFP28).

Are you then using HPE X240 100G QSFP28 to QSFP28 Direct Attach Copper Cables like, as example, those ones with SKUs JL271A or JL272A (respectively, 1 meter or 3 meters long)?

VoIP-Buddy
HPE Pro

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

What IRF configuration are you looking to do?  If just between two switches, you don't need 4 IRF Port Groups.  You can do this...

irf-port 1/1
port group interface FortyGigE1/0/51

port group interface FortyGigE1/0/52
#
irf-port 2/2
port group interface FortyGigE2/0/51

port group interface FortyGigE2/0/52

Official J number DAC cables worlk.  I have that set up in the lab.

Regards,

David
 
Add tags

Carsick0
Occasional Advisor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

>with DAC Cable in order to setup the IRF Cluster.  The same device i used Fiber to to this without problem,

I had this same problem a few years ago when I got my first 5900 switches. I built them on the bench using DAC cables for the IRF links as that was easier than having single mode fibre all over the lab. When we then came to test the IRF config with the fibre modules it would not work. Advice from HP was that this was the case as they had recreated it their lab. You need to do a factory reset on the switches and then reconfigure them. I do not know if this was fixed in a later release of software. If you have a port that has never been used try configuring it with that interface.

 

parnassus
Honored Contributor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

Which software version is the 5900 Switch currently running on?

VoIP-Buddy
HPE Pro

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

Hi Carsick0!

That should not be the case and you shouldn't have to factory reset to fix it.  There is nothing that ties an IRF setup to the particular transceiver you used when the IRF stack was built.  As Parnassus asked, what version of Comware did you have loaded?  This doesn't make sense.

Were the fiber transceivers that you tried genuine HPE transceivers or 3rd party OEM compatible ones?  Is there any message in the logbuffer to indicate that Comware didn't like the transceiver?

Regards,

David

MaZ
Advisor

Re: HP5900 IRF CONFIGURATION WITH 40GB PORT

Hello,

On 5940 48XGT 6QSFP28 (JH391A) and 5940 48SFP+ 6QSFP28 (JH390A), 40 Gbps IRF links using 100Gbps interface are supported only since release F2603.

Try to contact your HPE support to get the last release.