Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

nt2
Occasional Contributor

HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

I am having strange issues with auto negotiation on HPE 5120-24g EI, it's reporting duplex mismatch on most ports and links going down and up twice in a row on random basis. Canon photocopier is most troublesome, it's connecting at 10 Mbps / half duplex and link is regularly going down and up every few seconds.

All devices (mostly Win 10 workstations and printers/plotters) are GbE capable and set to auto negotiate (including switch). Everything is currently connected by new cat7 and flat cat6 patch cables (length is between 5m and 20m) except connection to router that goes trough old in-wall cat5 installation. Switch is updated to latest firmware (R2222P01).

Does anyone have idea what could be wrong here?

5 REPLIES
Vince-Whirlwind
Honored Contributor

Re: HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

You say the devices are set to auto-negotiate, but what about the switchports?

nt2
Occasional Contributor

Re: HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

All ports on switch are also set to auto-negotiate.

Vince-Whirlwind
Honored Contributor

Re: HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

Watch debug level logging as you enable a switchport

Lrod78
Occasional Advisor

Re: HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

Run into the same issue on a HPE 5120-24g EI.  Going to see if I can reproduce on on a 48g.  This was also after upgrading to the newest firmware: R2222P01.

Going to try downgrading a version to see if it still exist.  Also, quick question, are you using a standard port config?

nt2
Occasional Contributor

Re: HPE 5120-24g EI - issues with auto-negotiation / duplex mismatch

Yes, I used standard port config at first, then I switched ports to 1 Gig/duplex on all devices and that partly solved the issue.