Comware-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE 5130 - how to enable set screen-length

SOLVED
Go to solution
stuart_d1
Occasional Contributor

HPE 5130 - how to enable set screen-length

As per my title how can I set the screen-length to pause when displaying the devices configuration?

I've done a search and tried various options but none work and the only real answer I see is how to disable teh MORE prompt.

4 REPLIES
sdide
Trusted Contributor

Re: HPE 5130 - how to enable set screen-length

Hi,

Not sure exactly what you want to do?

You can enable the the "more"-functionality by doing "undo screen-length disable", and disable the the "more"-functionality with "screen-length disable" both in user-view.

Setting a specific screen-length for you current vty is a little different.

You need to be in system-view, and you need to set it for you current line. So forexample if I'm on vty 0 (you can check your line with "display users"

[HP-5130-24G]display users 
  Idx  Line    Idle       Time              Pid     Type
+ 10   VTY 0   00:00:00   Jul 11 13:43:18   2049585 SSH 
...

So changing the screen-length for that vty will have effect immediately. Viz.

[HP-5130-24G]line 0
HP-5130-24G-line0]screen-length 80

Will set the screen length to 80 before the more-functionality "kicks in".  It has a range from 0 to 512.  0 corresponds to  disableing sreen-length .

NB: You need to remove it again if you want to have the default screen-length 24 again next time someone logs in at vty 0.

Regards

Søren Dideriksen, Network Administrator
Region Midtjylland
stuart_d1
Occasional Contributor

Re: HPE 5130 - how to enable set screen-length

Thank you Søren.

Despite my lack of initial clarity you have hit upon what I was getting at so thanks for that... however, whilst I can enter: undo screen-length disable  it 'appears' to have no effect so that when I do a dis curr it just keeps scrolling.

Also, system-view 40 (when in the right line) also has zero effect on stopping the text from scrolling until the end.

To calrify a bit... both the commands are accepted but neither has any effect on stopping scrolling or in presenting one with the MORE prompt.

Frustrating.

Highlighted
sdide
Trusted Contributor
Solution

Re: HPE 5130 - how to enable set screen-length

I've made a mistake in my configuration example I've pasted to you: I wrote "line 0" where I should have written "line vty 0". Line 0 is actually aux 0. .

I should have written.

[HP-5130-24G]line vty 0
[HP-5130-24G-line-vty0]screen-length 80

Maybe this makes a difference?

NB: If it still does not work for you, could you post the output of "display current-configuration configuration line" (and remember to remove passwords and stuff like that)

Regards

 

 

Søren Dideriksen, Network Administrator
Region Midtjylland
stuart_d1
Occasional Contributor

Re: HPE 5130 - how to enable set screen-length

Thanks again Søren.

It turns out that did the trick and what's more, doing some more digging as to why I have discovered that our automated device backup tool has a command that forces screen-length 0 as a default. Not sure why that would be but at least I have a way forward now.

Appreciate your time.