Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HPE 5130 problem with VLAN

gillesdenice
Occasional Collector

HPE 5130 problem with VLAN

I have a strange problem with a brand new HP 5130 switch.

I replaced a working Cisco 2950 with the HP 5130, I modified the Cisco configuration to use in the HP.

The switch is connected to a Cisco Catalyst 3560 for the L3 layer with a Trunk Link

I have a connection problem between a server and a printer

The printer is on VLAN  159 and the print server is on the same VLAN. A ping command works fine from another VLAN to the printer but on the same VLAN, the print serveur cannot ping the printer

I noticed that arp -a shows a problem  with the mac-address of the printer

It shows 134.59.22.13 00-00-00-00-00-00 Note valid

I have port-security enabled but not configured on the printer interface ?

Any idea ?

Thanks

5 REPLIES
Linkk
Frequent Advisor

Re: HPE 5130 problem with VLAN

Hi,

Can you ping the printer from another VLAN? 

I guess 134.59.22.13 is the IP address of the printer, from where in the topology did you test the L2 connection? Did you connect your PC (or whatever you tested with) to the same switch, the printer is on, or did you connect it to some other? 

If you connected it to another switch, please check the VLAN configuration in between the switches. If it is on the same switch, please check the VLAN configuration on the access ports. 

 

gillesdenice
Occasional Collector

Re: HPE 5130 problem with VLAN

Thanks for your help

The printer pings fine from another VLAN. The problem is that the print server is on this same VLAN.
If I put a computer on a port with same VLAN I can ping the printer but the print server in on another switch :(

I tried to do a "ping -t 134.59.22.13" (the printer) from the print server 
-> unreachable; I don't have the mac-address is in the arp table

I reboot the switch while the print serveur is pinging
-> I get a response from my printer, the mac-adress is in the arp table

I stop the ping -t
After few minutes, the ping no longer responds
The arp table doesn't contain the ip of the printer 

It is as if, after a moment, a service was launched which blocked the ARP requests ...

 

 

KSHKND
Advisor

Re: HPE 5130 problem with VLAN

Could you post the display current config with the port numbers where these devices are conneted? Also is there an IP address on the 5130's VLAN if its there try doing a display arp vlan VID and see if the printer's IP/MAC's binding in there

gillesdenice
Occasional Collector

Re: HPE 5130 problem with VLAN

Hello

The printer is on interface GigabitEthernet1/0/19
The trunk with the Cisco in on interface Ten-GigabitEthernet1/0/25

I replaced the printer with a computer (same ip : x.x.x.19)

I have realy a strange arp behavior
Computer x.x.x.19 is on GigabitEthernet1/0/19
Print server has x.x.x.23 ip

The ping command from x.x.x.23 (print server) to x.x.x.19 is unreacheable
I can't see the x.x.x.19 mac address in the arp cache

I initialise a ping from x.x.x.19 to x.x.x23, after a while it responds
At the same time, the ping -t from x.x.x.23 to x.x.x.19 changes from unreacheable to a correct response
From x.x.x.23, If i clear the arp cache (arp -d). The ping doesn't respond anymore

It sounds like an arp problem

If i replace the 5130 witch a Cisco 2950 I have no problem
With the 5130, the ping from
 any other VLAN works fine

I don't have any information regarding the print server or the printer.
I only have the information from the vlan 1

#
version 7.1.045, Release 3115P07
#
sysname L2-INFO-04
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
port-security enable
#
password-recovery enable
#
vlan 1
#
vlan 208
#
vlan 450
#
vlan 751
#
vlan 755 to 756
#
vlan 759
#
vlan 765
#
vlan 769
#
vlan 777
#
vlan 779
#
vlan 888
#
vlan 922
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.1.4 255.255.255.0
#
interface Vlan-interface450
description Management
ip address 172.16.22.4 255.255.252.0
#
interface GigabitEthernet1/0/19
description 758 / D19 / Switch imprimantes
port access vlan 759
port-security intrusion-mode blockmac
port-security max-mac-count 3
port-security port-mode autolearn
port-security mac-address security sticky 0015-c5bf-12d4 vlan 759
port-security mac-address security sticky 001b-a944-18ef vlan 759
#
interface Ten-GigabitEthernet1/0/25
description Trunk
port link-type trunk
port trunk permit vlan all
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 15
authentication-mode scheme
user-role network-operator
protocol inbound ssh
idle-timeout 0 0
#
line vty 16 63
user-role network-operator
#
ip route-static 0.0.0.0 0 192.168.1.250
#
snmp-agent
snmp-agent local-engineid 800063A280D8940325CF5B00000001
snmp-agent sys-info version all
#
ssh server enable
#
radius scheme system
user-name-format without-domain
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
return

gillesdenice
Occasional Collector

Re: HPE 5130 problem with VLAN

I found the cause of the problem
I had a Cisco Catalyst 2950 switch connected to port 8

interface GigabitEthernet1/0/8
port link-type trunk
port trunk permit vlan 1 779
#

I removed it, I removed/replaced the uplink and now the ARP queries are working correctly
I do not understand this issue, especially since the concerned VLAN did not go on this switch Cisco on the port 8

Any Idea ?