Comware-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Help With MSR 954 Router 4G module

SOLVED
Go to solution
cquirozb
Occasional Advisor

Help With MSR 954 Router 4G module

Hello community! 

I've been trying to get the 4G interface up on the router but nothing seems to work. Let me show you what I have discovered so far. 

So I have my Celluar interface UP and it is attached to the Eth-Channel 1/0:0

Cellular1/0
Current state: UP
Description: Cellular1/0 Interface
Last clearing of counters: Never
Modem status: Present
DM port status: Disabled
Capability:
1 Control channel,, 1 ETH channel
Control channel 0 traffic statistics:
TX: 0 packets, 0 errors
RX: 0 packets, 0 errors
ETH channel 0 traffic statistics:
TX: 0 packets, 0 errors
RX: 0 packets, 0 errors

controller Cellular1/0
eth-channel 0

interface Eth-channel1/0:0
description CONEXION 4G
dialer circular enable
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
dialer number *99#
ip address cellular-alloc
tcp mss 1024
nat outbound

If I check the status of the interfaces, I am seeing this: 

Eth-channel1/0:0
Current state: DOWN
Line protocol state: UP(spoofing)
Description: CONEXION 4G
Bandwidth: 100000kbps
Maximum Transmit Unit: 1500
Internet protocol processing: disabled

It is saying that The physical interface is Down but the line protocol is UP. I have read about this error and it seems to me that the router is not matching correctly the interfaces. 

I have rebooted, reset, re-configured and still, I am not able to bring the physical interface UP. 

May I have some help to solve this issue? 

 

 

 

5 REPLIES
VoIP-Buddy
Trusted Contributor

Re: Help With MSR 954 Router 4G module

Cquirozb,

Can you please share the configuration with us?  I am pretty sure you are missing something like the dial string.  Which carrier are you trying to connect to?

I have a couple of these running in the lab without any trouble.  We have AT&T and Verizon SIM cards.

Thanks!

David

cquirozb
Occasional Advisor

Re: Help With MSR 954 Router 4G module

Hello David! Thank you very much for your reply!

Here is the configuration that I'm using for the Eth-Channel1/0:0

interface Eth-channel1/0:0

description CONEXION 4G

dialer circular enable

dialer-group 1

dialer timer idle 0

dialer timer autodial 5

dialer number *99#

ip address cellular-alloc

tcp mss 1024

nat outbound


dialer-group 1 rule ip permit

 

I will paste the configuration edited as well. I left what I believe is "relevant". 

#

dialer-group 1 rule ip permit
#
dhcp enable
#
dns proxy enable
dns domain nh.inet
dns server 10.201.2.20
dns server 10.201.2.21
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
traffic classifier default operator and
if-match any
#
traffic classifier marc-oro operator and
if-match acl name marc-oro
#
traffic classifier marc-video operator and
if-match acl name marc-video
#
traffic classifier marc-voz operator and
if-match acl name marc-voz
#
traffic classifier oro operator and
if-match dscp af21
#
traffic classifier video operator and
if-match dscp af41
#
traffic classifier voice operator and
#
traffic classifier voz operator and
if-match dscp ef
#
traffic behavior Shape_92160
traffic-policy ip-wan-qos
gts cir 92160 cbs 5760000 ebs 0 queue-length 50
#
traffic behavior default
#
traffic behavior marc-oro
remark dscp af21
#
traffic behavior marc-video
remark dscp af41
#
traffic behavior marc-voz
remark dscp ef
#
traffic behavior oro
queue af bandwidth 36864
#
traffic behavior video
queue af bandwidth 18432
#
traffic behavior voz
queue ef bandwidth 9216 cbs 230400
#
qos policy Shape_92160
classifier default behavior Shape_92160
#
qos policy ip-wan-qos
classifier video behavior video
classifier voz behavior voz
classifier oro behavior oro
#
qos policy marcacion-ip
classifier marc-video behavior marc-video
classifier marc-voz behavior marc-voz
classifier marc-oro behavior marc-oro
#
controller Cellular0/0
#
controller Cellular0/1
#
controller Cellular2/0
eth-channel 0
#
controller Cellular4/0
#
interface Aux0
#
interface NULL0
#
interface GigabitEthernet0/0
port link-mode route
description CONEXION SWITCHES
combo enable copper
#
interface GigabitEthernet0/0.2
description Vlan Datos
ip address 10.200.45.1 255.255.255.128
vlan-type dot1q vid 2
dhcp select relay
dhcp relay server-address 10.201.2.63
#
interface GigabitEthernet0/0.3
description Vlan Voz
ip address 10.200.45.129 255.255.255.128
vlan-type dot1q vid 3

interface Eth-channel1/0:0
description CONEXION 4G
dialer circular enable
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
dialer number *99#
ip address cellular-alloc
tcp mss 1024
nat outbound
#
multicast routing
#
igmp
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class tty
user-role network-operator
#
line class vty
user-role network-operator
#
line aux 0
authentication-mode scheme
user-role network-admin
#
line vty 0 63
authentication-mode scheme
user-role network-operator
protocol inbound ssh
#
ip route-static 200.21.240.107 32 Eth-channel1/0:0 preference 100
#
ssh server enable
#
ntp-service unicast-server 192.68.9.9
ntp-service unicast-peer 192.68.9.9
#
undo password-control aging enable
undo password-control length enable
undo password-control history enable
password-control login-attempt 3 exceed lock-time 120
#
ipsec transform-set trans2
encapsulation-mode transport
esp encryption-algorithm des-cbc
esp authentication-algorithm md5
#
ipsec profile vpnprof isakmp
transform-set trans2
ike-profile vpnprof
#
ike profile vpnprof
keychain 1
#
ike keychain 1
pre-shared-key ***
#
return

Is there something missing ? 

I am trying to connect to Telefónica.

If you need further information please let me know so I can get it ASAP. Thank you very much for the help David!

 

 

 

parnassus
Honored Contributor

Re: Help With MSR 954 Router 4G module

What's the purpose of tcp mss 1024 command on your configuration? what's the result of display cellular-ethernet all, display interface cellular-ethernet and display dialer commands?

Shouldn't be present a directive:

ip route-static 0.0.0.0 0 Eth-channel1/0:0 

to get to your ISP?

cquirozb
Occasional Advisor
Solution

Re: Help With MSR 954 Router 4G module

Hello Community! 

 

The problem was within the equipment. We changed it and the link came up. 

 

Thank you very much for all your help! 

Highlighted
cquirozb
Occasional Advisor

Re: Help With MSR 954 Router 4G module

Hello! 

Its been a while but I was able to get the information that you requested: 

 

[HPE-Eth-channel1/0:0]display cellular
Cellular1/0:
Modem State:
Hardware Information:
Model: MC7354
Manufacturer: Sierra Wireless, Incorporated
Modem Firmware Version: SWI9X15C_05.05.16.02 r21040 carmd-fwbuild1 2014/03/17 23:49:48
Modem Boot Version: SWI9X15C_05.05.16.02 r21040 carmd-fwbuild1 2014/03/17 23:49:48
Modem Image Type = ATT
Firmware Unique ID = 005.010_001
Firmware Build ID = 05.05.16.02_ATT
Configuration Unique ID = 005.010_001
Configuration Build ID = 05.05.16.02_ATT
PRI Version: 9903211 05.07
International Mobile Equipment Identity (IMEI): 359225050640002
International Mobile Subscriber Identity (IMSI): 732123603487194
Mobile Equipment Identifier (MEID): 35922505064000
Hardware Version: 1.0
Modem Status: Online
Profile Information:
Profile index: 1
PDP Type: IPv4
Header Compression: Off
Data Compression: Off
Access Point Name (APN): internet.movistar.com.co
Authentication: PAP
Username: movistar
* - Default profile
Profile index: 16
PDP Type: IPv4
Header Compression: Off
Data Compression: Off
Access Point Name (APN): internet.movistar.com.co
Authentication: PAP
Username: 7321236034871941CN62HB300L1movistar
Network Information:
Current Service Status: Service Available
Registration Status: Registered
Current Service: Combined
Current Roaming Status: Home
Current Data Bearer Technology: Unknown
Network Selection Mode: Automatic
Current IP address Mode: Cellular-alloc
Mobile Country Code (MCC): 732
Mobile Network Code (MNC): 123
Location Area Code (LAC): 65534
Tracking Area Code(TAC): 2363
Cell ID: 7efb202
Radio Information:
Technology Preference: No preference specified (AUTO)
Technology Selected: LTE
Configured LTE Band = 2,4,5,17
LTE related info:
Current RSSI: -43 dBm
Current RSRQ: -9 dB
Current RSRP: -74 dBm
Current SNR: 11 dB
Tx Power: Invalid
Active Band = E-UTRA Operating Band 4
Modem Security Information:
PIN Verification: Disabled
PIN Status: PIN Requirement Disabled
Number of PIN Retries Remaining: 3
Number of PUK Retries Remaining: 10
SIM Status: OK
ICCID: 8957123411406361349

GPS Information:
GPS Info:
GPS State: Enabled
GPS Mode Configured: Standalone
Latitude: 4 Deg 34 Min 47 Sec North
Longitude: 74 Deg 17 Min 0 Sec West
Timestamp (UTC): 01/01/1970 00:00:00
Local time: 04/15/2010 00:45:19
Heading: 0.00, Velocity Horiz: 0.00, Velocity Vert: 0.00
Height (MSL): -12.00 m
Satellite Info:
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]
[HPE-Eth-channel1/0:0]displ
[HPE-Eth-channel1/0:0]display dialer
Eth-channel1/0:0
Dialer Route:
Dialer number: *99#
Dialer Timers(in seconds):
Auto-dial: 5 Compete: 20 Enable: 5
Idle: 0 Wait-for-Carrier: 60
Total Channels: 1
Free Channels: 1

 

We were able to fix the issue by changing the equipment, but! I have the faulty one in my hands and I really want to know if there is something wrong within the equipment. 

 

Regarding the static route. That is true, I have to configure that in order to have access to the internet. Nevertheless, I should be able to get an IP address from my SIM Card for the 4G Network even if the route is not there.