Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

How to configure Voice VLAN in new install

NCGnet
Occasional Advisor

How to configure Voice VLAN in new install

Hi Everyone,

 

I have been writing a configuration for the HP A5500EI switches which we will be installing into our new building to act as the buidings layer 3 'core'. Throughout the building we have seven cabinets each with HP procurve switches in which will connect back to the 5500 pair (in an IRF) via fibre. I have written an MSTP config which will run throughout the building.

 

Now, VLAN 50 is what will become the Voice VLAN for IP Phones. On the Procurve switches I have enabled the 'voice' command on that VLAN. But as the procuves will be sending tagged packets to the 5500's how do I configure the 5500's so that they honour that voice traffic? Or tell the 5500's that VLAN 50 is a voice VLAN?

 

I have tried working through the 5500 manual, and have tried the following config:

 

interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 4 23 25 30 35 40 49 to 50 60 66
port trunk permit vlan 97 99
voice vlan qos trust
loopback-detection enable
loopback-detection control enable
loopback-detection per-vlan enable
loopback-detection action shutdown
broadcast-suppression 30

 

And tried to add the following:  

 

voice vlan mode auto

voice vlan 50 enable

 

But I get the following message

 

In auto voice VLAN mode, voice VLAN can not be enabled on a Trunk or a Hybrid port that is in voice VLAN already.

 

Which would indicate that the port is already in a voice VLAN, but if I

 

dis voice vlan state

 

Maximum of Voice VLANs: 8
Current Voice VLANs: 0
Voice VLAN security mode: Normal
Voice VLAN aging time: 1440 minutes
Voice VLAN enabled port and its mode:
PORT VLAN MODE COS DSCP
--------------------------------------------------------------------

 

Which indicates there are no voice VLANS configured.. 

 

Any ideas anyone please? :o/

 

 EDIT:

 

Could it be as simple as 

 

undo voice vlan mode auto

voice vlan 50 enable

 

Which the switch seems to have accepted without complaining ...

 

7 REPLIES
NCGnet
Occasional Advisor

Re: How to configure Voice VLAN in new install

Hi all,

 

Have had a play with this although I do not know if this will work or is correct, perhaps someone could verify if this would work? VOIP / QOS isn't my area of expertise so any suggestions would be appreciated.

 

The IP Phones are not plugged directly into this switch as it is acting as the building core (2x A5500EI in an IRF). The handsets will be plugged into HP Procurve 2530 switches (VLAN 50) and they have the 'voice' command enabled on that VLAN. They are then connected back to the core via fibre. So I am thinking this config on the core switch would just honor that?

 

sys

 

#
undo voice vlan security enable
#

 

#
interface GigabitEthernet1/0/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 4 23 25 30 35 40 49 to 50 60 66
port trunk permit vlan 97 99
undo voice vlan mode auto
voice vlan qos trust
voice vlan 50 enable
loopback-detection enable
loopback-detection control enable
loopback-detection per-vlan enable
loopback-detection action shutdown
broadcast-suppression 30
#

 

spgsitsupport
Frequent Advisor

Re: How to configure Voice VLAN in new install

Anybody could confirm that this is correct way of doing it?

I have exactly the same setup (5900 core with 2920 as satellites that IP Phones connect to)

CORE (HPE 5900 Comware) <-- Edge (HP 2920 Procurve) <-- IPPhone

And while I can do it on single links, I can NOT do it on aggregated connections: (in addition members can NOT have it configured either)

[HPE5900-SR1-Bridge-Aggregation1]undo voice-vlan mode auto
Operation failed.

So what am I to do with such conenctions?

HP just states:

Voice VLAN cannot be enabled on a port with LACP enabled

But I have Static aggregation & same error is presented...

spgsitsupport
Frequent Advisor

Re: How to configure Voice VLAN in new install

Anybody at all?

 Do I need at all any voice vlan settings on downlink ports? ie

 undo voice-vlan mode auto
 voice-vlan 21 enable

Seb

Duncan Phillips
Occasional Advisor

Re: How to configure Voice VLAN in new install

On our network we have the voice vlan tagged on the links between switches and voice-vlan xxx enable on the edge ports. We have found you can't have the voice vlan tagged and voice-vlan xxx enable on the same port

spgsitsupport
Frequent Advisor

Re: How to configure Voice VLAN in new install

Well, on Comware switch

voice-vlan xx enable

is pretty much the only command that does enable the voice vlan. And ofcours any port that is used in voice tramsmission will have vlan xx tagged, so I see no logic in this statement:

 "can't have the voice vlan tagged and voice-vlan xxx enable on the same port" 

But the question is the same, do I even need voice-vlan xx enable on downlinks (I assume it does not, but could not find any definitive answer anywhere)

vlan 21
 description VOIP

interface Ten-GigabitEthernet1/0/4
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 7 10 21 99 
 voice-vlan qos trust
 undo voice-vlan mode auto
 voice-vlan 21 enable
 qos trust dscp

Seb

Duncan Phillips
Occasional Advisor

Re: How to configure Voice VLAN in new install

Our configuration varies as we use different VoIP vlans depending on which building but goes along the lines

vlan 864
 description VoIP-864

# Edge facing ports are configured

interface GigabitEthernet1/0/1
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan xxx untagged
 port hybrid pvid vlan xxx
 voice-vlan 864 enable
 loopback-detection enable vlan 1 to 4094
 loopback-detection action block

# Uplinks towards our core

interface Ten-GigabitEthernet1/0/50
 port link-type hybrid
 port hybrid vlan xxx 864 tagged
 port hybrid vlan 1 untagged
 qos trust dscp
 port link-aggregation group 50
 dhcp snooping trust

Trying to add the command "port hybrid vlan 864 tagged" to one of the outlet facing ports which already has "voice-vlan 864 enable" gives an error message "In auto voice VLAN mode, a Trunk or Hybrid port can not be added to or be delete from voice VLAN manually when voice VLAN is enabled on it."

Similarly try to issue the command "voice-vlan 864 enable" on a port that already has vlan 864 as a tagged vlan gives the same error message. This is on a stack of HPE 5130's running SwVers: 7.1.045_Release_3115P05. This was the same on the HPE 5120 switches.

Perhaps things are different on ports that are configured as "port link-mode bridge" and "port link-type trunk" but I can only comment when the ports are configured with "port link-type hybrid" as that is how we configure things.

Duncan

spgsitsupport
Frequent Advisor

Re: How to configure Voice VLAN in new install

To get rid of the error one must first do

undo voice-vlan mode auto

but I still am not convinced that it is needed on core downlink (or that it does actually help/disturb/do anything)

I see your Edge switches run Comware, where I have Procurve 2920 on the Edge (so for me only the Core itself runs Comware HPE 5900)