Comware Based
Showing results for 
Search instead for 
Did you mean: 

Re: How to enable SSH on H3C S5800?

Go to solution

How to enable SSH on H3C S5800?

Hello folks,


I am trying to figure out how to enable a new user for SSH access.



<H3C> system-view

[H3C] interface vlan-interface 1

[H3C-Vlan-interface1] ip address

[H3C-Vlan-interface1] quit


# This command was not available!

[H3C] rsa local-key-pair create


# Set the authentication mode for the user interfaces to AAA.

[H3C] user-interface vty 0 4

[H3C-ui-vty0-4] authentication-mode scheme


# Enable the user interfaces to support SSH.

[H3C-ui-vty0-4] protocol inbound ssh

[H3C-ui-vty0-4] quit


# Create local client “client001”, and set the authentication password to “abc”, protocol type to SSH, and command privilege level to 3 for the client.

[H3C] local-user sshuser

[H3C-luser-client001] password simple abc

[H3C-luser-client001] service-type ssh level 3

[H3C-luser-client001] quit


# Specify the authentication method of user client001 as password  This command was not available.

[H3C] ssh user sshuser authentication-type password

# Instead I ran this command available.

[H3C] ssh user sshuser service-type all authentication-type password


I can ping it but connection is refused.


I am following this article example.


Anyone have a suggestion?

Trusted Contributor

Re: How to enable SSH on H3C S5800?

You should add:



ssh server enable

public local create rsa


local-user sshuser

  password simple abc

  service-type ssh

  authorization-attribute level 3



That will solve your issue.




H3CSE, MASE Network Infrastructure [2011], Switzerland

Re: How to enable SSH on H3C S5800?

Thank you very much!  That worked!!