Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

In-line Hybrid VoiceVLAN Registration Problems

SquareWorld
Occasional Visitor

In-line Hybrid VoiceVLAN Registration Problems

I'm trying to program my 3COM 4500G switches to automatically put my VoIP phones on VLAN 22; while putting the PC (connected via the same Ethernet cable; in-line) on VLAN 1.



What I've tried:

1) Configuring 'voice vlan 22 enable' globally and on the interface.



2) Putting phone on Access VLAN 22 and then moving the phone to a hybrid port.



3) Enabling GVRP (trunking all vlans)



Here is my consolidated config:



voice vlan 22 enable

voice vlan mac-address 0004-f200-0000 mask ffff-ff00-0000 description Avaya01

voice vlan mac-address 001b-4f00-0000 mask ffff-ff00-0000 description Avaya Phone 01

#

gvrp

#

vlan 1

igmp-snooping enable

#

vlan 22

#

interface Vlan-interface1

ip address 192.168.0.240 255.255.255.0

#

interface GigabitEthernet1/0/1

port link-type hybrid

port hybrid vlan 22 tagged

port hybrid vlan 1 untagged

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/47

port link-type trunk

port trunk permit vlan all

broadcast-suppression pps 3000

undo jumboframe enable

description Uplink to Server Switch

stp edged-port enable

gvrp

#

ip route-static 0.0.0.0 0.0.0.0 192.168.0.1



2 REPLIES
SquareWorld
Occasional Visitor

Re: In-line Hybrid VoiceVLAN Registration Problems

UPDATE:

Here is a manual workaround I've discovered. (But it's unpractical):



-Manually configured Port 1 as an Access Port on VLAN 22.

-Let the phone re-boot, and detect the VoIP server.

-Must make a phone call on the new VLAN.

-In-line PC get's an IP address from VLAN 22's DHCP (this is unacceptable.)

-Manually change the port from Access to Hybrid, PVID 1, 1 untagged, 22 tagged.

-Finally, Reboot the PC and it get's an IP address from VLAN 1.

-This configuration works, until the trunk carrying the GVRP trunk information get's severed; afterwhich all ports 'forget' and manual configuration steps need to be repeated per port.



(We also have some 'Dell PowerConnect 3324' - they picked up the hybrid config without a hitch. Only my new 4500G's have given me troubles.)

Shirin
Frequent Advisor

Re: In-line Hybrid VoiceVLAN Registration Problems

Why are you using gvrp? It is not a must and not at all required for your voice config to work.

Also, it will only work on trunk port and only for passing vlans on these ports.



Also, unless the pc behind he phone is using authentication such as dot1x anyone just can bring a PC and connect it into his desk phone. That is not probably what you want!





VLAN 22

voice vlan 22 enable

voice vlan mac-address 0004-f200-0000 mask ffff-ff00-0000 description Avaya01

voice vlan mac-address 001b-4f00-0000 mask ffff-ff00-0000 description Avaya Phone 01



# Define the IP address of DHCP server

dhcp-server 1 ip xx.xx.xx.xx



# Define a vlan interface for vlan 22

interface Vlan-interface22

# Configure an ip address for interface vlan 22

ip address ip_address sub_net

# Configure a dhcp relay(udp ports 67 and 68) for the interface vlan 22 if there is no DHCP server in this VLAN

dhcp-server 1



interface GigabitEthernet1/0/1

# Setup for Hybrid ports

port link-type hybrid

# Setup for voice vlan

voice vlan enable



Because you are using your Data vlan as VID1 that is all what you require because VID1 is per defalt the PVID.

This message was edited by Shirin on 3-15-09 @ 2:28 AM