Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Link-aggregation and ESXi5 issues with A5120

robyaps
Advisor

Link-aggregation and ESXi5 issues with A5120

Hi, we have problems configuring ESXi with IRF stack.

 

Example:

   - 4 A5120 in IRF stack

   - ESXi 5.5 with 4 links with ip based hash algo

 

we want these 4 links are being used as the default VLAN for the connesisoni ESXi LAN segment, and for any other VLANs configured to separate the traffic at the Port Group ESXI (vMotion, etc.).

 

Starting from the default IRF configuration, the PVID to this VLAN is 1 (default). Aggregating 4 ports as described in the documents (port link-type trunk), leaving ESXi without VLAN configuration on the VM port group for the LAN do not works.

 

interface bridge-aggregation 21
description LAG esxi11 lan
port link-type trunk
port trunk permit vlan 1
stp disable

interface GigabitEthernet 1/0/39
port link-type trunk
port trunk permit vlan 1
port link-aggregation group 21
interface GigabitEthernet 4/0/39
port link-type trunk
port trunk permit vlan 1
port link-aggregation group 21

 

Instead we works by configuring as "port link-type access" and leaving everything not tagged

 

interface bridge-aggregation 21

description LAG esxi11 lan

interface GigabitEthernet 1/0/39
port link-aggregation group 21
interface GigabitEthernet 4/0/39
port link-aggregation group 21
interface Bridge-Aggregation 21
port link-type access
port access vlan 1

 

but we have 2 problems:

 

1. when a member of the IRF is disconnected, some VMs do not communicate on the network (probably port sense problems or unsupporte port-tyoe access mode issue...), all works again and "immediately" as soon as we attach power supply, also if member switch is only on in this phase.

 

2. Probably with this configuration, we can not use VLAN in port group

 

What is wrong in the configuration with link-type trunk ?

 

Thank you in advance

 

P.S. This post has been splitted off from other thread in Comware-Based, and edited its subject. - HP Forum Moderator

1 REPLY
robyaps
Advisor

Re: Link-aggregation and ESXi5 issues with A5120

Ok. We resolved trunk mode issue with this config:

 

interface bridge-aggregation 21
description LAG esxi11 lan
port link-type trunk
port trunk pvid vlan 1

port trunk permit vlan 1

 

Probbaly we erroneously assagned default VLAN to other than default VLAN 1...

So we resolved also issue 2 as we can add permitted VLAN on this trunk (ESXi vMotion, ...).

 

 

Can someone help on issue 1 ? could be related to the configuration with link-type access? not supported ?

 

Thank you