Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Link aggregation

Flegel
Occasional Visitor

Link aggregation

Hello 3COM community!



I try to setup static(dynamic) link aggregation between 4500(3CR17562-91)and 4500G(3CR17761-91)



We used the following Manuals - 3Com_Switch_4500G_Config_Guide_V05.02.00 and 3Com_Stackable_Switch_Advanced_Config_Guide



Dynamic link-aggregation example

4500 config:

#

sysname 4500

#

undo password-control aging enable

undo password-control length enable

undo password-control history enable

password-control login-attempt 3 exceed lock-time 120

#

local-server nas-ip 127.0.0.1 key 3com

#

igmp-snooping enable

#

radius scheme system

#

domain system

#

local-user admin

service-type ssh telnet terminal

level 3

local-user manager

password simple manager

service-type ssh telnet terminal

level 2

local-user monitor

password simple monitor

service-type ssh telnet terminal

level 1

#

stp disable

#

acl number 4999

rule 0 deny dest 0000-0000-0000 ffff-ffff-ffff

#

vlan 1

igmp-snooping enable

#

vlan 100

#

interface Vlan-interface1

ip address dhcp-alloc

#

interface Vlan-interface100

ip address 192.168.0.4 255.255.255.0

...

...

...

#

interface GigabitEthernet1/0/49

port link-type trunk

port trunk permit vlan 1 100

lacp enable

#

interface GigabitEthernet1/0/50

port link-type trunk

port trunk permit vlan 1 100

lacp enable



4500G example:

#

version 3Com OS V5.02.00s168p01,

#

sysname 4500G

#

domain default enable system

#

telnet server enable

#

undo ip ttl-expires

#

undo cluster enable

#

igmp-snooping

#

vlan 1

igmp-snooping enable

#

vlan 100

#

radius scheme system

server-type extended

primary authentication 127.0.0.1 1645

primary accounting 127.0.0.1 1646

user-name-format without-domain

#

domain system

access-limit disable

state active

idle-cut disable

self-service-url disable

#

user-group system

#

local-user admin

authorization-attribute level 3

service-type telnet terminal

local-user manager

password simple manager

authorization-attribute level 2

service-type telnet terminal

local-user monitor

password simple monitor

authorization-attribute level 1

service-type telnet terminal

#

stp disable

#

interface Bridge-Aggregation1

link-aggregation mode dynamic

#

interface NULL0

#

interface Vlan-interface1

ip address dhcp-alloc

#

interface Vlan-interface100

ip address 192.168.0.3 255.255.255.0

#

interface GigabitEthernet1/0/23

port link-type trunk

port trunk permit vlan 1 100

broadcast-suppression pps 3000

undo jumboframe enable

port link-aggregation group 1

#

interface GigabitEthernet1/0/24

port link-type trunk

port trunk permit vlan 1 100

broadcast-suppression pps 3000

undo jumboframe enable

port link-aggregation group 1



In this case 4500 cannot ping 4500G. Whats the problem ?



Logs:



*4500G

Aggregation Interface: Bridge-Aggregation1

Aggregation Mode: Dynamic

Loadsharing Type: Shar

System ID: 0x8000, 001a-c14b-f300

Local:

Port Status Priority Oper-Key Flag

--------------------------------------------------------------------------------

GE1/0/23 U 32768 1 {A}

GE1/0/24 U 32768 1 {A}

Remote:

Actor Partner Priority Oper-Key SystemID Flag

--------------------------------------------------------------------------------

GE1/0/23 49 32768 1 0x8000, 001e-c188-b8c0 {ACEFG}

GE1/0/24 50 32768 1 0x8000, 001e-c188-b8c0 {ACEFG}



*4500

Aggregation ID: 1, AggregationType: Dynamic, Loadsharing Type: NonS

Aggregation Description:

System ID: 0x8000, 001e-c188-b8c0

Port Status: S -- Selected, U -- Unselected

Local:

Port Status Priority Key Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/50 S 32768 1 {ACDEFG}



Remote:

Actor Partner Priority Key SystemID Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/50 0 32768 0 0x8000,0000-0000-0000 {DEF}

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Flags: A -- LACP_Activity, B -- LACP_timeout, C -- Aggregation,

D -- Synchronization, E -- Collecting, F -- Distributing,

G -- Defaulted, H -- Expired



Aggregation ID: 2, AggregationType: Dynamic, Loadsharing Type: NonS

Aggregation Description:

System ID: 0x8000, 001e-c188-b8c0

Port Status: S -- Selected, U -- Unselected

Local:

Port Status Priority Key Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/49 S 32768 1 {ACDEFG}



Remote:

Actor Partner Priority Key SystemID Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/49 0 32768 0 0x8000,0000-0000-0000 {DEF}

5 REPLIES
richardkok
Frequent Advisor

Re: Link aggregation

I would configure LACP on both switches or configure it manually on both switches.. Not lacp one one and manual on the other.

For manual dont forget the "link-aggregation group 1 mode manual" command in global mode. Futher use "speed 1000" and "duplex full" on the interfaces. Make sure you have no cables connected while configuring this.



regards

r.

Flegel
Occasional Visitor

Re: Link aggregation

Hello richardkok !



Thanks for your replay.



As can be seen from config examples dynamic linkaggregation was implemented. I try to setup speed 1000 and duplex full on both switches - no result.

When links up i see next messages in console log:



4500G

%May 6 05:05:02:76 2000 4500G LLDP/2/CREREM:Port GigabitEthernet1/0/23 (IfIndex 9437206):Created new neighbor, chassis ID: 001a-c14b-f300, port ID: GigabitEthernet1/0/24.

%May 6 05:05:03:83 2000 4500G LLDP/2/CREREM:Port GigabitEthernet1/0/24 (IfIndex 9437207):Created new neighbor, chassis ID: 001a-c14b-f300, port ID: GigabitEthernet1/0/23.



4500

#Apr 4 17:09:52:280 2000 4500 L2INF/2/PORT LINK STATUS CHANGE:- 1 -

Trap 1.3.6.1.6.3.1.1.5.4(linkUp): portIndex is 4228017, ifAdminStatus is 1, ifOperStatus is 1



#Apr 4 17:09:52:484 2000 4500 IFNET/5/TRAP:- 1 -1.3.6.1.6.3.1.1.5.4(linkUp) Interface 31 is Up

#Apr 4 17:09:52:605 2000 4500 LAGG/2/AggPortRecoverActive:- 1 -Trap 1.3.6.1.4.1.43.45.1.5.25.25.2.2(hwAggPortInactiveNotification): TrapIndex 2 Aggregation Group 2: port member GigabitEthernet1/0/50 is now ACTIVE!

%Apr 4 17:09:52:874 2000 4500 L2INF/5/PORT LINK STATUS CHANGE:- 1 -

GigabitEthernet1/0/50 is UP



%Apr 4 17:09:52:994 2000 4500 L2INF/5/VLANIF LINK STATUS CHANGE:- 1 -

Vlan-interface1 is UP



%Apr 4 17:09:53:114 2000 4500 IFNET/5/UPDOWN:- 1 -Line protocol on the interface Vlan-interface1 is UP



#Apr 4 17:09:54:842 2000 4500 L2INF/2/PORT LINK STATUS CHANGE:- 1 -

Trap 1.3.6.1.6.3.1.1.5.4(linkUp): portIndex is 4228009, ifAdminStatus is 1, ifOperStatus is 1



#Apr 4 17:09:55:045 2000 4500 LAGG/2/AggPortRecoverActive:- 1 -Trap 1.3.6.1.4.1.43.45.1.5.25.25.2.2(hwAggPortInactiveNotification): TrapIndex 1 Aggregation Group 1: port member GigabitEthernet1/0/49 is now ACTIVE!

%Apr 4 17:09:55:315 2000 4500 L2INF/5/PORT LINK STATUS CHANGE:- 1 -

GigabitEthernet1/0/49 is UP



%Apr 4 17:09:55:434 2000 4500 LAGG/3/PartnerNoLacp:- 1 -LACP is not enabled on the remote end of port GigabitEthernet1/0/50.

%Apr 4 17:09:57:195 2000 4500 LAGG/3/PartnerNoLacp:- 1 -LACP is not enabled on the remote end of port GigabitEthernet1/0/49.



LACP is not enabled on 4500G switch. I am at a loss :quest:

richardkok
Frequent Advisor

Re: Link aggregation

That is exactly the problem. You have configured LACP on your 4500 switch but you have NON-LACP on your 4500G. That is why you get the messages like :



%Apr 4 17:09:55:434 2000 4500 LAGG/3/PartnerNoLacp:- 1 -LACP is not enabled on the remote end of port GigabitEthernet1/0/50.

%Apr 4 17:09:57:195 2000 4500 LAGG/3/PartnerNoLacp:- 1 -LACP is not enabled on the remote end of port GigabitEthernet1/0/49.



You should enable LACP on the 4500G as well.. OR.... config both end as NON-LACP... thus manual aggregation



regards

r.

Flegel
Occasional Visitor

Re: Link aggregation

Text from 4500G Release notes:



2.2.1. Link Aggregation – LACP (IEEE 802.3ad)

Dynamic LACP has been removed. LACP is only supported with static link-aggregation groups. There is more information on this in the “Chapter 4- Upgrading Software†, sections Dynamic LACP Aggregated Links and “Chapter 6- Converting dynamic aggregated links to static aggregated links†.

and...

4.2. Dynamic LACP Aggregated Links

Dynamic LACP (IEEE 802.3ad) has been removed from V5.01.03. LACP (IEEE 802.3ad) can be used with static aggregated links. If dynamic links are configured, convert them to static aggregated links before updating to V5.01.03. This link to 3KB Document ID: 3KB21594, alias “Chapter 6- Converting dynamic aggregated links to static aggregated links†provides information on how to determine if dynamic link aggregation groups are configured and how to convert a dynamic link aggregation group to a static link aggregation group.



it seems it is not possible...

This message was edited by Flegel on 5-25-09 @ 8:36 AM
Flegel
Occasional Visitor

Re: Link aggregation

Ok, well...

I try static link aggregation mode. No positive results :mad:



Small quota from Advanced config guide for 4500:



1) In manual aggregation mode # Create manual aggregation group 1. system-view link-aggregation group 1 mode manual # Add Ethernet 1/0/1 through Ethernet 1/0/3 to aggregation group 1. interface Ethernet1/0/1 port link-aggregation group 1 quit interface Ethernet1/0/2 port link-aggregation group 1 quit interface Ethernet1/0/3 port link-aggregation group 1 2) In static LACP aggregation mode # Create static aggregation group 1. system-view link-aggregation group 1 mode static







No sense to try "static LACP aggregation mode" because LACP was removed from 4500G



Example with mode manual(static) with no result.



4500:

#

interface GigabitEthernet1/0/49

port link-type trunk

port trunk permit vlan 1 100

port link-aggregation group 1

#

interface GigabitEthernet1/0/50

port link-type trunk

port trunk permit vlan 1 100

port link-aggregation group 1

#



display link-aggregation summary



Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor ID: 0x8000, 001e-c188-b8c0



AL AL Partner ID Select Unselect Share Master

ID Type Ports Ports Type Port

--------------------------------------------------------------------------------

1 M none 2 0 Shar GigabitEthernet1/0/49



display link-aggregation verbose

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Flags: A -- LACP_Activity, B -- LACP_timeout, C -- Aggregation,

D -- Synchronization, E -- Collecting, F -- Distributing,

G -- Defaulted, H -- Expired



Aggregation ID: 1, AggregationType: Manual, Loadsharing Type: Shar

Aggregation Description:

System ID: 0x8000, 001e-c188-b8c0

Port Status: S -- Selected, U -- Unselected

Local:

Port Status Priority Key Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/49 S 32768 1 {}

GigabitEthernet1/0/50 S 32768 1 {}



Remote:

Actor Partner Priority Key SystemID Flag

--------------------------------------------------------------------------------

GigabitEthernet1/0/49 0 0 0 0x0000,0000-0000-0000 {}

GigabitEthernet1/0/50 0 0 0 0x0000,0000-0000-0000 {}



4500G:

#

interface GigabitEthernet1/0/23

port link-type trunk

port trunk permit vlan 1 100

broadcast-suppression pps 3000

undo jumboframe enable

port link-aggregation group 1

#

interface GigabitEthernet1/0/24

port link-type trunk

port trunk permit vlan 1 100

broadcast-suppression pps 3000

undo jumboframe enable

port link-aggregation group 1

#



display link-aggregation member-port



Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

D -- Synchronization, E -- Collecting, F -- Distributing,

G -- Defaulted, H -- Expired



GigabitEthernet1/0/23:

Aggregation Interface: Bridge-Aggregation1

Port Number: 23

Oper-Key: 1



GigabitEthernet1/0/24:

Aggregation Interface: Bridge-Aggregation1

Port Number: 24

Oper-Key: 1



display link-aggregation summary



Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 001a-c14b-f300



AGG AGG Partner ID Select Unselect Share

Interface Mode Ports Ports Type

-------------------------------------------------------------------------------

BAGG1 S none 0 2 Shar



display link-aggregation verbose



Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Port Status: S -- Selected, U -- Unselected

Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,

D -- Synchronization, E -- Collecting, F -- Distributing,

G -- Defaulted, H -- Expired



Aggregation Interface: Bridge-Aggregation1

Aggregation Mode: Static

Loadsharing Type: Shar

Port Status Oper-Key

--------------------------------------------------------------------------------

GE1/0/23 U 1

GE1/0/24 U 1



In result::

--- 192.168.0.4 ping statistics ---

5 packet(s) transmitted

0 packet(s) received

100.00% packet loss



Latest firmware,latest manual...I'm confused.

Please, help!