cancel
Showing results for 
Search instead for 
Did you mean: 

MSR BGP Setup

Highlighted
agent4043
Visitor

MSR BGP Setup

Hi,

I'm new to Comware and have an MSR2004 I'm trying to setup with BGP. I could use a review of my config. I have two subnets to advertise and would like to split them into port based type-acces vlans 10 (ports 3-14) and vlan 20 (ports 15-26). vlan 10 is where my firewall lives. vlan 20 is my legacy phone system which we will eventually be consolidating into vlan1 but I still need it available for now.

IPs assigned by ISP were changed to internal addresses...

ISP:

IP: 192.168.1.1/30
AS: 1000

MSR:

IP: 192.168.1.2/30 on Gi 0/1
AS: 2000

vlan10 - 172.16.1.16/28 (hosts 17-30)

vlan20 - 10.1.1.0/28 (hosts 1-14)

-----------------------------
#I first setup my vlans with an IP on the vlan to serve as a gw for the access ports...

#
vlan 10
description Primary IP Block
interface vlan 10
ip address 172.16.1.30 28
#
port-group manual Primary
Group-member Gi 0/3 to gi 0/14
port link-type access
port access Vlan 10
#
vlan 20
description Secondary IP Block
interface vlan 20
ip address 10.1.1.1 28
#
port-group manual Secondary
Group-member Gi 0/15 to gi 0/26
port link-type access
port access Vlan 20

#BGP section:
bgp 2000
router-id 192.168.1.2
peer 192.168.1.1 as-number 1000
address-family ipv4 unicast
peer 192.168.1.1 enable

network 172.16.1.16 255.255.255.240
network 10.1.1.0 255.255.255.240

ip route-static 0.0.0.0 0 192.168.1.1 description ISP gw

-----------------------------

I appreciate any feedback! 

Thank you,

-eric

2 REPLIES
jmont0021
Frequent Visitor

Re: MSR BGP Setup

With Luck that should be enough..

agent4043
Visitor

Re: MSR BGP Setup

My luck is sketchy at best, but I appreciate the second set of eyes.  Thank you!