Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

MSR2003 DHCP/Inter-VLAN routing not working

 
SOLVED
Go to solution
LeviG
Occasional Collector

MSR2003 DHCP/Inter-VLAN routing not working

Hi,

Im currently working on "HPE Comware Software, Version 7.1.064, Release 0707P12"

I am trying to get a trunk port and NAT to work in a router-on-a-stick like configuration, however i couldn't get it configured in one go so i took a step back and i am now just configuring the vlans and DHCP server on each of them. I am however new to HPE syntax (always used cisco before this) and i can't even get this to work. This is my (shortened) config:

=====

version 7.1.064, Release 0707P12
#
sysname TWA-Router
#
nat address-group 1
port-range 1024 65535
address interface GigabitEthernet0/1
#
dhcp enable
dhcp server always-broadcast
#
dns proxy enable
#
password-recovery enable
#
vlan 1
name Default
#
vlan 2
name Internet
#
vlan 3
name Management
#
dhcp server ip-pool default
gateway-list 192.168.1.1
network 192.168.1.0 mask 255.255.255.0
address range 192.168.1.10 192.168.1.12
dns-list 151.248.48.1 151.248.49.1
#
dhcp server ip-pool internet
gateway-list 192.168.2.1
network 192.168.2.0 mask 255.255.255.0
address range 192.168.2.10 192.168.2.50
dns-list 151.248.48.1 151.248.49.1
#
dhcp server ip-pool management
gateway-list 192.168.3.1
network 192.168.3.0 mask 255.255.255.0
address range 192.168.3.10 192.168.3.50
dns-list 151.248.48.1 151.248.49.1
domain-name TWAntwerpenManagement
#
interface Vlan-interface1
ip address 192.168.1.1 255.255.255.0
dhcp server apply ip-pool default
#
interface Vlan-interface2
ip address 192.168.2.1 255.255.255.0
dhcp server apply ip-pool internet
#
interface Vlan-interface3
ip address 192.168.3.1 255.255.255.0
dhcp server apply ip-pool management
#
interface GigabitEthernet0/1
port link-mode route
ip address dhcp-alloc
undo dhcp select server
# ^ no clue what this does it was here by default
#
interface GigabitEthernet0/0
port link-mode bridge
port access vlan 3

=====

I tried making a trunk, hybrid port, access port, but whatever i do, my test devices don't get an IP.

What am i missing?

Thanks!

6 REPLIES 6
akg7
HPE Pro

Re: MSR2003 DHCP/Inter-VLAN routing not working

Hi,

It seems the issue is not clear here, the iss ue is with DHCP or Inter vlan routing?

Could you please explain more in detail?

Thanks!

I am an HPE Employee

Accept or Kudo

LeviG
Occasional Collector

Re: MSR2003 DHCP/Inter-VLAN routing not working

Hi,

Neither is working at the moment with this configuration, the clients don't get an ip through DHCP (ipconfig /renew on windows does not work) and even if the ip's (and default gateway) are set manually it is impossible to ping.

Thank you for your time.

LeviG
Occasional Collector

Re: MSR2003 DHCP/Inter-VLAN routing not working

Okay i really can't get this to work, this is the entire config should you need it:

#
 version 7.1.064, Release 0707P12
#
 sysname TWA-Router
#
nat address-group 1
 port-range 1024 65535
 address interface GigabitEthernet0/1
#
 dhcp enable
 dhcp server always-broadcast
#
 dns proxy enable
#
 password-recovery enable
#
vlan 1
 name Default
#
vlan 2
 name Internet
#
vlan 3
 name Management
#
dhcp server ip-pool default
 gateway-list 192.168.1.1
 network 192.168.1.0 mask 255.255.255.0
 address range 192.168.1.10 192.168.1.12
 dns-list 151.248.48.1 151.248.49.1
#
dhcp server ip-pool internet
 gateway-list 192.168.2.1
 network 192.168.2.0 mask 255.255.255.0
 address range 192.168.2.10 192.168.2.50
 dns-list 151.248.48.1 151.248.49.1
#
dhcp server ip-pool management
 gateway-list 192.168.3.1
 network 192.168.3.0 mask 255.255.255.0
 address range 192.168.3.10 192.168.3.50
 dns-list 151.248.48.1 151.248.49.1
 domain-name TWAntwerpenManagement
#
controller Cellular0/0
#
interface Aux0
#
interface NULL0
#
interface Vlan-interface1
 ip address 192.168.1.1 255.255.255.0
 dhcp server apply ip-pool default
#
interface Vlan-interface2
 dhcp server apply ip-pool internet
#
interface Vlan-interface3
 ip address 192.168.3.1 255.255.255.0
 dhcp server apply ip-pool management
#
interface GigabitEthernet0/1
 port link-mode route
 description Multiple_Line
 ip address dhcp-alloc
 tcp mss 1280
 nat outbound
 undo dhcp select server
#
interface GigabitEthernet0/0
 port link-mode bridge
 port access vlan 3
#
 scheduler logfile size 16
#
line class aux
 user-role network-admin
#
line class tty
 user-role network-operator
#
line class vty
 user-role network-operator
#
line aux 0
 user-role network-admin
#
line vty 0 63
 authentication-mode scheme
 user-role network-operator
#
 password-control enable
 undo password-control aging enable
 undo password-control history enable
 password-control length 6
 password-control login-attempt 3 exceed lock-time 10
 password-control update-interval 0
 password-control login idle-time 0
 password-control complexity user-name check
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
local-user admin class manage
 service-type telnet http
 authorization-attribute user-role network-admin
#
cwmp
 cwmp enable
#
 ip http enable
#
return
Sendurrr
Occasional Visitor

Re: MSR2003 DHCP/Inter-VLAN routing not working

Were you perhaps able to fix this issue? i got exactly the same problem with my MSR2003 ..... Config is similar... If you could post your config when it is working now.... would be great

Highlighted
LeviG
Occasional Collector
Solution

Re: MSR2003 DHCP/Inter-VLAN routing not working

Hi,

Yes my issue was solved, i got in touch with HPE support and they were able to tell me that the vlan interfaces are not supported on MSR2003 instead you need to use subinterfaces and assign those to the VLAN's. Then everything started working.

Sendurrr
Occasional Visitor

Re: MSR2003 DHCP/Inter-VLAN routing not working

Thanks!! Got it now working also