Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Microsoft NLB Cluster in Multicast Mode on vmware hosts

BMNetworks
Occasional Advisor

Microsoft NLB Cluster in Multicast Mode on vmware hosts

Hello,

 

I have a problem with a virtual microsoft terminal server cluster in multicast mode on vmware esx hosts on a 5500 switch.

I added the virtual mutlicast mac address to all switchports, where esx hosts are connected and added a static arp entry with the cluster ip to the multicast ip address.

User reportet, the connection to the ts cluster does not always work.

 

I have done this configuration on the 5500 switch.

undo arp check enable
arp static 172.12.1.200 03af-0987-00aa

mac-address multicast 03af-0987-00aa vlan 1 (on every esx host port)

 

Thanks and regards

3 REPLIES
manuel.bitzi
Trusted Contributor

Re: Microsoft NLB Cluster in Multicast Mode on vmware hosts

Hi BM

 

It should work. I use this setup on multiple costumer sites.

 

SW 5.2 R2210 or later is required. Please check.

 

br

Manuel

H3CSE, MASE Network Infrastructure [2011], Switzerland

Re: Microsoft NLB Cluster in Multicast Mode on vmware hosts

How about on an 4 node cluster of A5800-48G-PoE+, running  Version 5.20, Release 1211P09

We have just switched over core routing from E5400 to this, and are experiencing similar problems with a small percentage of users who cannot get connected to the NLB address.

Identical config, undo arp check enable, and the NLB mcast ethernet address hardcoded to the appropriate nics.

 

thanks,

Johan

Thunderbird School of Global Management

www.thunderbird.edu

 

Wouter Ooms
Occasional Advisor

Re: Microsoft NLB Cluster in Multicast Mode on vmware hosts

I know this thread is quite old, but for what it's worth: I was able to fix this by issuing these commands:

 

 undo arp check enable 

 mac-address multicast [MAC of VIP]  interface GigabitEthernet X/0/Y  to GigabitEthernet X/0/Y  [interfaces of the physical servers of the cluster] vlan [VLAN of cluster]  
 
 I also created a static ARP entry in the swicthes ARP table, but things only started working after I REMOVED this static entry. So that's probably why it doesn't work for BMNetworks: you have to remove the static arp entry you created, you only need the virtual multicast mac.