Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast L2 Forwarding on Comware 7 5900AF

spyd4man
Occasional Contributor

Multicast L2 Forwarding on Comware 7 5900AF

Hi everyone,

 

Just wondered if there are any special multicast configuration requirements in comware 7 for standard access switch l2 forwarding of multicast frames?

 

I have a layer3 device in our enterprise (5800 Comware 5) that is configured for PIM-DM and IGMP on the VLAN interface which goes toward the layer-2 5900 comware 7 switch.

 

On the 5800 I can confirm that:

- I see the Multicast Join from the host on the 5900 access switch

- I see PIM-DM populating the multicast routing table to send that multicast traffic toward the layer2 5900, upstream and downstream VLANs are correct.

 

All looks good on the layer-3 5800, however the multicast traffic does not appear on the end receiving host (off the layer-2 5900).

 

I assumed the 5900 (comware7) would act as a dumb layer-2 switch in that it will forward the multicast frame out of all ports on the VLAN (except the one it was received on).  However this does not appear to work.

 

I have not enabled ANY multicast routing or special multicast commands on the 5900 (Its a layer-2 unit doing pass through for host connectivity).  However does comware 7 need "igmp snooping" enabled globally and on the VLAN to even forward multicast frames at layer-2?

 

I am experienced with Comware 3 and 5 but 7 is new to me.  Any ideas are appreciated.  Unfortunatly I have no test 5900 comware 7 in the lab, and the production has to go through change control to amend, so I need to prove theory first before "tinkering".

1 REPLY
Peter_Debruyne
Honored Contributor

Re: Multicast L2 Forwarding on Comware 7 5900AF

Hi,

 

I has been a year ago since I did multicast on the 5900, (was still on one of those initial comware7 releases, I believe R2208), but at that time, the default switch was flooding all multicast traffic and I had to explicitly configure it for igmp-snooping and filtering of unknown multicast (as expected), so I hope they did not change this and something else is causing this effect...

 

These were the commands used for the L2 traffic IGMP filtering:

 

igmp-snooping
#
vlan 11
 igmp-snooping enable
 igmp-snooping drop-unknown
 igmp-snooping version 2
#

 

Keep us posted !