Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Multiport not working with NLB cluster

LionLantech
Advisor

Multiport not working with NLB cluster

Hi all,

in our network we have this situation: we are using a cluster of 2 virtual NLB servers hosted each on an ESX server and configured in unicast mode. To limit broadcast traffic, we would like to fix VIP cluster mac-address on each interface where these server are connected to.
In our case, servers are connected to a switch HP 7506 (switch "B"), which is directly connect to the core switch (anoher HP 7506, switch "A") using bridge-aggregation 1 of switch B to bridge-aggregation 5 of switch A. Each server is using 3 ports of switch B.
We have configured multiport, fixing VIP mac-address on the correct 6 interfaces of switch B:

mac-address multiport xxxx-xxxx-xxxx interface GigabitEthernet a/a/a/a VLAN 1

Then, switch A forwards packets heading to NLB cluster just to switch B, as we have configured on switch A that VIP cluster mac-address is behind its interface bridge-aggregation 5:

interface Bridge-Aggregation5

...

mac-address static xxxx-xxxx-xxxx vlan 1


After this configuration, we can reach by icmp-ping VIP IP address just from switch B and another one directly connect to switch B, but not from any else switch (as switch A) or client (also clients connected to switch B). There is no routing between switch A or B and NLB server as they belong all to the same VLAN 1.
Without multiport configuration, VIP IP address is reachable from everywhere in the network.

Whats' wrong with multiport configuration?

Thanks in advance to all

2 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Multiport not working with NLB cluster

Does the failed ping resolve a MAC address?

LionLantech
Advisor

Re: Multiport not working with NLB cluster

Yes it does