Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Performance issue on 5510 IRF

soze
Occasional Contributor

Performance issue on 5510 IRF

Hi all,

we have 4 5510 switches in IRF mode ring topology (recently installed) and we're experiencing serious issues in bandwidht between the IRF stack itself and other subnets the switches are uplinked to. Before having this configuration we had two 5500 in IRF with no particular configuration and everithyng worked a charme.

STP is actually disabled as the old configuration were too, and it was designed as an intranodal network for an HPC cluster.

Long story short, some nodes in the uplink subnet works correctly with performance around 990 MBps (tested with qperf), whilst other are lacking and lagging and qperf result in a poor output (bounch of KBps). Everything seems to change as the STP topology on the uplink switches change, but I'm relatively new to networking so I'm unable to understand what's going on and if that could be a possible clue. 
To add some complexity at the case, in some circumstances the nodes acts asymmetrically with good performance from node A to node B but not from node B to node A.

This is the current configuration, any suggestion is very appreciated.

<HPE>dis current-configuration
#
 version 7.1.045, Release 1122P02
#
 sysname HPE
#
 clock timezone Lisbon add 00:00:00
 clock protocol none
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 32
 irf member 2 priority 31
 irf member 3 priority 30
 irf member 4 priority 29
#
 mac-address mac-roaming enable
#
 password-recovery enable
#
vlan 1
#
vlan 105
 name super_vlan
 description super_vlan
#
irf-port 1/1
 port group interface Ten-GigabitEthernet1/0/49
 port group interface Ten-GigabitEthernet1/0/50
#
irf-port 1/2
 port group interface Ten-GigabitEthernet1/0/51
 port group interface Ten-GigabitEthernet1/0/52
#
irf-port 2/1
 port group interface Ten-GigabitEthernet2/0/49
 port group interface Ten-GigabitEthernet2/0/50
#
irf-port 2/2
 port group interface Ten-GigabitEthernet2/0/51
 port group interface Ten-GigabitEthernet2/0/52
#
irf-port 3/1
 port group interface Ten-GigabitEthernet3/0/49
 port group interface Ten-GigabitEthernet3/0/50
#
irf-port 3/2
 port group interface Ten-GigabitEthernet3/0/51
 port group interface Ten-GigabitEthernet3/0/52
#
irf-port 4/1
 port group interface Ten-GigabitEthernet4/0/49
 port group interface Ten-GigabitEthernet4/0/50
#
irf-port 4/2
 port group interface Ten-GigabitEthernet4/0/51
 port group interface Ten-GigabitEthernet4/0/52
#
 stp port-log instance 0 to 4094
 stp port-log vlan 1 to 4094
 stp mode pvst
#
interface Bridge-Aggregation1
 port access vlan 105
 link-aggregation mode dynamic
#
interface Bridge-Aggregation2
 port access vlan 105
 link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface1
 ip address 10.128.101.1 255.255.0.0
#
interface GigabitEthernet1/0/1
 port link-mode bridge
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 description Manager1
 port access vlan 105
#
interface GigabitEthernet1/0/3
 port link-mode bridge
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 description Manager2
 port access vlan 105
#
interface GigabitEthernet1/0/5
 port link-mode bridge
#
interface GigabitEthernet1/0/6
 port link-mode bridge
#
interface GigabitEthernet1/0/7
 port link-mode bridge
#
interface GigabitEthernet1/0/8
 port link-mode bridge
#
interface GigabitEthernet1/0/9
 port link-mode bridge
#
interface GigabitEthernet1/0/10
 port link-mode bridge
#
interface GigabitEthernet1/0/11
 port link-mode bridge
#
interface GigabitEthernet1/0/12
 port link-mode bridge
#
interface GigabitEthernet1/0/13
 port link-mode bridge
#
interface GigabitEthernet1/0/14
 port link-mode bridge
#
interface GigabitEthernet1/0/15
 port link-mode bridge
#
interface GigabitEthernet1/0/16
 port link-mode bridge
#
interface GigabitEthernet1/0/17
 port link-mode bridge
#
interface GigabitEthernet1/0/18
 port link-mode bridge
#
interface GigabitEthernet1/0/19
 port link-mode bridge
#
interface GigabitEthernet1/0/20
 port link-mode bridge
#
interface GigabitEthernet1/0/21
 port link-mode bridge
#
interface GigabitEthernet1/0/22
 port link-mode bridge
#
interface GigabitEthernet1/0/23
 port link-mode bridge
#
interface GigabitEthernet1/0/24
 port link-mode bridge
#
interface GigabitEthernet1/0/25
 port link-mode bridge
#
interface GigabitEthernet1/0/26
 port link-mode bridge
#
interface GigabitEthernet1/0/27
 port link-mode bridge
#
interface GigabitEthernet1/0/28
 port link-mode bridge
#
interface GigabitEthernet1/0/29
 port link-mode bridge
#
interface GigabitEthernet1/0/30
 port link-mode bridge
#
interface GigabitEthernet1/0/31
 port link-mode bridge
#
interface GigabitEthernet1/0/32
 port link-mode bridge
#
interface GigabitEthernet1/0/33
 port link-mode bridge
#
interface GigabitEthernet1/0/34
 port link-mode bridge
#
interface GigabitEthernet1/0/35
 port link-mode bridge
#
interface GigabitEthernet1/0/36
 port link-mode bridge
#
interface GigabitEthernet1/0/37
 port link-mode bridge
#
interface GigabitEthernet1/0/38
 port link-mode bridge
#
interface GigabitEthernet1/0/39
 port link-mode bridge
#
interface GigabitEthernet1/0/40
 port link-mode bridge
#
interface GigabitEthernet1/0/41
 port link-mode bridge
#
interface GigabitEthernet1/0/42
 port link-mode bridge
#
interface GigabitEthernet1/0/43
 port link-mode bridge
#
interface GigabitEthernet1/0/44
 port link-mode bridge
#
interface GigabitEthernet1/0/45
 port link-mode bridge
#
interface GigabitEthernet1/0/46
 port link-mode bridge
#
interface GigabitEthernet1/0/47
 port link-mode bridge
#
interface GigabitEthernet1/0/48
 port link-mode bridge
#
interface GigabitEthernet2/0/1
 port link-mode bridge
#
interface GigabitEthernet2/0/2
 port link-mode bridge
 description Manager1
 port access vlan 105
#
interface GigabitEthernet2/0/3
 port link-mode bridge
#
interface GigabitEthernet2/0/4
 port link-mode bridge
 description Manager2
 port access vlan 105
#
interface GigabitEthernet2/0/5
 port link-mode bridge
#
interface GigabitEthernet2/0/6
 port link-mode bridge
#
interface GigabitEthernet2/0/7
 port link-mode bridge
#
interface GigabitEthernet2/0/8
 port link-mode bridge
#
interface GigabitEthernet2/0/9
 port link-mode bridge
#
interface GigabitEthernet2/0/10
 port link-mode bridge
#
interface GigabitEthernet2/0/11
 port link-mode bridge
#
interface GigabitEthernet2/0/12
 port link-mode bridge
#
interface GigabitEthernet2/0/13
 port link-mode bridge
#
interface GigabitEthernet2/0/14
 port link-mode bridge
#
interface GigabitEthernet2/0/15
 port link-mode bridge
#
interface GigabitEthernet2/0/16
 port link-mode bridge
#
interface GigabitEthernet2/0/17
 port link-mode bridge
#
interface GigabitEthernet2/0/18
 port link-mode bridge
#
interface GigabitEthernet2/0/19
 port link-mode bridge
#
interface GigabitEthernet2/0/20
 port link-mode bridge
#
interface GigabitEthernet2/0/21
 port link-mode bridge
#
interface GigabitEthernet2/0/22
 port link-mode bridge
#
interface GigabitEthernet2/0/23
 port link-mode bridge
#
interface GigabitEthernet2/0/24
 port link-mode bridge
#
interface GigabitEthernet2/0/25
 port link-mode bridge
#
interface GigabitEthernet2/0/26
 port link-mode bridge
#
interface GigabitEthernet2/0/27
 port link-mode bridge
#
interface GigabitEthernet2/0/28
 port link-mode bridge
#
interface GigabitEthernet2/0/29
 port link-mode bridge
#
interface GigabitEthernet2/0/30
 port link-mode bridge
#
interface GigabitEthernet2/0/31
 port link-mode bridge
#
interface GigabitEthernet2/0/32
 port link-mode bridge
#
interface GigabitEthernet2/0/33
 port link-mode bridge
#
interface GigabitEthernet2/0/34
 port link-mode bridge
#
interface GigabitEthernet2/0/35
 port link-mode bridge
#
interface GigabitEthernet2/0/36
 port link-mode bridge
#
interface GigabitEthernet2/0/37
 port link-mode bridge
#
interface GigabitEthernet2/0/38
 port link-mode bridge
#
interface GigabitEthernet2/0/39
 port link-mode bridge
#
interface GigabitEthernet2/0/40
 port link-mode bridge
#
interface GigabitEthernet2/0/41
 port link-mode bridge
#
interface GigabitEthernet2/0/42
 port link-mode bridge
#
interface GigabitEthernet2/0/43
 port link-mode bridge
#
interface GigabitEthernet2/0/44
 port link-mode bridge
#
interface GigabitEthernet2/0/45
 port link-mode bridge
#
interface GigabitEthernet2/0/46
 port link-mode bridge
#
interface GigabitEthernet2/0/47
 port link-mode bridge
#
interface GigabitEthernet2/0/48
 port link-mode bridge
#
interface GigabitEthernet3/0/1
 port link-mode bridge
#
interface GigabitEthernet3/0/2
 port link-mode bridge
#
interface GigabitEthernet3/0/3
 port link-mode bridge
#
interface GigabitEthernet3/0/4
 port link-mode bridge
#
interface GigabitEthernet3/0/5
 port link-mode bridge
#
interface GigabitEthernet3/0/6
 port link-mode bridge
#
interface GigabitEthernet3/0/7
 port link-mode bridge
#
interface GigabitEthernet3/0/8
 port link-mode bridge
#
interface GigabitEthernet3/0/9
 port link-mode bridge
#
interface GigabitEthernet3/0/10
 port link-mode bridge
#
interface GigabitEthernet3/0/11
 port link-mode bridge
#
interface GigabitEthernet3/0/12
 port link-mode bridge
#
interface GigabitEthernet3/0/13
 port link-mode bridge
#
interface GigabitEthernet3/0/14
 port link-mode bridge
#
interface GigabitEthernet3/0/15
 port link-mode bridge
 description super_uplink
 port access vlan 105
 port link-aggregation group 1
#
interface GigabitEthernet3/0/16
 port link-mode bridge
 description super_uplink
 port access vlan 105
 port link-aggregation group 2
#
interface GigabitEthernet3/0/17
 port link-mode bridge
#
interface GigabitEthernet3/0/18
 port link-mode bridge
#
interface GigabitEthernet3/0/19
 port link-mode bridge
#
interface GigabitEthernet3/0/20
 port link-mode bridge
#
interface GigabitEthernet3/0/21
 port link-mode bridge
#
interface GigabitEthernet3/0/22
 port link-mode bridge
#
interface GigabitEthernet3/0/23
 port link-mode bridge
#
interface GigabitEthernet3/0/24
 port link-mode bridge
#
interface GigabitEthernet3/0/25
 port link-mode bridge
#
interface GigabitEthernet3/0/26
 port link-mode bridge
#
interface GigabitEthernet3/0/27
 port link-mode bridge
#
interface GigabitEthernet3/0/28
 port link-mode bridge
#
interface GigabitEthernet3/0/29
 port link-mode bridge
#
interface GigabitEthernet3/0/30
 port link-mode bridge
#
interface GigabitEthernet3/0/31
 port link-mode bridge
#
interface GigabitEthernet3/0/32
 port link-mode bridge
#
interface GigabitEthernet3/0/33
 port link-mode bridge
#
interface GigabitEthernet3/0/34
 port link-mode bridge
#
interface GigabitEthernet3/0/35
 port link-mode bridge
#
interface GigabitEthernet3/0/36
 port link-mode bridge
#
interface GigabitEthernet3/0/37
 port link-mode bridge
#
interface GigabitEthernet3/0/38
 port link-mode bridge
#
interface GigabitEthernet3/0/39
 port link-mode bridge
#
interface GigabitEthernet3/0/40
 port link-mode bridge
#
interface GigabitEthernet3/0/41
 port link-mode bridge
#
interface GigabitEthernet3/0/42
 port link-mode bridge
#
interface GigabitEthernet3/0/43
 port link-mode bridge
#
interface GigabitEthernet3/0/44
 port link-mode bridge
#
interface GigabitEthernet3/0/45
 port link-mode bridge
#
interface GigabitEthernet3/0/46
 port link-mode bridge
#
interface GigabitEthernet3/0/47
 port link-mode bridge
#
interface GigabitEthernet3/0/48
 port link-mode bridge
#
interface GigabitEthernet4/0/1
 port link-mode bridge
#
interface GigabitEthernet4/0/2
 port link-mode bridge
#
interface GigabitEthernet4/0/3
 port link-mode bridge
#
interface GigabitEthernet4/0/4
 port link-mode bridge
#
interface GigabitEthernet4/0/5
 port link-mode bridge
#
interface GigabitEthernet4/0/6
 port link-mode bridge
#
interface GigabitEthernet4/0/7
 port link-mode bridge
#
interface GigabitEthernet4/0/8
 port link-mode bridge
#
interface GigabitEthernet4/0/9
 port link-mode bridge
#
interface GigabitEthernet4/0/10
 port link-mode bridge
#
interface GigabitEthernet4/0/11
 port link-mode bridge
#
interface GigabitEthernet4/0/12
 port link-mode bridge
#
interface GigabitEthernet4/0/13
 port link-mode bridge
#
interface GigabitEthernet4/0/14
 port link-mode bridge
#
interface GigabitEthernet4/0/15
 port link-mode bridge
 description super_uplink
 port access vlan 105
 port link-aggregation group 1
#
interface GigabitEthernet4/0/16
 port link-mode bridge
 description super_uplink
 port access vlan 105
 port link-aggregation group 2
#
interface GigabitEthernet4/0/17
 port link-mode bridge
#
interface GigabitEthernet4/0/18
 port link-mode bridge
#
interface GigabitEthernet4/0/19
 port link-mode bridge
#
interface GigabitEthernet4/0/20
 port link-mode bridge
#
interface GigabitEthernet4/0/21
 port link-mode bridge
#
interface GigabitEthernet4/0/22
 port link-mode bridge
#
interface GigabitEthernet4/0/23
 port link-mode bridge
#
interface GigabitEthernet4/0/24
 port link-mode bridge
#
interface GigabitEthernet4/0/25
 port link-mode bridge
#
interface GigabitEthernet4/0/26
 port link-mode bridge
#
interface GigabitEthernet4/0/27
 port link-mode bridge
#
interface GigabitEthernet4/0/28
 port link-mode bridge
#
interface GigabitEthernet4/0/29
 port link-mode bridge
#
interface GigabitEthernet4/0/30
 port link-mode bridge
#
interface GigabitEthernet4/0/31
 port link-mode bridge
#
interface GigabitEthernet4/0/32
 port link-mode bridge
#
interface GigabitEthernet4/0/33
 port link-mode bridge
#
interface GigabitEthernet4/0/34
 port link-mode bridge
#
interface GigabitEthernet4/0/35
 port link-mode bridge
#
interface GigabitEthernet4/0/36
 port link-mode bridge
#
interface GigabitEthernet4/0/37
 port link-mode bridge
#
interface GigabitEthernet4/0/38
 port link-mode bridge
#
interface GigabitEthernet4/0/39
 port link-mode bridge
#
interface GigabitEthernet4/0/40
 port link-mode bridge
#
interface GigabitEthernet4/0/41
 port link-mode bridge
#
interface GigabitEthernet4/0/42
 port link-mode bridge
#
interface GigabitEthernet4/0/43
 port link-mode bridge
#
interface GigabitEthernet4/0/44
 port link-mode bridge
#
interface GigabitEthernet4/0/45
 port link-mode bridge
#
interface GigabitEthernet4/0/46
 port link-mode bridge
#
interface GigabitEthernet4/0/47
 port link-mode bridge
#
interface GigabitEthernet4/0/48
 port link-mode bridge
#
interface M-GigabitEthernet0/0/0
 ip address 192.168.1.1 255.255.255.0
 ipv6 address auto
 ipv6 address dhcp-alloc
#
interface Ten-GigabitEthernet1/0/49
#
interface Ten-GigabitEthernet1/0/50
#
interface Ten-GigabitEthernet1/0/51
#
interface Ten-GigabitEthernet1/0/52
#
interface Ten-GigabitEthernet2/0/49
#
interface Ten-GigabitEthernet2/0/50
#
interface Ten-GigabitEthernet2/0/51
#
interface Ten-GigabitEthernet2/0/52
#
interface Ten-GigabitEthernet3/0/49
#
interface Ten-GigabitEthernet3/0/50
#
interface Ten-GigabitEthernet3/0/51
#
interface Ten-GigabitEthernet3/0/52
#
interface Ten-GigabitEthernet4/0/49
#
interface Ten-GigabitEthernet4/0/50
#
interface Ten-GigabitEthernet4/0/51
#
interface Ten-GigabitEthernet4/0/52
#
 scheduler logfile size 16
#
line class aux
 user-role network-admin
#
line class vty
 user-role network-operator
#
line aux 0 3
 user-role network-admin
#
line vty 0
 user-role network-operator
#
line vty 1 10
 authentication-mode scheme
 user-role network-operator
#
line vty 11 63
 user-role network-operator
#
 ssh server enable
 sftp server enable
 ssh user admin service-type all authentication-type password
 ssh user prisma service-type all authentication-type password
 scp server enable
#
 ntp-service source Vlan-interface1
 ntp-service unicast-server 10.128.1.93
#
radius scheme system
 user-name-format without-domain
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
local-user admin class manage
 password hash $h$6$5WlAwfvOvEDxi1QI$bzM5BrxvFKFt+2nK4XfUQylmr5bXhH/YS9qhsR7/x5DuQrDVvPZGVLbx1BIf0QUPTVvvuERgFIf7WxZX6sFvYg==
 service-type ssh telnet terminal http https
 authorization-attribute user-role security-audit
 password-control aging 365
 password-control login-attempt 10 exceed lock-time 1
#
local-user prisma class manage
 password hash $h$6$GrtVuEHSgpli97tI$cuVxUbXbrBoSkc2NWNV31vWzUpJa+K2lVSIjthRMV7oQgxOIWieX5+7qoPvtw8rUfnYUDIaPVUOQbNYK31M9Ww==
 access-limit 5
 service-type ssh telnet terminal http https
 authorization-attribute user-role network-admin
 authorization-attribute user-role network-operator
 password-control aging 365
 password-control login-attempt 10 exceed lock-time 1
#
 ftp server enable
#
 ip http enable
#
return

Thanks

6 REPLIES
parnassus
Honored Contributor

Re: Performance issue on 5510 IRF

I feel there is something strange about your BAGGs configurations: from a Bridge-Aggregation Group standpoint on a Comware based switch...shouldn't be more common to see port link-type trunk and port trunk permit vlan 105 options (vlan 105 in your specific case) instead of port access vlan 105? I mean, there a specific way to setup a BAGG on Comware...what is the reason to use port access in this context?

Which ports are used as uplinks to other Switches?

Why BAGGs have member ports, respectively, on both 3rd and 4th IRF Members - BAGG 1: 3/0/15 + 4/0/15 and BAGG 2: 3/0/16 + 4/0/16 - only? does that impact negatively your qperf tests? are those BAGGs involved at all in your tests? what are you testing exactly (what interfaces/extra switches/IRF switch members are involved)?

soze
Occasional Contributor

Re: Performance issue on 5510 IRF

Hi parnassus, thanks for the reply.

We use port access because we have a single untagged vlan in the whole stack and we were unaware of the options you suggested us. That’s worth a try for sure.

 

As per the uplink switches, we use port these BAGG interfaces to the other switches (Procurve 2900, LACP trunk ports), we configured only uplinks on sitch members 3 and 4 because of the lack of free ports on switch 1 and 2; we still didn’t know if this can impact on testing, I thing the weird thing is that some hosts are performing normally while other doesn’t though.

We use qperf in both send and receive mode from hosts on the other subnet to the hosts on the IRF Stack, random interfaces, different switches.

 
For istance, we can try from host A (connected to 2900) to host B on port 1/0/1 having a given result, then still from host A to host B on port 2/0/2 with another result, and so on to switch 3 and 4.

The more we try, the less we achieve as the problem seems to affect every switch, doesn’t care which one.

Is that a way to test directly the BAGG interfaces or the switch links?

furthermore, we noticed on the previous switches an "enhanced irf mode" that isn't available on these switch. Should it be available or it is enabled by default in latest releases?

Thanks for your kind suggestions.

parnassus
Honored Contributor

Re: Performance issue on 5510 IRF


@sozewrote: We use port access because we have a single untagged vlan in the whole stack and we were unaware of the options you suggested us. That’s worth a try for sure.

Well, more than options...it's my understanding that HPE suggests some ways of configuring BAGGs/LAGs - especially those used between Switches (terminology change between Comware/ProVision/Cisco/etc. but concepts are the same) - and, generally, if you look at official HPE KB Articles or related manuals for your Switch series BAGGs are always done in a standard common way (permitted than a lot of BAGG related options are always possible).

HPE has a KB Article that explains how to setup a BAGG between a Comware based Switch and a ProVision (now ArubaOS-Switch) based one...read about it here.

As per the uplink switches, we use port these BAGG interfaces to the other switches (Procurve 2900, LACP trunk ports), we configured only uplinks on sitch members 3 and 4 because of the lack of free ports on switch 1 and 2; we still didn’t know if this can impact on testing, I thing the weird thing is that some hosts are performing normally while other doesn’t though.

Well, a starting point would be to verify if issues happen also between hosts belonging to IRF Member without involving any other uplinked Switch or if issues happen also/only between hosts belonging to some IRF Members and any other host on the uplinked (via BAGG) Switch. I mean...you need to find a pattern in order to shrink all possible causes (BAGGs configuration? IRF issues? and so on...).

 

We use qperf in both send and receive mode from hosts on the other subnet to the hosts on the IRF Stack, random interfaces, different switches.

So the issue is not hitting when you test Host A (on a IRF Member) to Host B (on another far/near neighbour IRF Member)?


For istance, we can try from host A (connected to 2900) to host B on port 1/0/1 having a given result, then still from host A to host B on port 2/0/2 with another result, and so on to switch 3 and 4.

Wrote this way it seems more an issue related to traffic passing through your uplinks (between IRF Stack and HP ProCurve 2900 Switches) than an issue involving IRF Members.

The more we try, the less we achieve as the problem seems to affect every switch, doesn’t care which one.

Is that a way to test directly the BAGG interfaces or the switch links?

There is a way to diagnose BAGGs (Comware side) and corresponding Port Trunks (ProCurve side).

IMHO you should start with IRF: diagnose it, then ,once sure the IRF Stack is working correctly, diagnose uplinks to other 3rd Party Switches (ProCurve)...once you're sure that BAGGs-Port Trunks are OK (from both standpoints, IRF and ProCurve) move on...can we consider VLANs among other possible causes?

IRF troubleshooting (if you want you can paste sanitized commands' outputs):

  • display version
  • display interface (specifying IRF involved physical interfaces)
  • display irf
  • display irf configuration
  • display irf topology

BAGGs (LACP) troubleshooting from the IRF standpoint:

  • display interface (specifying used BAGGs interfaces)
  • display link-aggregation verbose (specifying used BAGG interfaces)

Port Trunks (LACP) troubleshooting from the HP ProCurve Switch standpoint:

  • show trunk
  • show lacp
  • show interface

furthermore, we noticed on the previous switches an "enhanced irf mode" that isn't available on these switch. Should it be available or it is enabled by default in latest releases?

Thanks for your kind suggestions.


I don't believe that the lack/presence of enhanced irf mode setting is the real culprit if your four member IRF Stack is already correctly formed.

soze
Occasional Contributor

Re: Performance issue on 5510 IRF


@parnassuswrote:


IMHO you should start with IRF: diagnose it, then ,once sure the IRF Stack is working correctly, diagnose uplinks to other 3rd Party Switches (ProCurve)...once you're sure that BAGGs-Port Trunks are OK (from both standpoints, IRF and ProCurve) move on...can we consider VLANs among other possible causes?

IRF troubleshooting (if you want you can paste sanitized commands' outputs):


That's fine, hope this won't be annoying you! 

There'arent connectivity issues between nodes connected to the IRF members in the internal network. We do experience issues only when go through the uplinks or from the uplinks. Yet I already did some tests now just to be sure of what I'm wirting.

from this you can probably see we had changed the IRF cables to the IRF ports and rebooted the switch in order to debug the situation.

 

This is the output of a Procurve switch:

SuperSwUp# show trunks

 Load Balancing Method: L3-based (Default), L2-based if non-IP traffic

  Port   | Name                             Type      | Group Type
  ------ + -------------------------------- --------- + ----- --------
  1      | LACP                             100/1000T | Trk2  LACP
  2      | LACP                             100/1000T | Trk2  LACP
  3      | LACP                             100/1000T | Trk2  LACP
  4      | LACP                             100/1000T | Trk2  LACP
  33     |                                  100/1000T | Trk3  LACP
  34     |                                  100/1000T | Trk3  LACP
  45     | Uplink A                         1000SX    | Trk1  Trunk
  46     | UplinK B                         1000SX    | Trk1  Trunk


SuperSwUp#
SuperSwUp# show lacp

                           LACP

          LACP      Trunk     Port                LACP
   Port   Enabled   Group     Status    Partner   Status
   ----   -------   -------   -------   -------   -------
   1      Active    Trk2      Up        Yes       Success
   2      Active    Trk2      Up        Yes       Success
   3      Active    Trk2      Up        Yes       Success
   4      Active    Trk2      Up        Yes       Success
   33     Active    Trk3      Up        Yes       Success
   34     Active    Trk3      Up        Yes       Success


SuperSwUp#
SuperSwUp# show interfaces 33

 Status and Counters - Port Counters for port 33

  Name  :
  MAC Address      : f0921c-ccd19f
  Link Status      : Up
  Totals (Since boot or last clear) :
   Bytes Rx        : 110,269,226        Bytes Tx        : 5,692,722
   Unicast Rx      : 804                Unicast Tx      : 0
   Bcast/Mcast Rx  : 853,803            Bcast/Mcast Tx  : 28,691
  Errors (Since boot or last clear) :
   FCS Rx          : 0                  Drops Tx        : 0
   Alignment Rx    : 0                  Collisions Tx   : 0
   Runts Rx        : 0                  Late Colln Tx   : 0
   Giants Rx       : 0                  Excessive Colln : 0
   Total Rx Errors : 0                  Deferred Tx     : 0
  Others (Since boot or last clear) :
   Discard Rx      : 0                  Out Queue Len   : 0
   Unknown Protos  : 0
  Rates (5 minute weighted average) :
   Total Rx  (bps) : 4,250,264          Total Tx  (bps) : 1,344,696
   Unicast Rx (Pkts/sec) : 0            Unicast Tx (Pkts/sec) : 0
   B/Mcast Rx (Pkts/sec) : 2            B/Mcast Tx (Pkts/sec) : 0
   Utilization Rx  : 00.42 %            Utilization Tx  : 00.13 %


SuperSwUp#
SuperSwUp# show interfaces 34

 Status and Counters - Port Counters for port 34
  Name  :
  Name  :
  MAC Address      : f0921c-ccd19e
  Link Status      : Up  ast clear) :
  Totals (Since boot or last clear) :
   Bytes Rx        : 414,461,783        Bytes Tx        : 5,692,338
   Unicast Rx      : 232                Unicast Tx      : 0
   Bcast/Mcast Rx  : 2,926,057          Bcast/Mcast Tx  : 28,686
  Errors (Since boot or last clear) :
   FCS Rx          : 0                  Drops Tx        : 0
   Alignment Rx    : 0                  Collisions Tx   : 0
   Runts Rx        : 0                  Late Colln Tx   : 0
   Giants Rx       : 0                  Excessive Colln : 0
   Total Rx Errors : 0                  Deferred Tx     : 0
  Others (Since boot or last clear) :
   Discard Rx      : 0                  Out Queue Len   : 0
   Unknown Protos  : 0
  Rates (5 minute weighted average) :   Total Tx  (bps) : 1,344,696
   Total Rx  (bps) : 5,001,520          Total Tx  (bps) : 1,297,432
   Unicast Rx (Pkts/sec) : 0            Unicast Tx (Pkts/sec) : 0
   B/Mcast Rx (Pkts/sec) : 1            B/Mcast Tx (Pkts/sec) : 0
   Utilization Rx  : 00.50 %            Utilization Tx  : 00.12 %

SuperSwUp#

The uplink ports are the ones in Trunk3.

Hope to configure BAGGS interfaces and more uplinks tomorrow.

 

soze
Occasional Contributor

Re: Performance issue on 5510 IRF

This is the output of the config. of the IRF stack. It will be splitted in one or more posts because of the huge amount of carachters:

<HPE>display version
HPE Comware Software, Version 7.1.045, Release 1122P02
Copyright (c) 2010-2017 Hewlett Packard Enterprise Development LP
HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A uptime is 7 weeks, 0 days, 23 hours, 49 minutes
Last reboot reason : User reboot

Boot image: flash:/5510hi-cmw710-boot-r1122p02.bin
Boot image version: 7.1.045, Release 1122P02
  Compiled Jul 03 2017 16:00:00
System image: flash:/5510hi-cmw710-system-r1122p02.bin
System image version: 7.1.045, Release 1122P02
  Compiled Jul 03 2017 16:00:00


Slot 1:
Uptime is 1 week,1 day,2 hours,44 minutes
HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A with 2 Processors
BOARD TYPE:         5510 48G 4SFP+ HI 1-slot Switch
DRAM:               1984M bytes
FLASH:              512M bytes
PCB 1 Version:      VER.A
Bootrom Version:    126
CPLD 1 Version:     003
Release Version:    HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A-1122P02
Patch Version  :    None
Reboot Cause  :     UserReboot
[SubSlot 0] 48GE+4SFP Plus

Slot 2:
Uptime is 1 week,1 day,2 hours,49 minutes
HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A with 2 Processors
BOARD TYPE:         5510 48G 4SFP+ HI 1-slot Switch
DRAM:               1984M bytes
FLASH:              512M bytes
PCB 1 Version:      VER.A
Bootrom Version:    126
CPLD 1 Version:     003
Release Version:    HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A-1122P02
Patch Version  :    None
Reboot Cause  :     UserReboot
[SubSlot 0] 48GE+4SFP Plus

Slot 3:
Uptime is 7 weeks,0 days,23 hours,50 minutes
HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A with 2 Processors
BOARD TYPE:         5510 48G 4SFP+ HI 1-slot Switch
DRAM:               1984M bytes
FLASH:              512M bytes
PCB 1 Version:      VER.A
Bootrom Version:    126
CPLD 1 Version:     003
Release Version:    HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A-1122P02
Patch Version  :    None
Reboot Cause  :     ColdReboot
[SubSlot 0] 48GE+4SFP Plus

Slot 4:
Uptime is 7 weeks,0 days,23 hours,49 minutes
HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A with 2 Processors
BOARD TYPE:         5510 48G 4SFP+ HI 1-slot Switch
DRAM:               1984M bytes
FLASH:              512M bytes
PCB 1 Version:      VER.A
Bootrom Version:    126
CPLD 1 Version:     003
Release Version:    HPE 5510 48G 4SFP+ HI 1-slot Switch JH146A-1122P02
Patch Version  :    None
Reboot Cause  :     ColdReboot
[SubSlot 0] 48GE+4SFP Plus
<HPE>

<HPE>display irf
MemberID    Role    Priority  CPU-Mac         Description
   1        Standby 32        00e0-fc0f-8c02  ---
 *+2        Master  31        00e0-fc0f-8c03  ---
   3        Standby 30        00e0-fc0f-8c04  ---
   4        Standby 29        00e0-fc0f-8c05  ---
--------------------------------------------------
 * indicates the device is the master.
 + indicates the device through which the user logs in.

 The bridge MAC of the IRF is: 943f-c275-f575
 Auto upgrade                : yes
 Mac persistent              : 6 min
 Domain ID                   : 0
<HPE>

<HPE>display irf configuration
 MemberID NewID    IRF-Port1                     IRF-Port2
 1        1        Ten-GigabitEthernet1/0/49     Ten-GigabitEthernet1/0/51
                   Ten-GigabitEthernet1/0/50     Ten-GigabitEthernet1/0/52
 2        2        Ten-GigabitEthernet2/0/49     Ten-GigabitEthernet2/0/51
                   Ten-GigabitEthernet2/0/50     Ten-GigabitEthernet2/0/52
 3        3        Ten-GigabitEthernet3/0/49     Ten-GigabitEthernet3/0/51
                   Ten-GigabitEthernet3/0/50     Ten-GigabitEthernet3/0/52
 4        4        Ten-GigabitEthernet4/0/49     Ten-GigabitEthernet4/0/51
                   Ten-GigabitEthernet4/0/50     Ten-GigabitEthernet4/0/52
<HPE>

<HPE>display irf topology
                              Topology Info
 -------------------------------------------------------------------------
               IRF-Port1                IRF-Port2
 MemberID    Link       neighbor      Link       neighbor    Belong To
 2           UP         1             UP         3           00e0-fc0f-8c03
 1           UP         4             UP         2           00e0-fc0f-8c03
 4           UP         3             UP         1           00e0-fc0f-8c03
 3           UP         2             UP         4           00e0-fc0f-8c03
<HPE>

<HPE>display interface Bridge-Aggregation1
Bridge-Aggregation1
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-28cf
Description: Bridge-Aggregation1 Interface
Bandwidth: 2000000 kbps
2Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
PVID: 105
Port link-type: Access
 Tagged VLANs:   None
 Untagged VLANs: 105
Last clearing of counters: Never
Last 300 seconds input:  0 packets/sec 26 bytes/sec 0%
Last 300 seconds output:  2 packets/sec 428 bytes/sec 0%
Input (total):  108023 packets, 19493622 bytes
        29816 unicasts, 934 broadcasts, 77273 multicasts, 0 pauses
Input (normal):  108023 packets, - bytes
        29816 unicasts, 934 broadcasts, 77273 multicasts, 0 pauses
Input:  0 input errors, 0 runts, 0 giants, 0 throttles
        0 CRC, 0 frame, - overruns, 0 aborts
        - ignored, - parity errors
Output (total): 5846304 packets, 821826037 bytes
        31968 unicasts, 4371891 broadcasts, 1442445 multicasts, 0 pauses
Output (normal): 5846304 packets, - bytes
        31968 unicasts, 4371891 broadcasts, 1442445 multicasts, 0 pauses
Output: 0 output errors, - underruns, - buffer failures
        0 aborts, 0 deferred, 0 collisions, 0 late collisions
        0 lost carrier, - no carrier

<HPE>display interface Bridge-Aggregation2
Bridge-Aggregation2
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-28d0
Description: Bridge-Aggregation2 Interface
Bandwidth: 2000000 kbps
2Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
PVID: 105
Port link-type: Access
 Tagged VLANs:   None
 Untagged VLANs: 105
Last clearing of counters: Never
Last 300 seconds input:  33 packets/sec 3152 bytes/sec 0%
Last 300 seconds output:  29 packets/sec 2883 bytes/sec 0%
Input (total):  360877087 packets, 145561405917 bytes
        355888719 unicasts, 3636682 broadcasts, 1351686 multicasts, 0 pauses
Input (normal):  360877087 packets, - bytes
        355888719 unicasts, 3636682 broadcasts, 1351686 multicasts, 0 pauses
Input:  0 input errors, 0 runts, 0 giants, 0 throttles
        0 CRC, 0 frame, - overruns, 0 aborts
        - ignored, - parity errors
Output (total): 1408922785 packets, 2081052689075 bytes
        1408878674 unicasts, 9512 broadcasts, 34599 multicasts, 0 pauses
Output (normal): 1408922785 packets, - bytes
        1408878674 unicasts, 9512 broadcasts, 34599 multicasts, 0 pauses
Output: 0 output errors, - underruns, - buffer failures
        0 aborts, 0 deferred, 0 collisions, 0 late collisions
        0 lost carrier, - no carrier

<HPE>

<HPE>display link-aggregation verbose Bridge-Aggregation1
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected,
             I -- Individual, * -- Management port
Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
        D -- Synchronization, E -- Collecting, F -- Distributing,
        G -- Defaulted, H -- Expired

Aggregate Interface: Bridge-Aggregation1
Aggregation Mode: Dynamic
Loadsharing Type: Shar
Management VLAN : None
System ID: 0x8000, 943f-c275-f575
Local:
  Port             Status  Priority Oper-Key  Flag
--------------------------------------------------------------------------------
  GE3/0/15            S       32768    1         {ACDEF}
  GE4/0/15            S       32768    1         {ACDEF}
Remote:
  Actor            Partner Priority Oper-Key  SystemID               Flag
--------------------------------------------------------------------------------
  GE3/0/15            33      0        212       0xd180, f092-1ccc-d180 {ACDEF}
  GE4/0/15            34      0        212       0xd180, f092-1ccc-d180 {ACDEF}
<HPE>display link-aggregation verbose Bridge-Aggregation2
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port Status: S -- Selected, U -- Unselected,
             I -- Individual, * -- Management port
Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
        D -- Synchronization, E -- Collecting, F -- Distributing,
        G -- Defaulted, H -- Expired

Aggregate Interface: Bridge-Aggregation2
Aggregation Mode: Dynamic
Loadsharing Type: Shar
Management VLAN : None
System ID: 0x8000, 943f-c275-f575
Local:
  Port             Status  Priority Oper-Key  Flag
--------------------------------------------------------------------------------
  GE3/0/16            S       32768    2         {ACDEF}
  GE4/0/16            S       32768    2         {ACDEF}
Remote:
  Actor            Partner Priority Oper-Key  SystemID               Flag
--------------------------------------------------------------------------------
  GE3/0/16            33      0        212       0xbc40, f092-1cca-bc40 {ACDEF}
  GE4/0/16            34      0        212       0xbc40, f092-1cca-bc40 {ACDEF}
<HPE>
soze
Occasional Contributor

Re: Performance issue on 5510 IRF

<HPE>display interface Ten-GigabitEthernet1/0/49
Ten-GigabitEthernet1/0/49
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c276-2d0e
Description: Ten-GigabitEthernet1/0/49 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 0 minutes
Last clearing of counters: Never
 Peak input rate: 10150800 bytes/sec, at 2018-02-21 17:55:21
 Peak output rate: 105206791 bytes/sec, at 2018-02-22 11:14:14
 Last 300 second input: 88 packets/sec 16532 bytes/sec 0%
 Last 300 second output: 101 packets/sec 22723 bytes/sec 0%
 Input (total):  410093878 packets, 70748600021 bytes
         404352089 unicasts, 3343016 broadcasts, 2397011 multicasts, 0 pauses
 Input (normal):  410092116 packets, - bytes
         404352089 unicasts, 3343016 broadcasts, 2397011 multicasts, 0 pauses
 Input:  1755 input errors, 0 runts, 0 giants, 0 throttles
         1755 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 1858605627 packets, 2761865558963 bytes
         1849115234 unicasts, 61930 broadcasts, 9428463 multicasts, 0 pauses
 Output (normal): 1858605627 packets, - bytes
         1849115234 unicasts, 61930 broadcasts, 9428463 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet1/0/50
Ten-GigabitEthernet1/0/50
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c276-2d0f
Description: Ten-GigabitEthernet1/0/50 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 0 minutes
Last clearing of counters: Never
 Peak input rate: 18434249 bytes/sec, at 2018-02-21 21:44:56
 Peak output rate: 298640 bytes/sec, at 2018-02-21 14:17:45
 Last 300 second input: 25 packets/sec 12388 bytes/sec 0%
 Last 300 second output: 18 packets/sec 6284 bytes/sec 0%
 Input (total):  98681681 packets, 126101502751 bytes
         87326835 unicasts, 1151258 broadcasts, 10199969 multicasts, 0 pauses
 Input (normal):  98678062 packets, - bytes
         87326835 unicasts, 1151258 broadcasts, 10199969 multicasts, 0 pauses
 Input:  3607 input errors, 0 runts, 0 giants, 0 throttles
         3607 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 35419314 packets, 7572712372 bytes
         28821402 unicasts, 3710060 broadcasts, 2887852 multicasts, 0 pauses
 Output (normal): 35419314 packets, - bytes
         28821402 unicasts, 3710060 broadcasts, 2887852 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet1/0/51
Ten-GigabitEthernet1/0/51
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c276-2d10
Description: Ten-GigabitEthernet1/0/51 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 46 minutes
Last clearing of counters: Never
 Peak input rate: 247692 bytes/sec, at 2018-02-21 21:43:35
 Peak output rate: 4847152 bytes/sec, at 2018-02-21 17:20:08
 Last 300 second input: 76 packets/sec 16011 bytes/sec 0%
 Last 300 second output: 64 packets/sec 14164 bytes/sec 0%
 Input (total):  67831793 packets, 16054624094 bytes
         61990179 unicasts, 1512420 broadcasts, 4329194 multicasts, 0 pauses
 Input (normal):  67831793 packets, - bytes
         61990179 unicasts, 1512420 broadcasts, 4329194 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 48317914 packets, 11925780153 bytes
         42255766 unicasts, 3343740 broadcasts, 2718408 multicasts, 0 pauses
 Output (normal): 48317914 packets, - bytes
         42255766 unicasts, 3343740 broadcasts, 2718408 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet1/0/52
Ten-GigabitEthernet1/0/52
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c276-2d11
Description: Ten-GigabitEthernet1/0/52 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 46 minutes
Last clearing of counters: Never
 Peak input rate: 6214085 bytes/sec, at 2018-02-20 17:15:08
 Peak output rate: 18444612 bytes/sec, at 2018-02-21 21:44:56
 Last 300 second input: 74 packets/sec 21020 bytes/sec 0%
 Last 300 second output: 93 packets/sec 22720 bytes/sec 0%
 Input (total):  54081508 packets, 17164961092 bytes
         41569260 unicasts, 3226068 broadcasts, 9286180 multicasts, 0 pauses
 Input (normal):  54081508 packets, - bytes
         41569260 unicasts, 3226068 broadcasts, 9286180 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 94598780 packets, 56364813655 bytes
         79998412 unicasts, 3962351 broadcasts, 10638017 multicasts, 0 pauses
 Output (normal): 94598780 packets, - bytes
         79998412 unicasts, 3962351 broadcasts, 10638017 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet2/0/49
Ten-GigabitEthernet2/0/49
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c275-f5ce
Description: Ten-GigabitEthernet2/0/49 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 47 minutes
Last clearing of counters: Never
 Peak input rate: 18424968 bytes/sec, at 2018-02-21 21:42:35
 Peak output rate: 6206775 bytes/sec, at 2018-02-20 17:12:25
 Last 300 second input: 96 packets/sec 23249 bytes/sec 0%
 Last 300 second output: 76 packets/sec 21555 bytes/sec 0%
 Input (total):  94634949 packets, 56375123662 bytes
         80019230 unicasts, 3964433 broadcasts, 10651285 multicasts, 0 pauses
 Input (normal):  94634948 packets, - bytes
         80019230 unicasts, 3964433 broadcasts, 10651285 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 54086369 packets, 17166745550 bytes
         41571959 unicasts, 3226124 broadcasts, 9288286 multicasts, 0 pauses
 Output (normal): 54086369 packets, - bytes
         41571959 unicasts, 3226124 broadcasts, 9288286 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet2/0/50
Ten-GigabitEthernet2/0/50
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c275-f5cf
Description: Ten-GigabitEthernet2/0/50 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 47 minutes
Last clearing of counters: Never
 Peak input rate: 4840672 bytes/sec, at 2018-02-21 17:20:05
 Peak output rate: 247724 bytes/sec, at 2018-02-21 21:42:35
 Last 300 second input: 67 packets/sec 14904 bytes/sec 0%
 Last 300 second output: 79 packets/sec 16639 bytes/sec 0%
 Input (total):  48325374 packets, 11929082445 bytes
         42258744 unicasts, 3343812 broadcasts, 2722817 multicasts, 0 pauses
 Input (normal):  48325373 packets, - bytes
         42258744 unicasts, 3343812 broadcasts, 2722817 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 67859021 packets, 16061449976 bytes
         62012649 unicasts, 1513066 broadcasts, 4333306 multicasts, 0 pauses
 Output (normal): 67859021 packets, - bytes
         62012649 unicasts, 1513066 broadcasts, 4333306 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet2/0/51
Ten-GigabitEthernet2/0/51
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c275-f5d0
Description: Ten-GigabitEthernet2/0/51 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 7 minutes
Last clearing of counters: Never
 Peak input rate: 422174 bytes/sec, at 2018-02-21 11:29:30
 Peak output rate: 34885862 bytes/sec, at 2018-02-21 11:29:25
 Last 300 second input: 0 packets/sec 33 bytes/sec 0%
 Last 300 second output: 0 packets/sec 0 bytes/sec 0%
 Input (total):  17986565 packets, 4850873008 bytes
         12533997 unicasts, 1167065 broadcasts, 3454620 multicasts, 0 pauses
 Input (normal):  17155682 packets, - bytes
         12533997 unicasts, 1167065 broadcasts, 3454620 multicasts, 0 pauses
 Input:  810518 input errors, 35 runts, 0 giants, 0 throttles
         810483 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 36387728 packets, 42698647422 bytes
         34872096 unicasts, 81248 broadcasts, 1434349 multicasts, 0 pauses
 Output (normal): 36387693 packets, - bytes
         34872096 unicasts, 81248 broadcasts, 1434349 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet2/0/52
Ten-GigabitEthernet2/0/52
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c275-f5d1
Description: Ten-GigabitEthernet2/0/52 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 51 minutes
Last clearing of counters: Never
 Peak input rate: 11760411 bytes/sec, at 2018-02-20 02:18:07
 Peak output rate: 21063660 bytes/sec, at 2018-02-19 17:48:51
 Last 300 second input: 65 packets/sec 22070 bytes/sec 0%
 Last 300 second output: 64 packets/sec 22110 bytes/sec 0%
 Input (total):  187499908 packets, 199012629399 bytes
         171799545 unicasts, 6017750 broadcasts, 9682140 multicasts, 0 pauses
 Input (normal):  187499435 packets, - bytes
         171799545 unicasts, 6017750 broadcasts, 9682140 multicasts, 0 pauses
 Input:  472 input errors, 0 runts, 0 giants, 0 throttles
         472 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 150707949 packets, 136880541836 bytes
         134971631 unicasts, 4352123 broadcasts, 11384195 multicasts, 0 pauses
 Output (normal): 150707949 packets, - bytes
         134971631 unicasts, 4352123 broadcasts, 11384195 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>
<HPE>display interface Ten-GigabitEthernet3/0/49
Ten-GigabitEthernet3/0/49
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-28f1
Description: Ten-GigabitEthernet3/0/49 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 8 minutes
Last clearing of counters: Never
 Peak input rate: 107971905 bytes/sec, at 2013-01-22 07:18:46
 Peak output rate: 23943348 bytes/sec, at 2018-01-14 15:16:30
 Last 300 second input: 0 packets/sec 0 bytes/sec 0%
 Last 300 second output: 0 packets/sec 33 bytes/sec 0%
 Input (total):  8995289631 packets, 13402357957163 bytes
         8912648442 unicasts, 62229044 broadcasts, 20412119 multicasts, 0 pauses
 Input (normal):  8995289605 packets, - bytes
         8912648442 unicasts, 62229044 broadcasts, 20412119 multicasts, 0 pauses
 Input:  18 input errors, 4 runts, 0 giants, 0 throttles
         14 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 2076603725 packets, 232521341044 bytes
         1947749214 unicasts, 78223228 broadcasts, 50631279 multicasts, 0 pauses
 Output (normal): 2076603721 packets, - bytes
         1947749214 unicasts, 78223228 broadcasts, 50631279 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet3/0/50
Ten-GigabitEthernet3/0/50
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-28f2
Description: Ten-GigabitEthernet3/0/50 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 1 weeks 1 days 2 hours 52 minutes
Last clearing of counters: Never
 Peak input rate: 34104112 bytes/sec, at 2018-01-14 15:16:30
 Peak output rate: 82092382 bytes/sec, at 2018-01-13 17:53:34
 Last 300 second input: 68 packets/sec 22683 bytes/sec 0%
 Last 300 second output: 69 packets/sec 22644 bytes/sec 0%
 Input (total):  2567652654 packets, 2485133502778 bytes
         2413973263 unicasts, 61721868 broadcasts, 91277871 multicasts, 0 pauses
 Input (normal):  2566973002 packets, - bytes
         2413973263 unicasts, 61721868 broadcasts, 91277871 multicasts, 0 pauses
 Input:  678338 input errors, 4 runts, 0 giants, 0 throttles
         678334 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 3101153258 packets, 3861646267392 bytes
         2938592030 unicasts, 98498444 broadcasts, 64062780 multicasts, 0 pauses
 Output (normal): 3101153254 packets, - bytes
         2938592030 unicasts, 98498444 broadcasts, 64062780 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet3/0/51
Ten-GigabitEthernet3/0/51
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-28f3
Description: Ten-GigabitEthernet3/0/51 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 7 weeks 0 days 23 hours 52 minutes
Last clearing of counters: Never
 Peak input rate: 105250559 bytes/sec, at 2018-02-22 11:14:15
 Peak output rate: 54390179 bytes/sec, at 2018-01-12 15:09:20
 Last 300 second input: 50 packets/sec 15290 bytes/sec 0%
 Last 300 second output: 38 packets/sec 8270 bytes/sec 0%
 Input (total):  2200493424 packets, 3134389482164 bytes
         2077636770 unicasts, 60765423 broadcasts, 62091231 multicasts, 0 pauses
 Input (normal):  2200493424 packets, - bytes
         2077636770 unicasts, 60765423 broadcasts, 62091231 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 745924422 packets, 192851699146 bytes
         703602670 unicasts, 22225486 broadcasts, 20096266 multicasts, 0 pauses
 Output (normal): 745924422 packets, - bytes
         703602670 unicasts, 22225486 broadcasts, 20096266 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet4/0/49
Ten-GigabitEthernet4/0/49
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-1d91
Description: Ten-GigabitEthernet4/0/49 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 7 weeks 0 days 23 hours 52 minutes
Last clearing of counters: Never
 Peak input rate: 54301627 bytes/sec, at 2018-01-12 15:09:45
 Peak output rate: 105321882 bytes/sec, at 2018-02-22 11:14:14
 Last 300 second input: 38 packets/sec 8203 bytes/sec 0%
 Last 300 second output: 50 packets/sec 15261 bytes/sec 0%
 Input (total):  745741662 packets, 192836597466 bytes
         703602687 unicasts, 22048124 broadcasts, 20090846 multicasts, 0 pauses
 Input (normal):  745741657 packets, - bytes
         703602687 unicasts, 22048124 broadcasts, 20090846 multicasts, 0 pauses
 Input:  4 input errors, 4 runts, 0 giants, 0 throttles
         0 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 2200493686 packets, 3134389639132 bytes
         2077636789 unicasts, 60765432 broadcasts, 62091461 multicasts, 0 pauses
 Output (normal): 2200493682 packets, - bytes
         2077636789 unicasts, 60765432 broadcasts, 62091461 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet4/0/50
Ten-GigabitEthernet4/0/50
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-1d92
Description: Ten-GigabitEthernet4/0/50 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 7 weeks 0 days 23 hours 52 minutes
Last clearing of counters: Never
 Peak input rate: 27837558 bytes/sec, at 2018-01-14 15:16:32
 Peak output rate: 37197307 bytes/sec, at 2018-01-14 15:16:32
 Last 300 second input: 20 packets/sec 11617 bytes/sec 0%
 Last 300 second output: 14 packets/sec 5321 bytes/sec 0%
 Input (total):  262016701 packets, 162780489325 bytes
         155299556 unicasts, 36564254 broadcasts, 66532671 multicasts, 0 pauses
 Input (normal):  258396481 packets, - bytes
         155299556 unicasts, 36564254 broadcasts, 66532671 multicasts, 0 pauses
 Input:  3616708 input errors, 4 runts, 0 giants, 0 throttles
         3616704 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 159429935 packets, 39960547693 bytes
         48423643 unicasts, 61528880 broadcasts, 49477408 multicasts, 0 pauses
 Output (normal): 159429931 packets, - bytes
         48423643 unicasts, 61528880 broadcasts, 49477408 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet4/0/51
Ten-GigabitEthernet4/0/51
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-1d93
Description: Ten-GigabitEthernet4/0/51 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 2 minutes
Last clearing of counters: Never
 Peak input rate: 105327512 bytes/sec, at 2018-02-22 11:14:14
 Peak output rate: 54318750 bytes/sec, at 2018-01-12 15:09:50
 Last 300 second input: 99 packets/sec 22599 bytes/sec 0%
 Last 300 second output: 86 packets/sec 16415 bytes/sec 0%
 Input (total):  2384715844 packets, 3185396202368 bytes
         2324995303 unicasts, 633930 broadcasts, 59086601 multicasts, 0 pauses
 Input (normal):  2384715834 packets, - bytes
         2324995303 unicasts, 633930 broadcasts, 59086601 multicasts, 0 pauses
 Input:  2 input errors, 0 runts, 0 giants, 0 throttles
         2 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 929675425 packets, 236398218221 bytes
         832363926 unicasts, 81644612 broadcasts, 15666887 multicasts, 0 pauses
 Output (normal): 929675425 packets, - bytes
         832363926 unicasts, 81644612 broadcasts, 15666887 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier

<HPE>

<HPE>display interface Ten-GigabitEthernet4/0/52
Ten-GigabitEthernet4/0/52
Current state: UP
IP packet frame type: Ethernet II, hardware address: 943f-c250-1d94
Description: Ten-GigabitEthernet4/0/52 Interface
Bandwidth: 10000000 kbps
Loopback is not set
Media type is optical fiber, Port hardware type is 10G_BASE_SR_SFP
10Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
Maximum frame length: 12288
MDI type: automdix
Last link flapping: 4 days 23 hours 2 minutes
Last clearing of counters: Never
 Peak input rate: 436851 bytes/sec, at 2018-01-10 05:47:15
 Peak output rate: 41947942 bytes/sec, at 2018-01-14 15:16:32
 Last 300 second input: 18 packets/sec 6044 bytes/sec 0%
 Last 300 second output: 25 packets/sec 12547 bytes/sec 0%
 Input (total):  107102825 packets, 33786211407 bytes
         79880152 unicasts, 7028382 broadcasts, 14981516 multicasts, 0 pauses
 Input (normal):  101890050 packets, - bytes
         79880152 unicasts, 7028382 broadcasts, 14981516 multicasts, 0 pauses
 Input:  5154000 input errors, 0 runts, 0 giants, 0 throttles
         5154000 CRC, 0 frame, - overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 373701965 packets, 275124333298 bytes
         189152943 unicasts, 89940402 broadcasts, 94608620 multicasts, 0 pauses
 Output (normal): 373701965 packets, - bytes
         189152943 unicasts, 89940402 broadcasts, 94608620 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, 0 late collisions
         0 lost carrier, - no carrier