Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Possible issues with setting up IRF ring topology

 
fellixx
Occasional Contributor

Possible issues with setting up IRF ring topology

We recently installed 4 5800AF-48G switches initially in a daisy chained toplogy.  We then went ahead and configured IRF port 2 on SW1 and IRF port 1 on SW4 to complete the ring topology per the IRF configuration guide.  

 

All the ports were enabled but when we check the IRF topology we see the following:

 

Topology Info
-------------------------------------------------------------------------
IRF-Port1                                                   IRF-Port2
MemberID             Link                 neighbor                            Link                               neighbor                      Belong To
4                               DOWN             --                                          UP                                  3                                      cc3e-5fa0-8698
3                               UP                    4                                           UP                                   2                                      cc3e-5fa0-8698
2                               UP                    3                                           UP                                   1                                      cc3e-5fa0-8698
1                               UP                    2                                           DOWN                            --                                     cc3e-5fa0-8698

 

When we do a show IRF configuration we see the following:

 

MemberID             NewID                                                          IRF-Port1                                                             IRF-Port2
1                               1                                                                     Ten-GigabitEthernet1/0/53                         Ten-GigabitEthernet1/0/54
2                               2                                                                     Ten-GigabitEthernet2/0/53                         Ten-GigabitEthernet2/0/54
3                               3                                                                     Ten-GigabitEthernet3/0/53                         Ten-GigabitEthernet3/0/54
4                               4                                                                     Ten-GigabitEthernet4/0/53                         Ten-GigabitEthernet4/0/54

 

All ports are enabled 

 

irf-port 1/1
port group interface Ten-GigabitEthernet1/0/53 mode enhanced
#
irf-port 1/2
port group interface Ten-GigabitEthernet1/0/54 mode enhanced
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/0/53 mode enhanced
#
irf-port 2/2
port group interface Ten-GigabitEthernet2/0/54 mode enhanced
#
irf-port 3/1
port group interface Ten-GigabitEthernet3/0/53 mode enhanced
#
irf-port 3/2
port group interface Ten-GigabitEthernet3/0/54 mode enhanced
#
irf-port 4/1
port group interface Ten-GigabitEthernet4/0/53 mode enhanced
#
irf-port 4/2
port group interface Ten-GigabitEthernet4/0/54 mode enhanced

 

For switches configured with spanning tree I would expect that certain ports blocked but its been my understanding in a IRF configuration all ports are active and transfering traffic.  Is this correct behavior or are we missing something?

 

Thanks in advance. 

4 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Possible issues with setting up IRF ring topology

Swap the cable between 1 & 4 over with any of the other working cables?

fellixx
Occasional Contributor

Re: Possible issues with setting up IRF ring topology

Havent tried that yet as it is a brand new cable though we havent discounted the possibility it could be bad.  What I would like to confirm is whether or not all ports should how as being in an UP status in an IRF configuration.  

sjhwilkes
Visitor

Re: Possible issues with setting up IRF ring topology

Yes they should all be up.

fellixx
Occasional Contributor

Re: Possible issues with setting up IRF ring topology

Just to close this out, we did finally figure out what the issue was.  After we connected the SFP+ cable to complete the ring and enabled the respective ports,  we needed to again initiate the following command to make the IRF configuration active:

 

irf-port-configuration active

 

Once we did this the IRF ports came online.  

 

Thanks to all that replied.

 

PTH