Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems while ports flipping

Tobais.Sinner
Occasional Contributor

Problems while ports flipping

Hello everybody,



We've  got the problem, that in one of our location are 3 switches installed. Each of these switches is loosing for about 2 seconds the link of a port. (see log)


I have updated all switches to the latest available Software, but the problem is still there.


I have configured the arp-timeout to 1440 Minutes, but this also do not help.



Know I am running out of ideas to locate the problem.


One more information. The problem accures only, when there are people working, but the switches are locked in a spezial room. So there will be no possibility for cable problems.



Thanks for any idea and help.






%Feb 25 06:36:50:607 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/19 is DOWN





%Feb 25 06:36:52:614 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/19 is UP





%Feb 25 06:37:50:628 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/24 is DOWN





%Feb 25 06:37:52:635 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/24 is UP





%Feb 25 06:50:46:479 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/6 is DOWN





%Feb 25 06:50:48:486 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/6 is UP





%Feb 25 06:57:00:420 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/28 is DOWN





%Feb 25 06:57:02:429 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/28 is UP





%Feb 25 07:02:52:847 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/19 is DOWN





%Feb 25 07:02:54:853 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/19 is UP





%Feb 25 07:09:49:423 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/38 is DOWN





%Feb 25 07:09:51:431 2010 172.30.3.11 L2INF/5/PORT LINK STATUS CHANGE:- 1 -


 GigabitEthernet1/0/38 is UP


 



 



 



 



<172.30.3.11>dis ver


H3C Comware Platform Software


Comware Software, Version 3.10, Release 2203P05


Copyright (c) 2004-2008 Hangzhou H3C Technologies Co., Ltd. All rights reserved.


H3C S5100-48P-SI uptime is 1 week, 6 days, 16 hours, 48 minutes





H3C S5100-48P-SI with 1 Processor


64M   bytes DRAM


16M   bytes Flash Memory


Config Register points to FLASH





Hardware Version is REV.C


CPLD Version is 002


Bootrom Version is 619


48 GE ( 4 COMBO ) Hardware Version is REV.C



3 REPLIES
Fred_Mancen_1
Super Advisor

Re: Problems while ports flipping

I suggest you to try these steps:



1. Check the port status of each event you find in the log. Search for input errors, CRC and FCS input.



2. Check the configuration of these ports. If its in auto sensing mode for speed and duplex.



3. Set the NIC features of the hosts that are connectec to these ports, hardcode the features to the maximum speed and full duplex.



4. Make a double check in the ports for a while. If the errors still appears, hardcode the ports to the same speed and duplex that you have in the NIC settings.



If the errors persists, there is a minimum possibility to solve it with a NIC firmware upgrade, but as I said before, it's quite difficult to happen.



I don't believe in loops at the L2, cause if it was happening, it would appears in the logs.



HTH



Tobais.Sinner
Occasional Contributor

Re: Problems while ports flipping

Thanks for the quick answear.


I'v had already contolled all ports for errrors. There are no errors anywhere.


The link type differs, mostly it is set to autoneg.. but there are also ports which flipping and they are set to 100MBit full duplex. So I don't belive, that this could be the answear. I have alos this up and downs on the interface to the provider and this ist guaranteed set to 100M full duplex.



The most entrys in the log, are in the morning hours, when the stuff starts to work, and arround the noon, while some people reboot their computers.



We have this setting in other 5 Locations, so I won't belive, there will be a setup failure.



 



Fred_Mancen_1
Super Advisor

Re: Problems while ports flipping

Hi; considering the quick up/down event (around 2s), I wouldn't worry about it,  unless these events are causing deeper problems to the environment performance. If you didn't find out any errors, the settings are ok, there is no problem.



Sometime I see in the logs events like these you mentioned; and the network is running ok, without further issues.



Regards