Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

[RESOLVED] automatic Voice VLAN and QoS

frmeunier
Occasional Collector

[RESOLVED] automatic Voice VLAN and QoS

Hello all

I have an issue configuring QoS on voice vlan.

I did the following config :

*************

 lldp global enable
 voice-vlan track lldp

vlan 31
 name ToIP
 description ToIP

interface GigabitEthernet1/0/17
 port link-type trunk
 port trunk permit vlan 1 10
 port trunk pvid vlan 10
 voice-vlan qos 5 46
 voice-vlan 31 enable
 stp edged-port
 poe enable
#

interface GigabitEthernet1/0/19
 port link-type trunk
 port trunk permit vlan 1 10 31
 qos trust dscp
***********

IP phone is on port 1/0/17 and 1/0/19 is an uplink (trunk)

I expected to have vlan 31 outbound frames on int g1/0/19 being correctly vlan tagged and marked at L2 and L3.

When I capture what's in and out of 1/0/19, I see the phone frames correctly tagged as vlan 31, but no CoS or DSCP are marked (all at 0)

Here are the things I verified :

[TEST]dis voice state
 Current voice VLANs: 1
 Voice VLAN security mode: Security
 Voice VLAN aging time: 1440 minutes
 Voice VLAN enabled ports and their modes:
 Port                        VLAN        Mode        CoS        DSCP
 GE1/0/17                    31          AUTO        5          46

[TEST]dis mac-addr vlan 31
MAC Address      VLAN ID    State            Port/NickName            Aging
0080-9f91-cb09   31         VOICE-VLAN       GE1/0/17                 Y

[TEST]dis mac-addr int g1/0/17
MAC Address      VLAN ID    State            Port/NickName            Aging
0019-b97c-dcf2   10         Learned          GE1/0/17                 Y
0080-9f91-cb09   31         VOICE-VLAN       GE1/0/17                 Y

[TEST]dis vlan 31
 VLAN ID: 31
 VLAN type: Static
 Route interface: Configured
 IPv4 address: 192.168.3.1
 IPv4 subnet mask: 255.255.255.0
 Description: ToIP
 Name: ToIP
 Tagged ports:
    GigabitEthernet1/0/17         GigabitEthernet1/0/19
 Untagged ports: None

*******************

My question is : do I need to set a QoS policy ? I expected the automatic voice vlan config to do all the QoS stuff without additionnal config steps...

Have a nice day.

(on HPE 5130 EI "comware" switch)

 ********************

I finally found the solution (with the help of my co-worker) : you MUST create a OUI reference for the phone model.

voice-vlan mac-address mac-address mask oui-mask [ description text ]

Without this, the switch will not consider incoming frames as "voice", even if LLDP has told the phone to put them in the right VLAN.

So, LLDP does NOT insert OUI records in the table, it just tells the phone that there is a voice vlan and it's number.