Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Restore to factory default configuration option missing hp 6125 G/XG switch

LuckyTyagi
Occasional Advisor

Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

I'm trying to restore factory default configuration on my 6125 G/XG backplane switch. All the online forums and release notes suggests that in the Extended Bootware menu i should select option 5 i.e  Restore to Factory Default Configuration.

But i don't have that option in my menu, i see "Modify BootWare Password" option at that place. rest of the menu is same.

I tried deleting main and backup config file as well but still it isn't at factory settings.

I'm unable to find the option to resore factory settings. I tried with reset button on the switch as well, but didn't help. Can anyone please help me out?

17 REPLIES
peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hello
What is software version please?
JY
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

Thanks for replying. What command should i use to display the desired information? I'll send you the output.

-Lucky

peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

display version
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

<6125G/XG Blade Switch>display version
HP Comware Platform Software
Comware Software, Version 5.20.99, Release 2103
Copyright (c) 2010-2012 Hewlett-Packard Development Company, L.P.
HP 6125G/XG Blade Switch uptime is 0 week, 5 days, 10 hours, 59 minutes


Slot 1 (M):
Uptime is 0 weeks,5 days,10 hours,59 minutes
HP 6125G/XG Blade Switch with 1 Processor
1024M bytes SDRAM
256M bytes Nand Flash Memory
Hardware Version is Ver.B
CPLD Version is 003
BootWare Version is 1.05
[SubSlot 0] Back Panel
[SubSlot 1] Front Panel

peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

This is a pretty old version need to update asap latest R2112P07
So just try
Reboot device
During initialization
Press Ctrl+B within five seconfs
Press enter at password prompt
Select 5 restore factory configuration
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

That is the main problem. I don't have the 5th option as restore factory configuration when i do this.

Initial problem was this only.

Anything else that i should try?

sdide
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

SORRY just realised i posted a solution to a wrong switchtype (6125XLG) below ...

the latest version is R2432P01,

from version 2402 and onwards, you can from within user-view in the CLI do:

restore factory-default

That command will :"

• Deletes all configuration files (.cfg files) in the root directories of the storage media.
• Deletes all log files (.log files in the folder /logfile).
• Clears all log information (in the log buffer), trap information, and debugging information.
• Restores the parameters for the BootWare options to the factory-default settings.
After this operation, only the items required for device operation are retained, including the .bin files, the
MAC addresses, and the electronic label information.
"

See "HP 6125XLG Blade Switch Fundamentals Configuration Guide for Software version: Release 240x" page 131

Regards

 

Søren Dideriksen, Network Administrator
Region Midtjylland
sdide
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

if you delete main and backup configuraion-files. What configuration does the switch have when you reboot?

Anyways, the manual says:

 
says on page 104.
reset saved-configuration [backup|main]
 
should delete your config and on reboot, boot with factory defaults.
Regards
 
 
Søren Dideriksen, Network Administrator
Region Midtjylland
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

I also did the same. But somehow it didn't get cleared.

Maybe because i have interconnect 3 and 4 in Active and Standby. One is backup of other and i'm not being able to revert that.

-Lucky

peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

What is result of
Display default-configuration
Display saved
Display running
Display startup
Looks same ?
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

display current-configuration is a big output but not as much as it used to. As i deleted the config file and all the vlan, pvid that were present got erased so seems like new, but it isn't. Attaching outputs [not the complete output of display current-configuration and display running isn't a command]:

<6125G/XG Blade Switch>display current-configuration
#
version 5.20.99, Release 2103
#
sysname 6125G/XG Blade Switch
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user admin
password cipher $c$3$Z2SLFwXAT85E0/95xqzSD0ANJeXfOCc0
authorization-attribute level 3
service-type web
#
interface NULL0
#
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 1 untagged
#
interface GigabitEthernet1/0/2
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5

.......................................

#
interface GigabitEthernet1/1/5
port link-type hybrid
port hybrid vlan 1 untagged
#
interface GigabitEthernet1/1/6
#
interface GigabitEthernet1/1/7
#
interface GigabitEthernet1/1/8

..................................

<6125G/XG Blade Switch>display startup
MainBoard:
Current startup saved-configuration file: NULL
Next main startup saved-configuration file: flash:/config.cfg (This file does not exist.)
Next backup startup saved-configuration file: NULL
<6125G/XG Blade Switch>display saved-configuration
The config file does not exist!
<6125G/XG Blade Switch>

peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Display default ?
Also dir: result ?
sdide
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

How does the "display current", differ from "display default"?

The display current you posted looks pretty default to me (except for the user configuration).

I don't know if the blade-center chassis itself does some - "funny stuff" with the switch configuration.

Regards

Søren Dideriksen, Network Administrator
Region Midtjylland
LuckyTyagi
Occasional Advisor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

<6125G/XG Blade Switch>display default
^
% Unrecognized command found at '^' position.
<6125G/XG Blade Switch>dir
Directory of flash:/

0 -rw- 132 Apr 26 2000 12:00:26 patchstate
1 -rw- 16053376 Jun 05 2012 10:14:37 6125-cmw520-r2103.bin

260736 KB total (243608 KB free)

<6125G/XG Blade Switch>

peyrache
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

May be now must think to update firmware version
Seems pretty old
JY
sdide
Respected Contributor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

Hi,

I think we need somone from HP to explain whats going on here.

As far as I can see, you're running R2103. According to the manual

HP 6125G & 6125G/XG Blade Switches Fundamentals Command Reference for Software version: Release 2103 and later page 114, "display default-configuration" is a supported command.

Anyways:

Have you tried disabling the "password recovery" feature?

] undo password-recovery enable

According to the manual, the option number 5 "<5> Restore to Factory Default Configuration" should appear in the Extended Bootware menu if you use the above command in the CLI (and reboot). However according to the manual this command is available from R2105 and later.

So I guess you really need to upgrade.

Regards

Søren Dideriksen, Network Administrator
Region Midtjylland
hp6125g
Occasional Visitor

Re: Restore to factory default configuration option missing hp 6125 G/XG switch

hi 

i tryed to reset from manu 

Enter your choice(0-9): 5
Password recovery capability is enabled. To perform this operation, first
disable the password recovery capability using the undo password-recovery
enable command in CLI.

the problem i can't login to CLI