Comware-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

S3100 SSH-connection to the switch

KOVIK
Occasional Visitor

S3100 SSH-connection to the switch

Sorry for bad English, used Google traslate :smileysad:

Problems   SSH-connection to the switch

 

1. I created a RSA key for SSH:

 

<H3C>system-view
[H3C]rsa local-key-pair create
The key name will be: 5500G-EI_Host
The range of public key size is (512 ~ 2048).
NOTES: If the key modulus is greater than 512,
It will take a few minutes.
Input the bits in the modulus[default = 512]:2048
Generating keys...
............................+++
.............................................+++
..........++++++++
..++++++++
........

 

2. Allows the user to SSH-connection to the switch:

 

<H3C>system-view
[H3C]local-user admin
[H3C-luser-admin]service-type ssh level 3

 

3. Allow SSH on vty 0

 

<H3C>system-view
[H3C]user-interface vty 0
[H3C-ui-vty0]protocol inbound all

 

4. Using PuTTY to  SSH connect.  Enter login and get error

---------------------------
PuTTY Fatal Error
---------------------------
Disconnected: No supported authentication methods available
---------------------------
ОК   
---------------------------

 

What's the problem? Where is the mistake?

 Telnet-connection all OK

 

P.S. This thread has been moved from ProCurve / ProVision-Based to Comware-Based. -HP Forum Moderator

 

2 REPLIES
xdrop
Occasional Contributor

Re: S3100 SSH-connection to the switch

try this:

ssh user <username> authentication-type all

HP-Browniee
Trusted Contributor

Re: S3100 SSH-connection to the switch

Hi

Just a wild guess:

maybe the problem is in your putty settings, try to change protocol version

 

Kind regards