Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

[SOLVED] Recover bricked HPE 5820 router? Application program does not exist.

 
christian busch
Occasional Contributor

[SOLVED] Recover bricked HPE 5820 router? Application program does not exist.

Hi,

I accidentally bricked my 5820 JG219A. I sucessfully upgraded the firmware to A5800_5820X-CMW520-R1810P13. Thinking it is upgrded so I don't need the bin files anymore, I deleted the A5800_5820X-CMW520-R1810P13.bin on the flash.

Guess only noobs do that.

Now router goes to boot menu, saying the is no application file.

Boot:

 

********************************************************************************
* *
* HPE 5820AF-24XG Switch BOOTROM, Version 303 *
* *
********************************************************************************
Copyright (c) 2010-2015 Hewlett Packard Enterprise Development LP

Creation Date : Nov 10 2015,15:09:38
CPU Clock Speed : 750MHz
Memory Size : 1024MB
Flash Size : 512MB
CPLD Version : 002/006
PCB Version : Ver.A
Mac Address : 20xxxxxx

Application program does not exist.
BootRom password: Not required. Please press Enter to continue.

Password recovery capability is enabled.

BOOT MENU

1. Download application file to flash
2. Select application file to boot
3. Display all files in flash
4. Delete file from flash
5. Restore to factory default configuration
6. Enter BootRom upgrade menu
7. Skip current system configuration
8. Reserved
9. Set switch startup mode
0. Reboot
Ctrl+F: Format File System
Ctrl+P: Skip Super Password
Ctrl+R: Download application to SDRAM and Run
Ctrl+Z: Access EXTEND-ASSISTANT MENU

File System:

Display all file(s) in flash:

File Number File Size(bytes) File Name
================================================================================
1   411011    logfile.log 
2           4    snmpboots 
3     1584    private-data.txt 
4        33     system.xml 
5(*) 4221    config.cfg 
6       447    hostkey_v3 
7        591    serverkey_v3 
8      2962   ~/config.cfg 
9      2366   config2.cfg 
Free space: 526188544 bytes
The current application file is A5800_5820X-CMW520-R1810P13.bin
(*)-with main attribute
(b)-with backup attribute
(*b)-with both main and backup attribute

I can only get XModem to work.

FTP doesnt connect, Laptop to Switch with Serial & Lan cable:
5820: Server: 192.168.1.2 local:192.168.1.3 gateway: 0.0.0.0,
Laptop to port 25: 192.168.1.2,255.255.255.0, gateway blank.

Xmodem set to 9600, 8, N, 1, N, switching to 115200 when loading the file.

I have tried to:

1. Download application file A5800_5820X-CMW520-R1810P13.bin to flash - fails. file not visible in file system. pressing 2 to see application says there is none.

6. Upgrade Full BootRom with A5800_5820X-CMW520-R1810P13.bin - fails

CRTL-R Load application to SDRAM - loads, says invalid file.

Any suggestions how to recover the switch ? I have the config file saved. So happy to do what is needed.

 

[Solution]

So it turned out that loading with Option 1. Download to flash actually works using XModem but you have to be there when the download finished (takes ~65 minutes) to enter the comands to actually load it. If you are not there, I did it overnight, it times out and fails.