Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

STACK 4 1950 IRF > Problems timeout in 4

 
SOLVED
Go to solution
GairHald
Occasional Advisor

STACK 4 1950 IRF > Problems timeout in 4

Hello, I have read a lot on this forum and on other websites, but the solutions that they indicate do not work for me.

https://community.hpe.com/t5/Comware-Based/problems-with-IRF-quot-heartbeat-timed-out-quot/m-p/6143677#M4400

I have 4 1950 switches and I want to stack them with 8 SFP cables using the IRF. The connection is as follows

SW1 ports IRF 1/1 -> 2/2 ports IRF 1/2 -> 4/2
SW2 ports IRF 2/1 -> 3/2 ports IRF 2/2 -> 1/1
SW3 ports IRF 3/1 -> 4/1 ports IRF 3/2 -> 2/1
SW4 ports IRF 4/1 -> 3/1 ports IRF 4/2 -> 1/2

That is, they are in cascade and 1 again connected to 4. This is the scenario I want to do, and the first 3 I have in STACK without problems

[SWUsers]display irf configuration 
 MemberID NewID    IRF-Port1                     IRF-Port2
 1        1        Ten-GigabitEthernet1/0/49     disable                       
 2        2        Ten-GigabitEthernet2/0/49     Ten-GigabitEthernet2/0/50     
 3        3        Ten-GigabitEthernet3/0/49     Ten-GigabitEthernet3/0/50     
[SWUsers]dis
[SWUsers]display ir
[SWUsers]display irf to
[SWUsers]display irf topology 
                              Topology Info
 -------------------------------------------------------------------------
               IRF-Port1                IRF-Port2          
 MemberID    Link       neighbor      Link       neighbor    Belong To
 3           TIMEOUT    ---           UP         2           00e0-fc0f-8c02
 2           UP         3             UP         1           00e0-fc0f-8c02
 1           UP         2             DIS        ---         00e0-fc0f-8c02
[SWUsers]

[SWUsers]display irf link 
Member 1
 IRF Port  Interface                             Status
 1         Ten-GigabitEthernet1/0/49             UP    
 2         disable                               --    
Member 2
 IRF Port  Interface                             Status
 1         Ten-GigabitEthernet2/0/49             UP    
 2         Ten-GigabitEthernet2/0/50             UP    
Member 3
 IRF Port  Interface                             Status
 1         Ten-GigabitEthernet3/0/49             UP    
 2         Ten-GigabitEthernet3/0/50             UP    
[SWUsers]

 

In case the connection between 1 and 4 were a problem, I have disabled it in case it were a problem.

And in the 4 SW I want to add the configuration.

[SWUsers04]display irf configuration
 MemberID NewID    IRF-Port1                     IRF-Port2
 4        4        Ten-GigabitEthernet4/0/49     disable
[SWUsers04]
[SWUsers04]display irf topology
                              Topology Info
 -------------------------------------------------------------------------
               IRF-Port1                IRF-Port2
 MemberID    Link       neighbor      Link       neighbor    Belong To
 4           TIMEOUT    ---           DIS        ---         00e0-fc0f-8c05
[SWUsers04]

 

I have followed all the steps, I have removed and put the configuration back, but it always tells me the same thing:

%Mar  4 23:43:08:300 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is system-view
%Mar  4 23:43:18:442 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is display interface brief | include XGE
%Mar  4 23:46:27:104 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is irf-port 4/1
%Mar  4 23:46:40:380 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is port group interface Ten-GigabitEthernet 4/0/49
%Mar  4 23:47:36:741 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is quit
%Mar  4 23:47:44:348 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is interface Ten-GigabitEthernet 4/0/49
%Mar  4 23:47:48:095 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is undo shutdown
%Mar  4 23:47:48:251 2021 SWUsers04 IFNET/3/PHY_UPDOWN: Ten-GigabitEthernet4/0/49 link status is up.
%Mar  4 23:47:48:252 2021 SWUsers04 IFNET/5/LINK_UPDOWN: Line protocol on the interface Ten-GigabitEthernet4/0/49 is up.
%Mar  4 23:47:51:280 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is quit
%Mar  4 23:48:17:515 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is irf-port-configuration active
%Mar  4 23:48:17:520 2021 SWUsers04 STM/6/STM_LINK_STATUS_UP: IRF port 1 is up.
%Mar  4 23:48:19:618 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is save force
%Mar  4 23:48:30:926 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is display irf
%Mar  4 23:48:37:812 2021 SWUsers04 STM/2/STM_LINK_STATUS_TIMEOUT: IRF port 1 is down because heartbeat timed out.
%Mar  4 23:48:37:813 2021 SWUsers04 STM/3/STM_LINK_STATUS_DOWN: IRF port 1 is down.
%Mar  4 23:48:47:488 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is display irf configuration
%Mar  4 23:49:25:839 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is display irf topology
[SWUsers04]

 

so I don't know what to do anymore, I've also tried to do it on the WEB but neither, it always tells me the same thing, any suggestions? Thanks a lot

5 REPLIES 5
akg7
HPE Pro

Re: STACK 4 1950 IRF > Problems timeout in 4

Hello,

Have you added the command at last when forming the IRF: 'irf-port-confgiuration active'

This error 'heartbeat timed out' can be seen if its not applied

Is switch 4 joining stack without adding in ring (switch 4 and switch 1)?

Connection between switch 4 and switch 1 cannot be a problem.

Please share software version and current config if issue remains.

You can refer one of my post on IRF ring.

https://community.hpe.com/t5/Comware-Based/HP-5800-IRF-configuration/m-p/7094285#.YEF5Q2gzZPY

Thanks!

I am an HPE Employee

Accept or Kudo

Ivan_B
HPE Pro
Solution

Re: STACK 4 1950 IRF > Problems timeout in 4

Hi @GairHald !

In your configuration you have IRF-port 1 on member 3 connected to IRF-port 1 on member 4, as well as IRF-port 2 on member 1 connected to IRF-port 2 on member 4. That is why you see the error about packets timeout.

SW1 ports IRF 1/1 -> 2/2 ports IRF 1/2 -> 4/2
SW2 ports IRF 2/1 -> 3/2 ports IRF 2/2 -> 1/1
SW3 ports IRF 3/1 -> 4/1 ports IRF 3/2 -> 2/1
SW4 ports IRF 4/1 -> 3/1 ports IRF 4/2 -> 1/2

You must connect the physical interfaces of IRF-port 1 on one member to the physical interfaces of IRF-port 2 on the other., e.g. port 1/2 must be conneted to 4/1, port 3/1 must be connected to 4/2.

 

I am an HPE employee

Accept or Kudo

GairHald
Occasional Advisor

Re: STACK 4 1950 IRF > Problems timeout in 4

Hello, I have changed them as you have told me, putting 1/1 -> 2/2, 1/2 -> 2/1 and so on the rest, and now when I up the ports in SW04 (4/0/49 and 4/0/50), the one that is isolated, it restarts automatically all the time, but it doesn't go into STACK, I can't do anything, it just reboots and then administratively donw the ports again in this SW04

GairHald
Occasional Advisor

Re: STACK 4 1950 IRF > Problems timeout in 4

Miraculously now, after trying 4 times, he has joined the stack! Thank you very much !!

Ivan_B
HPE Pro

Re: STACK 4 1950 IRF > Problems timeout in 4

Great news, I am glad I could help you!

For your future reference - "it restarts automatically all the time, but it doesn't go into STACK, I can't do anything, it just reboots and then administratively donw the ports again in this SW04" happens because you performed 'irf-port-configuration active" BEFORE saving the config with IRF interfaces in shutdown state. Last time you did the same mistake:

%Mar  4 23:47:44:348 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is interface Ten-GigabitEthernet 4/0/49
%Mar  4 23:47:48:095 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is undo shutdown
%Mar  4 23:47:48:251 2021 SWUsers04 IFNET/3/PHY_UPDOWN: Ten-GigabitEthernet4/0/49 link status is up.
%Mar  4 23:47:48:252 2021 SWUsers04 IFNET/5/LINK_UPDOWN: Line protocol on the interface Ten-GigabitEthernet4/0/49 is up.
%Mar  4 23:47:51:280 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is quit
%Mar  4 23:48:17:515 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is irf-port-configuration active
%Mar  4 23:48:17:520 2021 SWUsers04 STM/6/STM_LINK_STATUS_UP: IRF port 1 is up.
%Mar  4 23:48:19:618 2021 SWUsers04 SHELL/6/SHELL_CMD: -Line=vty0-IPAddr=10.10.40.4-User=admin; Command is save force

 
Advice: when you configure IRF ports, follow this procedure:

1. Shutdown physical port
2. Attach the physical port to the logical irf-port (port group interface....)
3. Bring the physical port up (undo shutdown)
4. Now the most important part - save the config (s s f)
5. And only now you can activate the IRF (irf-port-configuration active)

It worked from the 4th time now because you were lucky enough to complete saving before the reboot. But if you follow the procedure above, this extreme luck won't be needed anymore (-:

P.S. If 'irf-port-configuration active" has been executed already, then whenever you bring the port up, the switch will reboot as soon as it senses IRF packet and agrees to be Standby. In such cases you may not have time to complete saving configuration before the reboot. In such situations, just disconnect the network cable from the IRF port, undo shutdown, save the configuration and only when save is done, connect the cable back.

 

I am an HPE employee

Accept or Kudo