Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

[Solved] A5120-48G Freeradius 802.1X

slafarguette
Visitor

[Solved] A5120-48G Freeradius 802.1X

Hi,

 

I'm tryning to use 802.1x wired authentication with a freeradius under debian squeeze. Supplicant is XP sp3.

 

My supplicant first authenticate got port authorized and 30 seconds later restart to authenticate.

 

My config for dot1x is the simplest possible like this :

 

 dot1x
 dot1x authentication-method eap
 dot1x free-ip 192.168.0.0 255.255.255.0
#

 

Radius and AAA configuration

 

#
radius scheme system
 server-type extended
 primary authentication 192.168.115.223
 primary accounting 192.168.115.223
 key authentication testing123
 key accounting testing123
 user-name-format without-domain
#
domain system
 authentication lan-access radius-scheme system local
 authorization lan-access radius-scheme system local
 authentication portal local
 access-limit disable
 state active
 idle-cut disable
 self-service-url disable
#

 

802.1x port configuration

 

interface GigabitEthernet1/0/1
 port access vlan 100
 dot1x max-user 1
 undo dot1x handshake
 dot1x

 

Some idea ?

 

Thanks a lot (apologies for my poor english)

 

Edit : I found solution by myself. Errors in dot1x configuration on switch.

1 REPLY
JDAIN
Regular Visitor

Re: [Solved] A5120-48G Freeradius 802.1X

Try Dot1x Port-method Port based