Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Supressing MSTP SNMP traps on the switch

LS1971
Frequent Advisor

Supressing MSTP SNMP traps on the switch

Hi,

 

we have a new iMC installation and I have added our switches. I want to reduce the SNMP traps coming from the access switches (5120-SI). So far I have disabled the UP/DOWN traps with

 

interface GigabitEthernet1/0/1

 undo enable snmp trap updown

 

What I'm still getting are MSTP topology changes which I would like to disable, for example:

 

OID: 1.3.6.1.4.1.25506.8.35.14.6.1

Description: Interface "18" on device "SWITCH(10.10.10.10)" turns into forwarding state in MSTP instance "0".

 

It's OK if iMC gets such SNMP traps from the trunking ports, but I want to disable these traps for the access ports.

 

Any ideas? I would like to supress the SNMP traps on the switches (I know it's possible to ignore them in iMC).

 

Regards, Leonardo

 

Regards, Leonardo
9 REPLIES

Re: Supressing MSTP SNMP traps on the switch

I want to do the same thing. I haven't got a solution yet!

 

For Up/Down alarms - it could get very tedious disabling the alarm on every interface.

 

Set system wide in IMC - System > System Configuration > System Settings > Interface Up/Down Alarm – change “Alarms for PC-connected links” and “Alarms for disconnected links” to 'Filter'. This will switch off all these alarms.

 

Andy

Apachez-
Trusted Contributor

Re: Supressing MSTP SNMP traps on the switch

int range gi 1/0/1 to gi 1/0/48

undo enable snmp trap updown

exit

 

would fix that part but I get your point.

 

I find the log handling in comware a bit confusing, I have still not found out how to get a syslog entry when a new arp entry shows up - please tell if you know how :-)

 

LS1971
Frequent Advisor

Re: Supressing MSTP SNMP traps on the switch

I got a hint in the NetOps Community forum. -> http://www.netopscommunity.net

 

On a 5120-SI switch I disabled the notifications with

 

undo stp port-log all

 

On a 5120-EI switch I disabled the notifications with

 

undo stp port-log instance 0

 

Depending on the Spanning-Tree configuration you'll have to change the above command to suit your needs.

 

Regards, Leonardo

 

Regards, Leonardo
Mark_Waistell
Occasional Contributor

Re: Supressing MSTP SNMP traps on the switch

Please ignore my post below I am unable to delete - it appears I am still getting an alarm after doing these actions. It has worked for other devices but not today.....
"In addition to this Andy you will need to set the Filter on specific interfaces. To do this double click the device then click on "Interface List". This should list the interfaces of the switch - now select the interfaces you want to prevent the Up/Down alarm alerts and click on the "MORE" drop down box to select "Up/Down Alarm Filter. At the new window click OK to confirm and that should stop the alarms on a per port basis."

16again
Respected Contributor

Re: Supressing MSTP SNMP traps on the switch

This topic focuses on blocking the snmp/trap messages fro STP process.    But why not prevent those messages from occurring in the first place? 
Just use admin-edge port and bpdu guard.

Vanuatu
Visitor

Re: Supressing MSTP SNMP traps on the switch

undo enable snmp trap updown 

Apply this command by interface

Dunky
Regular Advisor

Re: Supressing MSTP SNMP traps on the switch

I am having the same problem - how to disable MSTP SNMP messages for specific interfaces?

I have the following interace configuration:

interface GigabitEthernet1/0/10
description End User Client
port access vlan 60
undo enable snmp trap updown
undo enable log updown
loopback-detection enable
stp edged-port enable
port-security max-mac-count 1
port-security port-mode autolearn
port-security intrusion-mode disableport-temporarily
port-security mac-address security aaaa-aaaa-aaaa vlan 60

but I get the following in the log each time the port goes up/down...

%Oct 17 07:15:57:017 2016 SWITCH23 MSTP/6/MSTP_FORWARDING: Instance 0's port GigabitEthernet1/0/10 has been set to forwarding state.
%Oct 17 07:15:57:018 2016 SWITCH23 MSTP/6/MSTP_FORWARDING: Instance 1's port GigabitEthernet1/0/10 has been set to forwarding state.

Globally, I have ""stp bpdu-protection" set.

I done want to disable the MSTP messages globally as these are very useful for the uplinks etc., I just dont need them on the interfaces with PC;s/phones etc connected.

Any help would be most welcome.

 

 

 

Steven-P
Occasional Visitor

Re: Supressing MSTP SNMP traps on the switch

Hi,

Same problem than Dunky, I use RSTP and want to disable SNMP TRAP only on access port.

For people using MSTP maybe there is a solution :

Use different instance for access prot and trunk port.

Exemple :

Access port use instance 1

Trunk port use instance 2

You use the following command : undo stp port log instance 1

Then it should works.

Dunky
Regular Advisor

Re: Supressing MSTP SNMP traps on the switch

Hi Steven. I'm afraid that wouldnt work for me as I have specific VLANs in certain instances and then use stp costs to load balance over various fibre uplinks. I cant therefore change what vlans are in what instances.