Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Topology Change Causing Network Pause

prudin
Occasional Contributor

Topology Change Causing Network Pause

Hi there all, 

I am sure what I am about to ask has been covered in posts in the past, however I am looking for some clarity here. I have an issue that when a managed switch is added to the network, a VMWare server with Aggregated Ports is restarted or a Switch is removed from the network where we lose net connectivity for a brief period of time. This is not always network wide. I have Dual core switches (A5820X) that most of my other switches connect to. Most of my switches are connected via Dual 10G uplinks that are aggregated. 

My other switches are all A5120-EI, and are configured in IRF stacks. My VMware servers have the data networks connected to these switches via multiple 1G or 10G ports and are aggregated in which ever case they are connected. 

I am sure that the issue is an STP related issue. I have spoken with HP support about the issue several times and everytime I get a different answer and the answer is always murky and not explained with any clarity. 

I am wondering if I should add "stp loop-protection" or if it should be something more like "stp port bpdu-protection enable". I want to keep from having loops happen on my network, but at the same time I want to be able to restart a VMware host without having Topology Change go off and upset network traffic.

 

Any thoughts would be greatly appreciated.

3 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Topology Change Causing Network Pause

We need to see your network topology, including any vSwitches within VMWare.

We need to see the STP parameters from each switch, especially - is STP enabled? What is the STP priority? Are all switches using the same STP version and instance?

prudin
Occasional Contributor

Re: Topology Change Causing Network Pause

Hi thanks for your reply, the relevant topology is attached. STP is enabled on all of my switches. The switches are all using the same version as far as I can tell and the same instance. vSwitches are all configured as default switches in vMware. None are setup as distributed switches and except for the two 10G Aggregated connections and two 1G Aggregated connections, both for VM network traffic, there are no additional configurations in the vSwitches.

All POE ports are currently configured as such:

interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 1 untagged
voice vlan 200 enable
poe enable
stp edged-port enable

And non POE ports:

interface GigabitEthernet1/0/3
stp edged-port enable

And switch to switch uplink ports:

interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan all

1G aggregated ports to VMware Hosts:

interface Bridge-Aggregation4
description ESX 6
port link-type trunk
port trunk permit vlan 1 to 4048

10G aggregated ports to VMware Hosts:

interface Bridge-Aggregation6
description ESX 6 
port link-type trunk
port trunk permit vlan all
stp edged-port enable

 

Thank you

 

sdide
Respected Contributor

Re: Topology Change Causing Network Pause

Hi,

On your"1G aggregated ports to VMware Hosts" why don't you have "stp edged-port enable" ?

"stp edged-port enable", means your port will transisition fast to a forwarding state from the blocking state. So during recalculations, which can happen after TCNs non-edge ports can be blocked for a time.

You should only enable this on edge devices. A vmware server using the vswitch even with two or more uplinks are to be seen as an edge device. (Hypervisor uses split horizon forwarding rules)

But - interfaces to other devices forwarding layer 2 frames (switches and such), should NEVER have this option enabled. And therefore it should not be enabled on your uplinks as an example. (You haven't so all is good there)

Regards

Søren Dideriksen, Network Administrator
Region Midtjylland