Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk 3Com 4800g with Cisco 3500xl

knichel
Regular Visitor

Trunk 3Com 4800g with Cisco 3500xl

I am trying to trunk between a 3Com 4800g and a Cisco 3500xl.  I can get the a PC that connects to a vlan 1 port on the cisco switch to connect to the 3com switch and get connectivity.  However, I cannot get anthing on the cisco switch that is on vlan 2 to connect and get dhcp.  I am not a 3com guy, so I am not familiar with the command and configs.


We have 2 vlans on both switches:  Vlan 1 is Admin and Vlan 2 is Student.

 

Our Topology is like this...

 

Internet -> 3Com 4800g -> Cisco 3500xl

 

My Cisco 3500xl Fa0/1 is my trunk

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk

The Cisco switch has Vlan 1 interface with appropriate ip in appropriate subnet.  I can ping addresses in both vlans from the cisco switch (vlan 1 and vlan 2)

 

My 3Com 4800g gi1/0/11 is my trunk on other end.

interface GigabitEthernet1/0/11
 port link-type trunk
 port trunk permit vlan 1 to 2
 undo voice vlan mode auto
 broadcast-suppression pps 3000
 undo jumboframe enable
 lldp compliance admin-status cdp txrx

 I am connected between them with a crossover cable.

 

If I plug a pc into the 3500xl to a port in vlan 1, I get DHCP address and connectivity.  If I plug into a port in vlan 2, I do not.

 

This is really bugging me.  Any help would be appreciated.

 

 

 

6 REPLIES
Fredrik Lönnman
Honored Contributor

Re: Trunk 3Com 4800g with Cisco 3500xl

Looks OK. On the 4800, do you see any mac addresses in vlan2? Does vlan 2 exist? :)

---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

knichel
Regular Visitor

Re: Trunk 3Com 4800g with Cisco 3500xl

I am not familiar with the commands on the HP 4800,  What is the command for viewing mac address in vlan.

 

Yes, vlan 2 exists.  Our orgainzation uses these 4800s for their infrastructure and we use 3 vlans (Admin, Student, Voice).

 

I Appreciate the assistance.

 

 

knichel
Regular Visitor

Re: Trunk 3Com 4800g with Cisco 3500xl

OK, found the command to see mac-addresses in respective vlans.  Yes, I see mac addresses in vlan 2.

Fredrik Lönnman
Honored Contributor

Re: Trunk 3Com 4800g with Cisco 3500xl

Should work then. You do have a DHCP server in vlan 2 also? No DHCP snooping or other security features?
---
CCIE Service Provider
MASE Network Infrastructure [2011]
H3CSE
CCNP R&S

knichel
Regular Visitor

Re: Trunk 3Com 4800g with Cisco 3500xl

Yes, we have a DHCP server in vlan 2.  All PCs on vlan 2 on the 4800 switches get ip address fine.  Seems it is something in the way HP4800 (3Com 4800g) and  cisco 3500xl tag the vlans is causing the problem.  If I put a pc on the cisco switch in vlan 1 it gets an IP in the correct subnet.

Jeff Carrell
Honored Contributor

Re: Trunk 3Com 4800g with Cisco 3500xl

In your Cisco config, you don't show these 2 config parms in the interface:

 

switchport trunk allowed vlan 1 to 2

switchport nonegotiate

 

In my tests of 802.1Q (tagging aka trunking), I had to have these in order for the 802.1Q tags to be in pkts.

 

Another good source of info, the HP Networking and Cisco CLI Reference Guide. A free CLI ref of ProVision, Comware5, and Cisco in side-by-side comparison. Not all inclusive, but alot of the "daily" config needs.  ....and it's free!

 

https://h30590.www3.hp.com/product/HP+Networking+and+Cisco+CLI+Reference+Guide-PDF-6997

 

hth...Jeff