Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk from HP A5820 to Cisco 3750

PDoyle
Occasional Visitor

Trunk from HP A5820 to Cisco 3750

Hi,

 

I wonder if somebody can help with my issue.

 

I have been asked to setup a trunk between a Cisco switch on our nornal network and a HP A5820 that will host our SAN.  The problem I have is that when I bring up a device on either VLAN 3 or 4 on the HP side it cannot pick up a DHCP address from a server in VLAN 3 on the Cisco side.  If I put an ip helper on the Cisco side then it works.

Also, the servers on the HP side cannot see the windows domain when doing a network browse.

 

Both or the problems above seem to point to broadcast issues across the trunk port between the switches.

 

The config of the relevant ports is listed below.

 

Cisco switch

interface TenGigabitEthernet4/1/1

description *** SAN TRUNK Port ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,4,200

switchport mode trunk

 

interface TenGigabitEthernet4/1/2

description *** SAN TRUNK Port ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,4,200

switchport mode trunk

 

 

HP Switch

interface Ten-GigabitEthernet1/0/1

port link-mode bridge

port link-type trunk

port trunk permit vlan 1 3 to 4 200

 

interface Ten-GigabitEthernet1/0/2

port link-mode bridge

port link-type trunk

port trunk permit vlan 1 3 to 4 200

 

I am aware I do not have VLAN 1 set on the cisco side.  Does this matter?

Also I have not aggregated the ports yet but I assume spanning tree should take care of that.  Corect me if I am wrong?

 

All help is much appreciated with this problem.  I have nedium experience with Cisco switches but very little experience with HP switches.

 

Phil

1 REPLY
Arthis
Occasional Advisor

Re: Trunk from HP A5820 to Cisco 3750

Hi,

 

I'll try something like that:

- remove vlan 1 on HP  and DTP on Cisco

 

Cisco switch

interface TenGigabitEthernet4/1/1

description *** SAN TRUNK Port ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,4,200

switchport mode trunk

switchport nonegotiate

 

interface TenGigabitEthernet4/1/2

description *** SAN TRUNK Port ***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,4,200

switchport mode trunk

switchport nonegotiate

 

 

HP Switch

interface Ten-GigabitEthernet1/0/1

port link-mode bridge

port link-type trunk

port trunk permit vlan  3 to 4 200

 

interface Ten-GigabitEthernet1/0/2

port link-mode bridge

port link-type trunk

port trunk permit vlan  3 to 4 200