HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to upgrade hp 10508 switch to comware 7 due to insufficient flash memory

 
SOLVED
Go to solution
RakeshNaik
Occasional Visitor

Unable to upgrade hp 10508 switch to comware 7 due to insufficient flash memory

HI

We have recently brought HPE 10508 switches which have come with comware5. We want to upgrade them to Comware7 (10500_7.10.R7180).  Bin files are more than 200MB whereas the device's flash memory is just 128MB.

Is there any small files to upgrade to Com7 with the existing flash?

Is there an option to upgrade the flash of the device in this model to accomodate bigger file?

Kindly guide us to upgrade to comware7.

Directory of flash:/

0 drw- - Apr 14 2016 13:51:10 logfile
1 drw- - Apr 14 2016 13:51:11 seclog
2 -rw- 35665920 Apr 14 2016 13:30:36 10500-cmw520-r1208p08.bin
3 -rw- 21503 Sep 20 2016 05:59:54 system.xml
4 -rw- 47271 Sep 20 2016 06:00:24 config.cfg

125349 KB total (89579 KB free)

2 REPLIES
parnassus
Honored Contributor
Solution

Re: Unable to upgrade hp 10508 switch to comware 7 due to insufficient flash memory

I think that to upgrade (migrate) a HPE FlexNetwork 10500 Switch Series's Comware 5 based OS to a Comware 7 based OS you first have to ensure that your actual Switch hardware (MPU in particular) meets minimum Hardware requirements to let the migration be possible and to then happen succesfully (consider that SDRAM and Flash Memory are related to each specific MPU, right?).

Minimum Hardware requirements are declared on Comware 5 and 7 Release Notes for your HPE FlexNetwork 10500 Switch Series model.

AFAIK, the MPU (JC614A) used on a HPE FlexNetwork 10500 Switch Series running Comware 5 OS is different with respect to the MPU (JG496A) used on a HPE FlexNetwork 10500 Switch Series running Comware 7 OS: read about it here (As example, the MPU supporting Comware 7 OS provides 4 GB of SDRAM, check with display version command what is the amount of SDRAM your actual MPU is providing).

More clearly: considering an HPE FlexNetwork 10500 Switch Series...the Comware 7 OS (with a version number in the format Release 2xxx) applies only to LSU1SUPB0 (JG496A) MPUs, the LSU1SUPA0 (JC614A/JG375A) MPUs cannot run Comware 7 OS software. Reference: here.

So, as you see, it isn't (only[*]) a problem of tiny MPU's Flash Memory size (not forgetting that Comware 7 Boot and System bin files require, separately, about 28 MBytes and 193 MBytes...while the ipe file requires about 220 MBytes)...on the contrary the Flash Memory size is the least of your worries if your MPU is an LSU1SUPA0.

[*] since a storage space could also be a Compact Flash or an external USB Flash Memory (The switch starts up from the default storage medium. The default storage medium can be the Built-In Flash Memory, a Compact Flash Card or a USB disk).

Not completely unrelated (12500 isn't exactly a 10500)...there is a Comware 5 to 7 migration guide for HPE FlexNetwork 12500 Switch Series that can be of help to quantify things to check before considering a Comware 5 to 7 migration (here).

Hope that help.

VoIP-Buddy
HPE Pro

Re: Unable to upgrade hp 10508 switch to comware 7 due to insufficient flash memory

Unfortunately you cannot upgrade a 10500 MPU with Comware 5 on it.  There are no CF card slots or USB ports available on the MPU's.  The only way to get Comware 7 on your 10500 is to replace the MPU"s with 10500 Comware 7 MPU's.

Regards,

David