cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN access

 
cheehoong
Occasional Advisor

VLAN access

i had 5500G and 4200G switch

as below :



5500G had VLAN 500

4200G had VLAN 400



i had a question is,how to configure tow different VLAN(400 and 500) are communicate ?

i'm appreciate all expertise are can some me some configure example



thank you

This message was edited by cheehoong on 3-25-09 @ 5:25 AM
4 REPLIES
brucexx
Occasional Advisor

Re: VLAN access

The communication between VLANs occurs on layer 3 (IP), you need to implement inter-VLAN-routing. It can be done on the router via sub-interfaces (so-called router on the stick) or if I am not mistaken directly on your switches. I have never done this on the switch but I assume that the principals are the same. I am assuming (looking at my 4500 switch) you need to create VALN interfaces for each VLAN involved in inter-VLAN-routing and a static route between these interfaces.

I am not sure if I understood you correctly is VLAN 500 present on 4200 switch and VLAN 400 present on 5500?



Thanks



PS. Please post you subnet info.

alvaro.madero
Occasional Visitor

Re: VLAN access

To comunicate two VLANS you can create VLAN interfaces in the 5500 and assign ip addresses. Then you have to connect both switches either by using a trunk port on both switches or by assigning a port on the 5500 to be on the VLAN you have on the 4200.

Ex:

-----------5500G------------------

interface vlan 500

ip address 192.168.1.1 255.255.255.0

interface vlan 400

ip address 192.168.2.1 255.255.255.0

interface g1/0/1

port link-type trunk

port trunk permit vlan all



----------------4200G--------------

interface g1/0/1

port link-type trunk

port trunk permit vlan all







cheehoong
Occasional Advisor

Re: VLAN access

i got some question when setup a VLAN in 5500G and 4200G



as i understand VLAN got 3 type which is

1. Access

2. Trunk

3. Hybrid



let said SW 1 had VLAN 1 and VLAN 2, and SW 2 had VLAN 3 and VLAN4

after i configure the SW 1 VLAN1 and SW VLAN 3 as trunk mode. in order to allows VLAN 2 and VLAN 4 to communicate form SW 1 and SW 2 ,should it configure the VLAN 2 and VLAN 4 as hybrid mode?



please advice me

This message was edited by cheehoong on 4-7-09 @ 4:55 AM
cheehoong
Occasional Advisor

Re: VLAN access

i got some question when setup a VLAN in 5500G and 4200G



as i understand VLAN got 3 type which is

1. Access

2. Trunk

3. Hybrid



let said SW 1 had VLAN 1 and VLAN 2, and SW 2 had VLAN 3 and VLAN4

after i configure the SW 1 VLAN1 and SW VLAN 3 as trunk mode. in order to allows VLAN 2 and VLAN 4 to communicate form SW 1 and SW 2 ,should it configure the VLAN 2 and VLAN 4 as hybrid mode?



please advice me