Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Vlan routing on HP 5800 Switch

calleghf
Occasional Advisor

Vlan routing on HP 5800 Switch

Hello

I wonder if someone can give me some help on a very simple configuration on a s5800 that I inherited a few days ago.

I'm trying to set up inter vlan routing between two VLAN in an extremely simple scenario. 

I have access port 1/0/1 assigned to VLAN 10 -- SVI is 10.15.209.1 / 24

I have access port 1/0/10 assigned to VLAN 20 -- SVI is 20.20.20.1 / 24

I have a Windows 10 PC connected to port 1/0/1 at IP 10.15.209.90 (PC A) Gateway 10.15.209.1

I have a Windows 10 PC connected to port 1/0/10 at IP 20.20.20.20 (PC B) Gateway 20.20.20..1

 

From the s5800 console I can ping both PCs so it's not an issue on the firewall on the PCs (it's actually disabled)

From the PCs I can only ping the local Gateway but not the other side. The PCs are unable to ping each other.

What am I missing ? How can I route between the VLANs ?    

I enclose the configuration below. I also reset the switch to factory default, no help. 

 

Thanks a lot 

Fabio

 

<H3C>display current-configuration
#
version 5.20, Release 1808P25
#
sysname H3C
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
password-recovery enable
#
vlan 1
#
vlan 10
#
vlan 20
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
interface NULL0
#
interface Vlan-interface1
ip address dhcp-alloc client-identifier mac Vlan-interface1
#
interface Vlan-interface10
ip address 10.15.209.1 255.255.255.0
#
interface Vlan-interface20
ip address 20.20.20.1 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-mode bridge
port access vlan 10
#
interface GigabitEthernet1/0/2
port link-mode bridge
#
interface GigabitEthernet1/0/3
port link-mode bridge
#
interface GigabitEthernet1/0/4
port link-mode bridge
#
interface GigabitEthernet1/0/5
port link-mode bridge
#
interface GigabitEthernet1/0/6
port link-mode bridge
#
interface GigabitEthernet1/0/7
port link-mode bridge
#
interface GigabitEthernet1/0/8
port link-mode bridge
#
interface GigabitEthernet1/0/9
port link-mode bridge
#
interface GigabitEthernet1/0/10
port link-mode bridge
port access vlan 20
#
interface GigabitEthernet1/0/11
port link-mode bridge
#
interface GigabitEthernet1/0/12
port link-mode bridge
#
interface GigabitEthernet1/0/13
port link-mode bridge
#
interface GigabitEthernet1/0/14
port link-mode bridge
#
interface GigabitEthernet1/0/15
port link-mode bridge
#
interface GigabitEthernet1/0/16
port link-mode bridge
#
interface GigabitEthernet1/0/17
port link-mode bridge
#
interface GigabitEthernet1/0/18
port link-mode bridge
#
interface GigabitEthernet1/0/19
port link-mode bridge
#
interface GigabitEthernet1/0/20
port link-mode bridge
#
interface GigabitEthernet1/0/21
port link-mode bridge
#
interface GigabitEthernet1/0/22
port link-mode bridge
#
interface GigabitEthernet1/0/23
port link-mode bridge
#
interface GigabitEthernet1/0/24
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/25
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/26
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/27
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/28
port link-mode bridge
#
load xml-configuration
#
load tr069-configuration
#
user-interface aux 0
user-interface vty 0 15

4 REPLIES
parnassus
Honored Contributor

Re: Vlan routing on HP 5800 Switch

Are the Windows Firewalls really disabled (all Firewall's profiles) on both hosts? IP Routing, switch side, is automatically enabled when SVIs are defined (as you already did).
calleghf
Occasional Advisor

Re: Vlan routing on HP 5800 Switch

Thanks Parnassus for replying as usual. Yes firewalls are completely disabled. If they were enabled I would not not even be able to ping from the s5800 to the PCs but I can, it's just that the PCs cannot ping each other. I spent a lot of time trying. IF there is no solution I will throw this s5800 in the bin :-)  I have no problems with Cisco. Also I remember a 5700 switch worked immediately a while ago but this is very problematic.

Thanks

Fabio 

parnassus
Honored Contributor

Re: Vlan routing on HP 5800 Switch

Trashing into a bin is not a solution (well if you dislike it so much I'll made you a purchase offer... 8-) ).

Said so, have you collected some preliminary diagnostic information (commands: display ...)? was the 5800 in a factory default state before you started to configure it? also...IMO the Firmware your 5800 is currently running on is a little bit old (2014), have you ever planned to update it to latest available as of today (11/2017) and repeat your test?

AFAIK your Switch configuration looks good to me.

Do network configurations on your two PCs include respective default gateways? I hope so...
Highlighted
calleghf
Occasional Advisor

Re: Vlan routing on HP 5800 Switch

Hi Parnassus, 

Yes the default gateway is set on the respective PCs. When I got the switch it was pre-used so it had a set of VLANs and other stuff configured, I erased the system config and went back to defaults. I will take up your suggestions and flash the firmware, see if I can make some progress. ...will get back with the result tomorrow or Monday,

Thanks a gain

Fabio