Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

 
Occasional Advisor

Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Hello 

 

I am still searching/testing correct and functional Voice VLAN setup for HPE Comware switches and Alcetel VoIP.

We got here some 5120 and 5130 switches as EDGE.
Core is 5940. 
All connections are betwwe switches are with BAG. It looks like for example like this:

HPE.5120 <=BAG=> HPE.5940 <=BAG=> HPE.5130

On the edge switches are VoIP Telephones connected. Some alone and some with computer connected on it.

My configs looks this:

---#5120#--- 

vlan 100 
des DATA

vlan 10
des VOIP

voice vlan security enable
voice vlan aging 30
voice vlan mac-address 0080-9f00-0000 mask ffff-ff00-0000 description Alcatel phone
voice vlan mac-address 487a-5500-0000 mask ffff-ff00-0000 description Alcatel phone

- one of Edge PORTs:

interface GigabitEthernetX/0/X
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 100 untagged
port hybrid pvid vlan 100
broadcast-suppression pps 500
multicast-suppression pps 500
unicast-suppression pps 500
stp edged-port enable
stp root-protection
qos apply policy INBOUND_POLICY_LYNC inbound
qos trust dscp
voice vlan qos trust
voice vlan 10 enable
poe enable
quit

interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
stp loop-protection
mvrp enable
mad enable

interface GigabitEthernet1/0/52
port link-type trunk
port trunk permit vlan all
stp loop-protection
qos trust dscp
sflow sampling-rate 1000
sflow flow collector 1
mvrp enable
port link-aggregation group 1
#
interface GigabitEthernet3/0/52
port link-type trunk
port trunk permit vlan all
stp loop-protection
qos trust dscp
sflow sampling-rate 1000
sflow flow collector 1
mvrp enable
port link-aggregation group 1

 

 

----#5130#---- 

vlan 100 
des DATA

vlan 10
des VOIP

voice-vlan security enable
voice-vlan aging 30
voice-vlan mac-address 0080-9f00-0000 mask ffff-ff00-0000 description Alcatel phone
voice-vlan mac-address 487a-5500-0000 mask ffff-ff00-0000 description Alcatel phone

- one of Edge PORTs:

interface GigabitEthernetX/0/X
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 100 untagged
port hybrid pvid vlan 100
broadcast-suppression pps 500
multicast-suppression pps 500
unicast-suppression pps 500
stp edged-port enable
stp root-protection
qos apply policy INBOUND_POLICY_LYNC inbound
qos trust dscp
voice-vlan qos trust
voice-vlan 10 enable
poe enable
quit

interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
stp loop-protection
mvrp enable
mad enable

interface Te 1/0/52
port link-type trunk
port trunk permit vlan all
stp loop-protection
qos trust dscp
sflow sampling-rate 1000
sflow flow collector 1
mvrp enable
port link-aggregation group 1
#
interface Te 3/0/52
port link-type trunk
port trunk permit vlan all
stp loop-protection
qos trust dscp
sflow sampling-rate 1000
sflow flow collector 1
mvrp enable
port link-aggregation group 1

 

 

----#5940#--- 

vlan 100 
des DATA

vlan 10
des VOIP


EVERY UPLINK BAG

interface Bridge-AggregationXXX
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
stp loop-protection
mvrp enable
mad enable

interface Te 1/0/1
port link-type trunk
port trunk permit vlan all
stp root-protection
qos trust dscp
mvrp enable
port link-aggregation group XXX
#
interface Te 2/0/1
port link-type trunk
port trunk permit vlan all
stp root-protection
qos trust dscp
mvrp enable
port link-aggregation group XXX

 

 

---------------

I think, that this is correct setup. But I am not sure if it is correct setup for Alcatel Telephony. Because from PBX it looks lie that the phones got 5/46 but if I make settings without qos trust dscp command, on the display voice-vlan state command comes 6/46.

I am thinking abou manual setup for ports, but I am not sure.

Must I change some settings in ours 4400 entrerprise PBX? This is all the time without change.

So what is the correct setup?

 

 

 

6 REPLIES 6
HPE Pro

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Hello,

I would encourage you to check this post:

https://community.hpe.com/t5/Comware-Based/Should-I-use-Voice-Vlan-27-Enable-or-LLDP-voice-vlan-27/td-p/6962898#.XUP5h-gzaUk

There are two different Voice VLAN features, and you are using the "Manual" Voice VLAN, which I would not encourage and is supported only for legacy phones that can't LLDP. LLDP-Voice-VLAN is much improved and does not have some of the limitations (like aging out) that the old manual voice VLAN has.

Best regards,
Justin

Working @ HPE
Accept or Kudo
Occasional Advisor

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Thank you for answers.

 

What about uplink ports. Must it be with

qos trust dscp

I got everywhere 2 Interfaces with BAG connection. BAG ist with LACP. And on BAG is it not enabled. I work only on intarfaces.

 

+

Can make problems Jumbopackets?

 

 

HPE Pro

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Hello,

For more information about Manual vs LLDP Voice VLAN, I almost forgot about this old post I made

https://community.hpe.com/t5/Comware-Based/HP-H3C-5120-48G-SI/td-p/5762193#.XUQLEOgzaUk

As for your configuration, have you changed it to LLDP-Voice instead of the manual voice vlan configuration?

That aside, I notice your edge port configuration references a voice vlan "10", but this Voice VLAN is not being tagged on the Hybrid Port:

port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 100 untagged
port hybrid pvid vlan 100

For VoIP phones, the Voice VLAN is generally tagged and the Data (PC) VLAN untagged over the link. The VLAN tagging for your voice vlan 10 should be added here.

 

Best regards,
Justin

Working @ HPE
Accept or Kudo
Occasional Advisor

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Are you sure about it. I have found somwhere here, that correct ist without Tagged. But now I can not find it.

 

 

HPE Pro

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

Hello,

Not entirely, haven't set it up in a while. I had a look through the docs, and it looks like the voice vlan x command will tag it for you, if you are using the automatic mode, so that should be fine.

https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=mmr_sf-EN_US000005337&withFrame

In automatic mode, user enable the voice VLAN on the switch, and the switch automatically makes the port a member of this VLAN if it detects a frame that contains a voice packet. The switch then starts an aging timer. If no other voice traffic is received before the timer expires, the switch removes the port from the voice VLAN (until it receives voice traffic again).

 

One thing that might be interfering with your QoS DSCP is that you are enabling "qos trust dscp" on the edge and uplink ports, while it should only be enabled on the uplink to 'trust' the priority set by DSCP. Voice VLAN should also automatically configure the priority on the edge port for you. Make sure the priority is trusted on all uplinks where the voice traffic is flowing.

See: https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-c02642125&withFrame

Configuring QoS priority settings for voice traffic on an interface

By default, an interface modifies the CoS value and the DSCP value.

Best regards,
Justin

Working @ HPE
Accept or Kudo
Occasional Advisor

Re: Voice VLAN - HPE Comware switch and Alcatel VoIP Telephony

And how it works in BaG - Bridge aggregation groups.

 

Slave ports got those settings. But BAG cannot be configured.