Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Why only one GigabitEthernet interface?

SOLVED
Go to solution
jim80z
Occasional Visitor

Why only one GigabitEthernet interface?

All,

 

I have a H3C WX3024 switch.  It is at factory defaults after I tried to work through setting it up. Some info on the switch:

- SW Version 3111P12

- HW Version B

- Bootrom Version 1.16

 

I have logged into the default webpage 192.168.0.100 and have set only the following

- admin passowrd

- country

- and set a new IP number for VLAN-Interface1

 

Looking at all the manual screenshots I should be able to see all the gigabitethernet interfaces ie from 1/0/1 to 1/0/24........all that is actually displayed is 1/0/1. So if I look at interfaces in the web mgmt I see gigabitethernet1/0/1,  NULL0,  and Vlan-Interface1.

 

Now I know I can get to OAP from the console and see them in there and I know you can set a mgmt IP on the OAP (ie oap connect slot 0, set a different IP number then attach to the switch HW console), but why isnt it appearing in the unified front end so I can attach ether ports to VLANs etc?

 

I have other questions but right now the missing 23 ports has got me beat.

 

Thanks in advance

 

Jim

8 REPLIES
Peter_Debruyne
Honored Contributor

Re: Why only one GigabitEthernet interface?

Hi Jim,

 

This is because the WX3000 series is actually 2 devices :

* 1 classic network switch with 24 ports

* 1 wireless controller with 1 gigabit port, internally connected to the classic switch

 

When you open a console connection, you are connected to the wireless controller ( having 1 gigabit port). You can then switch to the classic switch with the

 oap connect slot 0

command, which brings you to the console of the switch.

In that context you can manage the switch. One of these ports (I believe port g1/0/25) is internally connected to the g1/0/1 of the wireless controller. So any vlan tag (port link-type trunk) should be configured on both the switch side port connecting to the controller and on the controller port connecting to the switch (g1/0/1).

 

Remember that these are 2 devices, running independent firmware, so you can configure an IP address on the switch and 1 on the controller. So you will have 2 web interfaces which are available, and so on.

If you handle the box as 2 devices, you should be fine.

 

Not a straight-forward device IMO, but once you get this principle you should be ok.

 

best regards,Peter

jim80z
Occasional Visitor

Re: Why only one GigabitEthernet interface?

Peter

 

Thanks for the answer. Thanks for confirming the duality. Before I reset to factory defaults both sides of the switch I did get both portals going. What threw me was that the documentation has the wireless portal side showing all the etherports in the screen dumps, so I figured I goofed somewhere....reset to factory and ask the question.

 

Now the second bit of your answer really got my interest. When I had both portals going I did set some of the switch ports to VLAN Access ports (9-24) to VLAN 20 while the others to VLAN1 (1-8). Then I tried to set port 2 as a trunk to link with a procurve and have VLAN 1 and 20 traverse. It didnt work. Are you saying that I should set port 1 for this purpose? That is set port one on the wirless engine to trunk and on the switch engine set port 1 to trunk as well?

 

Many thanks

 

Jim

Peter_Debruyne
Honored Contributor

Re: Why only one GigabitEthernet interface?

Hi Jim,

 

If you want certain vlans to reach to wireless controller, you should configure 2 switch ports (login on console of switch)

* an external facing interface to e.g. the procurve :

int g1/0/2

 des Switch UPLINK to external network

 port link-type trunk

 port trunk permit vlan 1 20

* the internal facing interface to the wireless controller:

int g1/0/29

 des Switch UPLINK to wifi-controller

 port link-type trunk

 port trunk permit vlan 1 20

 

Next you should configure the controller (login on console of controller)

int g1/0/1

 port link-type trunk

 port trunk permit vlan 1 20

 

That should do it,

 

regards,Peter

jim80z
Occasional Visitor

Re: Why only one GigabitEthernet interface?

Hi Peter

 

Did the below. Config dump below (with user stuff removed and IPs changed). Port 2 is definitely connected to the procurve (1800-24G) switch (port 3). When I set port 3 on the procurve switch to trunked, the WX3024 and everything on it loses connectivity to systems hanging off the procurve. Correction to this statement....if I have a system sitting on the WX3024 on one of the vlan 20 ports (6-24) then they have appropriate connectivity......but anything on vlan 1 does not (ports 1-8 on WX30024)  including switch and access IPs of the WX.

On the procurve things are pretty simple :

- I have defined VLAN 20, VLAN 1 was already there as per default

- I associated port 3 to both VLANs

- and then select port 3 to be trunked

 

Any ideas. Note I have the procurve uplinking to a DELL PowerConnect 5224 successfuly and behaving (port 4 on the procurve).

 

----------------------------------

 

Some snaps from the procurve

 

 

 

 

-------------------------

 

CONFIGS

 

FROM THE CONTROLLER


version 5.20, Release 3111P12
#
sysname JimsSurveillance
#
super password level 3 simple XXXXX
#
domain default enable system
#
telnet server enable
#
port-security enable
#
portal trap server-down
#
oap management-ip A.B.C.250 slot 0
#
wlan country-code AU
#
vlan 1
#
vlan 20
description OrangeNet
#
radius scheme system
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
wlan rrm
dot11a mandatory-rate 6 12 24
dot11a supported-rate 9 18 36 48 54
dot11b mandatory-rate 1 2
dot11b supported-rate 5.5 11
dot11g mandatory-rate 1 2 5.5 11
dot11g supported-rate 6 9 12 18 24 36 48 54
#
interface NULL0
#
interface Vlan-interface1
ip address A.B.C.252 255.255.255.0
#
interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan 1 20
#

 

FROM THE SWITCH

 

#
sysname JimsSurveillanceOAP
#
oap management-ip A.B.C.252 slot 0
#
radius scheme system
#
domain system
#
local-user admin
password simple XXXX
service-type telnet
level 3
#
vlan 1
#
vlan 20
description OrangeNet
#
interface Vlan-interface1
ip address A.B.C.250 255.255.255.0
#
interface Aux1/0/0
#
interface GigabitEthernet1/0/1
#
interface GigabitEthernet1/0/2
port link-type trunk
port trunk permit vlan 1 20
description Switch UPLINK to external network
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5
#
interface GigabitEthernet1/0/6
#
interface GigabitEthernet1/0/7
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
port access vlan 20
#
interface GigabitEthernet1/0/10
port access vlan 20
#
interface GigabitEthernet1/0/11
port access vlan 20
#
interface GigabitEthernet1/0/12
port access vlan 20
#
interface GigabitEthernet1/0/13
port access vlan 20
#
interface GigabitEthernet1/0/14
port access vlan 20
#
interface GigabitEthernet1/0/15
port access vlan 20
#
interface GigabitEthernet1/0/16
port access vlan 20
#
interface GigabitEthernet1/0/17
port access vlan 20
#
interface GigabitEthernet1/0/18
port access vlan 20
#
interface GigabitEthernet1/0/19
port access vlan 20
#
interface GigabitEthernet1/0/20
port access vlan 20
#
interface GigabitEthernet1/0/21
port access vlan 20
#
interface GigabitEthernet1/0/22
port access vlan 20
#
interface GigabitEthernet1/0/23
port access vlan 20
#
interface GigabitEthernet1/0/24
port access vlan 20
#
interface GigabitEthernet1/0/25
shutdown
port access vlan 20
#
interface GigabitEthernet1/0/26
shutdown
port access vlan 20
#
interface GigabitEthernet1/0/27
shutdown
port access vlan 20
#
interface GigabitEthernet1/0/28
shutdown
port access vlan 20
#
interface GigabitEthernet1/0/29
stp disable
port link-type trunk
port trunk permit vlan 1 20
description Switch UPLINK to wifi-controller
#
interface NULL0
#
user-interface aux 0
user-interface vty 0 4
authentication-mode scheme
user privilege level 3
#

 

 

Peter_Debruyne
Honored Contributor

Re: Why only one GigabitEthernet interface?

Hi,

 

I cannot see the Procurve 1800 snapshots, and to be honest, have no experience with these models. I remember that it is webbased, and that you have to set a pvid or something like that in the interface ?

 

The other config seems ok to me.

 

You can do some troubleshooting on the switch/controller with these commands:

 # check vlan 1 mac devices

dis mac-address vlan 1

 # check if you see some other mac hosts

dis mac-address vlan 20

 # check arp tables

dis arp

 

Cannot really help you with the1800 device ...

 

regards,Peter

 

 

jim80z
Occasional Visitor

Re: Why only one GigabitEthernet interface?

Peter

I must have been editing my post as you were typing yours. Did you see the following amendment "When I set port 3 on the procurve switch to trunked, the WX3024 and everything on it loses connectivity to systems hanging off the procurve. Correction to this statement....if I have a system sitting on the WX3024 on one of the vlan 20 ports (6-24) then they have appropriate connectivity......but anything on vlan 1 does not (ports 1-8 on WX30024) including switch and access IPs of the WX". Yes re PVID on the procurve , I set it to 1....but the rest is pretty brain dead simple.

So it looks like vlan20 is trunking fine but not vlan1.......does the WX have a feature where it does not let vlan1 trunk? Special setting?

BTW thanks a heap for your help.

Jim

Peter_Debruyne
Honored Contributor
Solution

Re: Why only one GigabitEthernet interface?

ok, now I see. The Procurve 1800 will probably send vlan 1 as tagged as well, while the controller - switch are by default sending vlan 1 untagged (since it is the PVID on their ports).

 

So on the switch port to the procurve, you need to change the PVID to some other vlan (any other), since only the PVID is sent untagged, all the others are tagged over the link.

 

int g1/0/2

 port trunk pvid vlan 4094

 

That should make it work.

jim80z
Occasional Visitor

Re: Why only one GigabitEthernet interface?

Peter

Your the best. You were spot on all the way......the only thing that needs to be done together with setting PVID on the WX to 4094 is to set the PVID on the procurve to "none". If its set to vlan 1 or 20 (even if the WX is set to 4094) it will still have problems.

Thankyou very much for your help!

PS anyone reading this I found saving the config and rebooting the WX after any change a thing to do.....some settings dont stick as soon as they are changed in the console.