Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

bgp between switches/router and transport vpn-target and import/export on the other site

SOLVED
Go to solution
Tobias L.
Occasional Advisor

bgp between switches/router and transport vpn-target and import/export on the other site

Hi,

I do not know it is possible. I want to transport the vpn-target between two switches with bgp and use the vpn-target import-extcommunity to import the route to the vpn instance. My configuration so far:

I want to import switch1 vpn-instance (rd 65001:3) to the vpn-instance (rd 65000:2) switch2. My transport vpn instance is rd 65001:9 and 65000:99.

At the moment the route to vpn-instance rd 65001:3 of switch 1 gets imported to switch 2 through my Transport VPN-Instance and the other way round. But it would be nice to filter it further within the source and target vpn-instance. 

Is this possible?

Switch1: AS65001
Switch2: AS65000


Switch 1 Configuration:
ip vpn-instance Transport-9.9.9.0/24
 route-distinguisher 65001:9
 vpn-target 65001:9 65001:3 import-extcommunity
 vpn-target 65001:9 export-extcommunity
#
ip vpn-instance test-3.3.3.0/24
 route-distinguisher 65001:3
 vpn-target 65001:3 65001:9 import-extcommunity
 vpn-target 65001:3 export-extcommunity

bgp 65001
 router-id 9.9.9.1
 #
 ip vpn-instance Transport-9.9.9.0/24
  peer 9.9.9.2 as-number 65000
  #
  address-family ipv4 unicast
   network 9.9.9.0 255.255.255.0
   peer 9.9.9.2 enable
   peer 9.9.9.2 advertise-community
   peer 9.9.9.2 advertise-ext-community
   peer 9.9.9.2 label-route-capability
   peer 9.9.9.2 next-hop-local
 #
 ip vpn-instance test-3.3.3.0/24
  #
  address-family ipv4 unicast
   network 3.3.3.0 255.255.255.0




Switch2 Configuration:
ip vpn-instance Transport-9.9.9.0/24
 route-distinguisher 65000:99
 vpn-target 65000:99 65000:2 import-extcommunity
 vpn-target 65000:99 export-extcommunity
#
ip vpn-instance test-2.2.2.0/24
 route-distinguisher 65000:2
 vpn-target 65000:2 65000:99 import-extcommunity
 vpn-target 65000:2 export-extcommunity

bgp 65000
 router-id 9.9.9.2
 #
 ip vpn-instance Transport-9.9.9.0/24
  peer 9.9.9.1 as-number 65001
  #
  address-family ipv4 unicast
   network 9.9.9.0 255.255.255.0
   peer 9.9.9.1 enable
   peer 9.9.9.1 advertise-community
   peer 9.9.9.1 advertise-ext-community
   peer 9.9.9.1 label-route-capability
   peer 9.9.9.1 next-hop-local
 #
 ip vpn-instance test-2.2.2.0/24
  #
  address-family ipv4 unicast
   network 2.2.2.0 255.255.255.0




4 REPLIES
Mike_ES
Valued Contributor

Re: bgp between switches/router and transport vpn-target and import/export on the other site

Hi,

Could you please show following outputs:

Switch1: AS65001

display bgp vpn-instance Transport-9.9.9.0/24

display bgp vpn-instance test-3.3.3.0/24

 

Switch2: AS65000

display bgp vpn-instance Transport-9.9.9.0/24

display bgp vpn-instance test-2.2.2.0/24

 

Second, do you have BGP peers and session established for vpn-inside Transport-9.9.9.0/24 ?

Michal

 

Tobias L.
Occasional Advisor

Re: bgp between switches/router and transport vpn-target and import/export on the other site

Hi,
sorry for the late answer. I figured out how to transport the routes. Mainly I had to enable mpls ldp to allow the vpn-target import/export on both sides. But now I am stuck with mpls ldp.
I want to get from 5.5.5.1 (client device) to 6.6.6.1 (client device). The routing table of the VPN-Instance. I am missing the proper mpls configuration so I get if I try to reach from 5.5.5.1 the destination 6.6.6.1 I receive with mpls packet debugging the following mpls error. I think I have forgotten something inside the mpls configuration. Can anyone give me an hint what's wrong?

*Apr  6 12:35:47:809 2016 8.8.8.1 MPLSFW/7/MPLSFW:
MPLS Forward: Receiving IP packet, len = 84, s = 5.5.5.1, d = 6.6.6.1, TOS = 0, TTL = 254.

*Apr  6 12:35:47:809 2016 8.8.8.1 MPLSFW/7/MPLSFW:
MPLS Forward: Discarding because failed to get fwd info by NID 4294967295!



[8.8.8.1]dis ip routing-table vpn-instance Google-5.5.5.0/24

Destinations : 15       Routes : 15

Destination/Mask   Proto   Pre Cost        NextHop         Interface
0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0
2.2.2.0/24         BGP     130 0           2.2.2.254       Vlan22
3.3.3.0/24         BGP     255 0           8.8.8.2         Vlan88
5.5.5.0/24         Direct  0   0           5.5.5.254       Vlan55
5.5.5.0/32         Direct  0   0           5.5.5.254       Vlan55
5.5.5.254/32       Direct  0   0           127.0.0.1       InLoop0
5.5.5.255/32       Direct  0   0           5.5.5.254       Vlan55
6.6.6.0/24         BGP     255 0           8.8.8.2         Vlan88
127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0
127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0
127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0
127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0
224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0
255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
[8.8.8.2]dis ip routing-table vpn-instance Microsoft-6.6.6.0/24

Destinations : 13       Routes : 13

Destination/Mask   Proto   Pre Cost        NextHop         Interface
0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0
5.5.5.0/24         BGP     255 0           8.8.8.1         Vlan88
6.6.6.0/24         Direct  0   0           6.6.6.254       Vlan66
6.6.6.0/32         Direct  0   0           6.6.6.254       Vlan66
6.6.6.254/32       Direct  0   0           127.0.0.1       InLoop0
6.6.6.255/32       Direct  0   0           6.6.6.254       Vlan66
127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0
127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0
127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0
127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0
224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0
224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0
255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

 

 

I change the configuration significant, so again the both switch configurations stripped of the default settings.

Switch 1:

ip vpn-instance Google-5.5.5.0/24
 route-distinguisher 65000:55
 vpn-target 65000:55 65000:22 65000:33 65000:66 import-extcommunity
 vpn-target 65000:55 export-extcommunity
#
ip vpn-instance test-2.2.2.0/24
 route-distinguisher 65000:22
 vpn-target 65000:22 65000:33 65000:55 import-extcommunity
 vpn-target 65000:22 export-extcommunity
#
 irf mac-address persistent timer
 irf auto-update enable
 undo irf link-delay
 irf member 1 priority 1
#
 ip ttl-expires enable

#
vlan 1
#
vlan 22
#
vlan 55
#
vlan 88

mpls ldp
 lsp-trigger all
 import bgp
 lsr-id 8.8.8.1
#
interface NULL0
#
interface Vlan-interface22
 ip binding vpn-instance test-2.2.2.0/24
 ip address 2.2.2.254 255.255.255.0
#
interface Vlan-interface55
 ip binding vpn-instance Google-5.5.5.0/24
 ip address 5.5.5.254 255.255.255.0
#
interface Vlan-interface88
 ip address 8.8.8.1 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls ldp transport-address interface
#
interface FortyGigE1/0/53
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
#

bgp 65000
 router-id 8.8.8.1
 peer 8.8.8.2 as-number 65000
 #
 address-family vpnv4
  undo policy vpn-target
  peer 8.8.8.2 enable
 #
 ip vpn-instance Google-5.5.5.0/24
  #
  address-family ipv4 unicast
   network 5.5.5.0 255.255.255.0
 #
 ip vpn-instance test-2.2.2.0/24
  #
  address-family ipv4 unicast
   network 2.2.2.0 255.255.255.0
#



Switch 2:
#
ip vpn-instance Microsoft-6.6.6.0/24
 route-distinguisher 65000:66
 vpn-target 65000:66 65000:55 import-extcommunity
 vpn-target 65000:66 export-extcommunity
#
ip vpn-instance test-3.3.3.0/24
 route-distinguisher 65000:33
 vpn-target 65000:33 65000:22 65000:55 import-extcommunity
 vpn-target 65000:33 export-extcommunity
#
mpls ldp
 lsp-trigger all
 import bgp
 lsr-id 8.8.8.2
#
interface NULL0
#
interface Vlan-interface33
 ip binding vpn-instance test-3.3.3.0/24
 ip address 3.3.3.254 255.255.255.0
#
interface Vlan-interface66
 ip binding vpn-instance Microsoft-6.6.6.0/24
 ip address 6.6.6.254 255.255.255.0
#
interface Vlan-interface88
 ip address 8.8.8.2 255.255.255.0
 mpls enable
 mpls ldp enable
 mpls ldp transport-address interface
#
interface FortyGigE1/0/53
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
#
bgp 65000
 router-id 8.8.8.2
 peer 8.8.8.1 as-number 65000
 #
 address-family vpnv4
  undo policy vpn-target
  peer 8.8.8.1 enable
 #
 ip vpn-instance Microsoft-6.6.6.0/24
  #
  address-family ipv4 unicast
   network 6.6.6.0 255.255.255.0
 #
 ip vpn-instance test-3.3.3.0/24
  #
  address-family ipv4 unicast
   network 3.3.3.0 255.255.255.0
#

 

Tobias L.
Occasional Advisor
Solution

Re: bgp between switches/router and transport vpn-target and import/export on the other site

OK now it works. The solution is, to create a loopback interface, configure the static routes and let bgp connect through the loopback. After that the mpls routing works.

freds1
New Member

Re: bgp between switches/router and transport vpn-target and import/export on the other site

Could you please send the latest configuration after it worked for you

Thanks in advance