Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

configure scp transfers 5920

leondv
Visitor

configure scp transfers 5920

Hi all,

I have a issue with the backup of the startup.cfg file with a scp transfer. The switch is running 5920-cmw710-system-r2422p01 firmware and returns "request failed on channel 0" with scp transfers. See logging and config below:

------------------

Scp log:

scp -v testscp@10.130.1.40:startup.cnf /tmp
Executing: program /usr/bin/ssh host 10.130.1.40, user testscp, command scp -v -f startup.cnf
OpenSSH_5.3p1, OpenSSL 1.0.1e-fips 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 10.130.1.40 [10.130.1.40] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/identity-cert type -1
debug1: identity file /root/.ssh/id_rsa type 1
debug1: identity file /root/.ssh/id_rsa-cert type -1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: identity file /root/.ssh/id_dsa-cert type -1
debug1: identity file /root/.ssh/id_ecdsa type -1
debug1: identity file /root/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 1.99, remote software version Comware-7.1.045
debug1: no match: Comware-7.1.045
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '10.130.1.40' is known and matches the RSA host key.
debug1: Found key in .
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: password
debug1: Next authentication method: password
testscp@10.130.1.40's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
debug1: Sending command: scp -v -f startup.cnf
exec request failed on channel 0

 

Config 5920:

#
line vty 0 15
authentication-mode scheme
user-role network-operator
#

#
ssh server enable
ssh user testscp service-type scp authentication-type password
#

local-user testscp class manage
password hash
service-type ssh
authorization-attribute user-role network-admin
#

3 REPLIES
Flash600
Occasional Visitor

Re: configure scp transfers 5920

Hi,

maybe because you have an writing mistake?

debug1: Sending command: scp -v -f startup.cnf ==> scp -v -f startup.cfg

leondv
Visitor

Re: configure scp transfers 5920

Hi,

Sorry human error :). Still getting exec failed:

#scp testscp@10.130.1.40:startup.cfg /tmp
exec request failed on channel 0

leondv
Visitor

Re: configure scp transfers 5920

fixed:

scp server enable