Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

hp 5900 lacp to flex10 (link standby)

SOLVED
Go to solution
drolfe
Valued Contributor

hp 5900 lacp to flex10 (link standby)

HI,

 

I setup a single interface lacp between my hp 5900 switch to bay2 flex10 switche

 

Problem is the lacp link state stays as standby ?

 

I would have expected bay2 ports to go standby if I also had bay1 ports in the portchannel but this isn't the case

 

Config I used below:

 

[hp5900-irf] interface Bridge-Aggregation200
[hp5900-irf-Bridge-Aggregation-200] port link-type trunk
[hp5900-irf-Bridge-Aggregation-200] port trunk permit vlan 30
[hp5900-irf-Bridge-Aggregation-200] link-aggregation mode dynamic


[hp5900-irf-Ten-GigabitEthernet2/0/2] port link-mode bridge
[hp5900-irf-Ten-GigabitEthernet2/0/2] port link-type trunk
[hp5900-irf-Ten-GigabitEthernet2/0/2] port trunk permit vlan 30
[hp5900-irf-Ten-GigabitEthernet2/0/2] port link-aggregation group 200

 

Any ideas ?

 

Regards, Daniel

10 REPLIES
Vince-Whirlwind
Honored Contributor

Re: hp 5900 lacp to flex10 (link standby)

Do you have additional 5900 interfaces in the LACP group?

 - Do we take it as read that any additional interface has the precise same config as the config you've shown for int Te2/0/2

 

What about the flex10 switch config - what does that look like?

drolfe
Valued Contributor

Re: hp 5900 lacp to flex10 (link standby)

HI,

 

Yes it's just the single 10g port for now in the port channel

 

the vc config is just a standard uplink set with the default setting

 

The reson for this single link uplink set is that I need vlan 30 to not be a private vlan on one blade servers but on all the others vlan 30 needs to be private.

 

Let me know if you need any other details

 

Regards, Daniel

 

 

drolfe
Valued Contributor

Re: hp 5900 lacp to flex10 (link standby)

Also please see attached diagram

 

Existing LACP group br100

 

Ten1/0/1 => bay3 x3 (Active)

Ten2/0/1 => bay3 x4 (Active)

Ten1/0/2 => bay4 x3 (Standby)

 

New LACP group br200

 

Ten2/0/2 => bay4 x4 (Standby) ...!!??

 

 

Regards, Daniel

Vince-Whirlwind
Honored Contributor

Re: hp 5900 lacp to flex10 (link standby)

I guess the question is: have you configured LACP on the physical ports on the FLex-10 module you've patched your switch to?

drolfe
Valued Contributor

Re: hp 5900 lacp to flex10 (link standby)

HI, Yes I have, well it's done by default when you add interfaces into a "shared uplinkset"

 

Please see attached

 

The interface high lighted is the one I tried to put into a single interface prot channel by itself but it remained in link-standby

 

 

Vince-Whirlwind
Honored Contributor

Re: hp 5900 lacp to flex10 (link standby)

OK, I was under the impression that it was when you add the ports in the Virtual Connect Manager that sets up the LACP. I was under the impression that the Shared Uplink Set relates to VLAN config, not link aggregation.

 

Regardless, that screenshot you've just attached shows that the Flex-10 side looks the way it is supposed to.

 

However, I am confused - it shows four "linked" links, and you're talking about a single link. ???

 

Going back to what you wrote earlier, I am now under the impression that you are trying to implement a *different* VLAN configuration on the Bay2 link from the VLAN config on the Bay1 link.

I think this might be the issue - I think the purpose of a "Shared Uplink Set" is to group links that have identical VLAN functionality?

So, I *think* that if you have differing VLAN requirements, you need to use different Shared Uplink Groups.

 

What do you think? I'm by no means an expert with these things - the only time I've had to deal with them, I was responsible for the ToR switches and the Data Centre guys drove the blade enclosure (via GUI, which I never understand very well) while I tried to figure out what they were doing.

drolfe
Valued Contributor

Re: hp 5900 lacp to flex10 (link standby)

HI,

 

I beleive the comware side is all good.

 

I think the question is on the virtual connect (flex10) side of things:

 

1) Can I expect flex switch 2 (bay 2) in a c7000 chassis to privide active LACP status if the LACP group doesn't have any switch1 (bay1) ports ???

 

2) Will it work with a single interface in the LACP group ???

 

Regards, Daniel

drolfe
Valued Contributor
Solution

Re: hp 5900 lacp to flex10 (link standby)

OK I got this working,

 

I changed two things and now the port is link-active

 

added vlan 1 (native vlan)

added stp edged-port

 

Full config below:

 

<HP-5900-Stack>dis cur interface br200
#
interface Bridge-Aggregation200
 port link-type trunk
 port trunk permit vlan 1 30
 link-aggregation mode dynamic
 stp edged-port
#
return
<HP-5900-Stack>dis cur interface Ten-GigabitEthernet 2/0/2
#
interface Ten-GigabitEthernet2/0/2
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan 1 30
 port link-aggregation group 200
#
return
<HP-5900-Stack>

 

 

Link-agg info

 

Aggregate Interface: Bridge-Aggregation200
Aggregation Mode: Dynamic
Loadsharing Type: Shar
System ID: 0x8000, 4431-922b-88b3
Local:
  Port             Status  Priority Oper-Key  Flag
--------------------------------------------------------------------------------
  XGE2/0/2         S       32768    4         {ACDEF}
Remote:
  Actor            Partner Priority Oper-Key  SystemID               Flag
--------------------------------------------------------------------------------
  XGE2/0/2         20      1        6         0x1   , 0026-5558-1a0b {ABCDEF}

 

 

Also see attached the VC is now happy

TerjeAFK
Respected Contributor

Re: hp 5900 lacp to flex10 (link standby)

Are you sure you want that config? stp edged-port is normally only used for ports connected to end user equipment so the port will start forwaring quicker when it comes online. It is normally not used for ports connecting to other managed switches. How is STP configured on the Flex10?

drolfe
Valued Contributor

Re: hp 5900 lacp to flex10 (link standby)

Hi,

 

AFAIK flex10 doesn't function like an actual switch and also doesn't run STP.

 

I got the stp edge-port config from the below site:

 

hp-virtual-connect-shared-uplink-set-configuration-with-hp-5900af-and-vsphere

 

Happy if someone can correct me on this but I seem to remember reading it somewhere.

 

Regards, Daniel