Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

hp-search-mac HPE FlexNetwork 7500

 
Highlighted
pificeli
Occasional Contributor

hp-search-mac HPE FlexNetwork 7500

Good morning,

for a long time I have been using a mac-address search software in my lan, hp-search-mac. this software works well on older procurve switches 5400. I am now replacing some switches in favor of HPE FlexNetwork 7510. I tried hp-search-mac on the new switches but it does not work, reporting the following error:

Warning: Can not get table from XXX.XXX.XXX.XXX, probably authentication or connection failure.

Can you halp me?

Thank you.

 

This is my config file:

#
version 7.1.070, Release 7568
#
mdc Admin id 1
#
sysname E3P1BNEW
#
clock timezone Amsterdam add 01:00:00
clock summer-time FDT 02:00:00 March last Sunday 03:00:00 October last Sunday 01:00:00
clock protocol ntp mdc 1
#
telnet server enable
#
forward-path-detection enable
#
irf mode normal
#
resource-monitor resource ac slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource agg_group slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource arp slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ecmpgroup slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource host slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipmc slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_127 slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_128 slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_64 slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource l2mc slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mac slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcin slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcout slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nd slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nexthoppool1 slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource openflow slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pbr slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterin slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterout slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource route slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource rport slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vlaninterface slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vrf slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsi slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsiintf slot 0 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ac slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource agg_group slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource arp slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ecmpgroup slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource host slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipmc slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_127 slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_128 slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_64 slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource l2mc slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10

resource-monitor resource mac slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcin slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcout slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nd slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nexthoppool1 slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource openflow slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pbr slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterin slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterout slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource route slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource rport slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vlaninterface slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vrf slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsi slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsiintf slot 5 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ac slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource agg_group slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource arp slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ecmpgroup slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource host slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipmc slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_127 slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_128 slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource ipv6_64 slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource l2mc slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mac slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcin slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource mqcout slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nd slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource nexthoppool1 slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource openflow slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pbr slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterin slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource pfilterout slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource route slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource rport slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vlaninterface slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vrf slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsi slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
resource-monitor resource vsiintf slot 6 cpu 0 by-percent minor-threshold 20 severe-threshold 10
#
igmp-snooping
#
udp-helper enable
udp-helper port netbios-ds
udp-helper port netbios-ns
#

dhcp enable
#
dhcp snooping enable
dhcp snooping enable vlan 75 200
#
lldp global enable
#
system-working-mode standard
xbar load-balance
password-recovery enable
#
vlan 1
#
vlan 75
name utenti
igmp-snooping enable
igmp-snooping version 3
#
vlan 200
name ced-cci
igmp-snooping enable
igmp-snooping version 3
#
stp region-configuration
region-name XXXXX
revision-level 1
active region-configuration
#
stp instance 0 priority 4096
stp mode rstp
stp bpdu-protection
stp global enable
#
ftth
#
interface Bridge-Aggregation1
description "E3P1B to E3CS"
port link-type trunk
port trunk permit vlan 1 75 200
link-aggregation mode dynamic
dhcp snooping trust
#

interface Bridge-Aggregation2
description "E3P1B to E2CS"
port link-type trunk
port trunk permit vlan 1 75 200
shutdown
link-aggregation mode dynamic
dhcp snooping trust
#
interface NULL0
#
interface Vlan-interface1
ip address 10.176.5.11 255.252.0.0
#
interface Vlan-interface75
ip forward-broadcast
dhcp select relay
dhcp relay server-address 10.10.0.4
dhcp relay server-address 10.10.0.1
udp-helper server 10.100.60.81
udp-helper server 10.100.60.80
#
interface Vlan-interface200
ip forward-broadcast
dhcp select relay
dhcp relay server-address 10.10.0.4
dhcp relay server-address 10.10.0.1
udp-helper server 10.100.60.81
udp-helper server 10.100.60.80
#

interface GigabitEthernet0/0/1
port link-mode bridge
port access vlan 75
stp root-protection
stp edged-port
stp tc-restriction
stp port bpdu-protection enable
loopback-detection enable vlan 1 to 4094
loopback-detection action shutdown
dhcp snooping binding record

#

.....

.....

interface GigabitEthernet0/0/48
port link-mode bridge
port access vlan 75
stp root-protection
stp edged-port
stp tc-restriction
stp port bpdu-protection enable
loopback-detection enable vlan 1 to 4094
loopback-detection action shutdown
dhcp snooping binding record

#

interface Ten-GigabitEthernet5/0/1
port link-mode bridge
description "E3P1B to E3CS"
port link-type trunk
port trunk permit vlan 1 75 200
port link-aggregation group 1
#

interface Ten-GigabitEthernet6/0/1
port link-mode bridge
description "E3P1B to E2CS"
port link-type trunk
port trunk permit vlan 1 75 200
port link-aggregation group 2
#

scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
authentication-mode password
user-role network-admin
set authentication password hash XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
#
line aux 1
user-role network-admin
#
line vty 0 4
authentication-mode scheme
user-role network-operator
set authentication password hashXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
#
line vty 5 63
user-role network-operator
#
ip route-static 0.0.0.0 0 10.176.0.2
#
info-center loghost 90.147.198.67
info-center source default console deny
#
ssh server enable
ssh user manager service-type all authentication-type password
#
sntp enable
sntp unicast-server 193.204.114.232
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role

role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user manager class manage
password hash XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
service-type ftp
service-type telnet http ssh terminal
authorization-attribute user-role level-3
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator
#
ip http enable
#

return

2 REPLIES 2
Rajendra_Jena
Occasional Advisor

Re: hp-search-mac HPE FlexNetwork 7500

Hi pificeli,

I need more information how the software fetches MAC information from the Procurve switches? Is it using Telnet or SNMP to get the switch mac informations? 

 

Best Regards,
I am an HPE Employee
pificeli
Occasional Contributor

Re: hp-search-mac HPE FlexNetwork 7500

Hi @Rajendra_Jena ,

hp-search-mac use smtp v1 to connect to switch procurve.

I want to use it to connect new os comware based.

hp-search-mac is a script in perl that use pkg opalmod and libnet-snmp-perl. It connect to procurve via snmp anche use this three variable to compose the OID:

$macToPortOid = "17.4.3.1.2";
$ifDescr = "2.2.1.2";
$base = ".1.3.6.1.2.1";

I think that the 7500 switch respond with empty value when hp-search-mac request OID.

thanks,

Pietro.