Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

incorrect ARP for Gateway IP driving me crazy!

pavlouc
Occasional Visitor

incorrect ARP for Gateway IP driving me crazy!

 

HELP!!!!!!!!!----incorrect ARP killing me here.

 

I have an Astaro Gateway router running v8 – this has 4 interfaces.

eth0 is assigned as internal and is the gateway with IP 192.168.151.1

eth1 is my external WAN interface which is on VLAN 2 this connects to port 3 on the core, which is tagged and the ISP circuit which is also tagged connects to port 1 on the core

eth2 is a guest network on vlan 10, this is also tagged on the core switch and connects to ports 6, 7 and 12(port 12 is also tagged for vlan 20).

Eth3 is on vlan 20 and is also tagged and occupies ports 6 and 12.

 

Core switch is an HP 2910 which is located on the 4th floor, this then connects down to the first switch on the 2nd floor over fibre, the first switch on the second floor then connects to the second switch on the 2nd floor over copper. The 2 switches on the 2nd floor are HP 2520.

 

My issue is this, users on the second floor intermittently can’t ping the gateway, if you then run and arp –a on the client PC it returns either the MAC for eth2 or eth3 of the Astaro(if I run an arp on the switch that the PC is connected to I get the correct MAC for eth0). If I clear the arp on the switch, it then relearns the MAC and sometimes it also picks up the mac for eth2 or eth3....but then after a short while this changes and shows the correct MAC for the gateway, I’ve tried setting the TTL of the MAC’s on the switch, this hasn’t helped.

VLAN tagging is only configured on the astaro and the core switch, there is no vlan’s configured on the 2nd floor switches.

 

Please see the attached word doc for screen captures. What can I do with my switching to overcome this?

 

thanks