HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

routing between subinterfaces not working

 
SOLVED
Go to solution
PeoplesProjects
Occasional Advisor

routing between subinterfaces not working

hi,

i have configured a MSR2003 with 3 subinterfaces:

G0/1.1   ip address 192.168.1.1 255.255.255.248

G0/1.10   ip address 192.168.10.254 255.255.255.0

G0/1.20   ip address 192.168.20.254 255.255.255.0

G0/0 has IP 192.168.0.100 255.255.255.0

the problem is that there is not routing between the subinterfaces. I can ping al of the gateway addresses from the same subnet but not from a different one.

I can ping the G0/0 without any problem from all my subnets. So routing works fine there.

my routing table show the direct connected routes.

[PPR1]show current-configuration
#
version 7.1.059, Release 0306P11
#
sysname PPR1
#
dhcp enable
#
dns server 8.8.8.8
dns server 8.8.4.4
#
password-recovery enable
#
vlan 1
description Management
#
vlan 10
description PeoplesProjects
#
vlan 20
description Guest
#
dhcp server ip-pool Gasten
network 192.168.20.0 mask 255.255.255.0
dns-list 8.8.8.8 8.8.4.4
domain-name gast-pp.be
netbios-type b-node
#
dhcp server ip-pool PeoplesProjects
gateway-list 192.168.10.254
network 192.168.10.0 mask 255.255.255.0
dns-list 192.168.10.1 8.8.8.8 8.8.4.4
domain-name bureau-peoplesprojects.be
expired day 5
netbios-type b-node
#
policy-based-route VLAN1 permit node 2
if-match acl 2000
#
controller Cellular0/0
#
interface Aux0
#
interface NULL0
#
interface Vlan-interface1
rip version 2 multicast undo dhcp select server
#
interface Vlan-interface10
#
interface Vlan-interface20
#
interface GigabitEthernet0/0
port link-mode route
ip address dhcp-alloc
rip version 2 multicast
undo dhcp select server
#
interface GigabitEthernet0/1
port link-mode route
mac-address e8f7-24e6-5163
#
interface GigabitEthernet0/1.1
ip address 192.168.1.1 255.255.255.0
rip version 2 multicast
vlan-type dot1q vid 1
#
interface GigabitEthernet0/1.10
ip address 192.168.10.254 255.255.255.0
rip version 2 multicast
vlan-type dot1q vid 10
#
interface GigabitEthernet0/1.20
ip address 192.168.20.254 255.255.255.0
rip version 2 multicast
vlan-type dot1q vid 20
#
security-zone name Local
#
security-zone name Trust
#
security-zone name DMZ
#
security-zone name Untrust
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class tty
user-role network-operator
#
line class vty
user-role network-operator#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
snmp-agent
snmp-agent local-engineid 800063A280E8F724E6516200000001
snmp-agent sys-info contact Benny Van Den Heuvel
snmp-agent sys-info location PeoplesProjects Server Room
snmp-agent sys-info version v3
#
ssh server enable
#
ntp-service refclock-master
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
role name pp
description Peoplesprojects administrators
#
user-group 1
#
user-group system
#
local-user admin class manage
password hash $h$6$u0I4FERrGg5MurYu$rqXZLSrNLsVHV+k8Xwnva+tC/WgwjVPRR3420J8jS1XXsS/ECoHTLXovKA5c2aQYRfx7ZgvEY3NSnCcrGWToHQ==
service-type ssh telnet terminal http https
authorization-attribute user-role level-15
authorization-attribute user-role network-operator
#
cwmp
cwmp enable
#
ip http enable
ip https enable
#


Any idea why the routing not worked between the subinterfaces?

 

 

3 REPLIES
Vince-Whirlwind
Honored Contributor

Re: routing between subinterfaces not working

What are the full IP addressing details of the devices you are using to initiate the ping?

PeoplesProjects
Occasional Advisor

Re: routing between subinterfaces not working

i was using the folowing for testing the ping:

IP: 192.168.10.1

sub: 255.255.255.0

gateway: 192.168.10.254

This was given trough DHCP pool i have setup on the router. I have a TP-link switch where i created VLAN 10 and 20.

This switch worked fine with my cisco router 2900 series where i had the same settings setup

i want to give VLAN 20 only access to internet this will be the Guest network. The default en VLAN 10 must communicate with eachother.

i use VLAN 1 for management of the network devices and VLAN 10 for our employees.

The strange thing is that i can ping the other port G0/0 at 192.168.0.100 without any issues from any VLAN.

 

PeoplesProjects
Occasional Advisor
Solution

Re: routing between subinterfaces not working

Update:

i just find out why it was not working. I was thinking in cisco terms while i created the trunk to the router but likely it is not a trunk on HP devices but access-port with multiple vlans tagged to it. After that routing was working fine.