Comware Based
cancel
Showing results for 
Search instead for 
Did you mean: 

strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enable"

spag
Occasional Advisor

strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enable"

Hi,

I have a strange problem with A5120 switch.

 

the problem occurs on certain switch port.

all port in the switch have the same configuration, for plug a SIP Phone and a Lapop are just a SIP Phone are just a lapop.

 

When i plug just a laptop under the interface gig1/0/1, this laptop receive ip address with the dhcp server (all parameter is ok), it can join the dhcp server but but nothing else, can't join his gateway are another laptop in the same vlan.

 

when i ping his gateway with this laptop, i seen the ARP request leave the switch laptop port and leave the switch interconnect switch-to-core port. I seen the ARP response go in the switch interconnect switch-to-core port. But this response does not arrive on the laptop port.

 
For this configuration i use the hybrid mode, if i keep the hybrid mode and if i disable the CLI " voice vlan 101 enable", the laptop have access to the network, but the SIP Phone don't receve his voice vlan id.
 

With the link type access or trunk under the interface gig1/0/1, no have problem with the laptop (but the SIP Phone don't receve his voice vlan id).

 

 

 

I have the problem under the interface GigabitEthernet1/0/1 but not with interface GigabitEthernet1/0/2 (this is the same configuration):

#
voice vlan aging 100
voice vlan mac-address 0008-5d00-0000 mask ffff-ff00-0000 description **Aastra-67xxi**
#
interface GigabitEthernet1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 25 untagged
port hybrid pvid vlan 25
voice vlan qos trust
voice vlan 101 enable
broadcast-suppression 5
multicast-suppression 5
undo jumboframe enable
poe enable
stp edged-port enable

#
interface GigabitEthernet1/0/2
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 25 untagged
port hybrid pvid vlan 25
voice vlan qos trust
voice vlan 101 enable
broadcast-suppression 5
multicast-suppression 5
undo jumboframe enable
poe enable
stp edged-port enable

4 REPLIES
Vince-Whirlwind
Honored Contributor

Re: strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enabl

Shouldn't you have 

port trunk permit vlan 25,101

?

spag
Occasional Advisor

Re: strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enabl

i don't use the trunk mode for the end user access, i use the hybrid mode with auto voice mode.

i use trunk mode just for the switch to switch interconnect port.

 

interface GigabitEthernet1/0/1
 port link-type hybrid
 undo port hybrid vlan 1
 port hybrid vlan 25 untagged
 port hybrid pvid vlan 25
 voice vlan qos trust
 voice vlan 101 enable
 broadcast-suppression 5
 multicast-suppression 5
 undo jumboframe enable
 poe enable
 stp edged-port enable

sdide
Respected Contributor

Re: strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enabl

Hi Spag,

 

If the configurations are exactly the same for the two ports, you're shifting the same equipment between the ports and it works in one, and not the other -

there are only a few options.

 

1: Somehow the ASIC is doing somthing wrong on that port. (hardware)

2: You're using a different cable in the ports and one is broken. (hardware)

3: You have some other configuration we cannot see that singles out interface Gi1/0/1 (traffic suppression, LLDP, etc).

4: A timing issue, with arp and mac timers. Have you tried clearing the mac-address-tables and the arp-tables?

5: Something not in 1-4 :)

 

Considering what you've written I think it might not be the same equipment in Gi 1/0/1 and Gi1/0/2- 

because:

1: Seems unlikely since the port is working fine in other secenarios.

2: Same as 1:

3: Well?

4: Can be ruled out easily.

5: Catchall not really useful.

 

By the way you could use LLDP to make the phones join the Voice vlan?

 

Regards.

Søren Dideriksen, Network Administrator
Region Midtjylland
spag
Occasional Advisor

Re: strange problem A5120, laptop don't have network access with the CLI " voice vlan 101 enabl

hi,

since monday i have disable "voice vlan xxx enable" just on the port 1/0/1 and i have activate 'lldp voice-vlan xxx".

actually it's work fine, i wait some day for seen if the problem come back.