cancel
Showing results for 
Search instead for 
Did you mean: 

Apache 1.3.26 installation

serguey kavafian
Occasional Advisor

Apache 1.3.26 installation

Hi
Ran ./configure on HP-UX 11 got following:

======== Error Output for sanity check
cd ..; cc -DHPUX11 -Aa -Ae -D_HPUX_SOURCE -DUSE_HSREGEX -DUSE_EXPAT -I.
/lib/expat-lite -DNO_DL_NEEDED `./apaci` -o helpers/dummy helpers/dummy.c
-lm -lpthread
(Bundled) cc: warning 480: The -A option is available only with the C/ANSI C pro
duct; ignored.
(Bundled) cc: warning 480: The -A option is available only with the C/ANSI C pro
duct; ignored.
(Bundled) cc: "helpers/dummy.c", line 3: warning 5: "const" will become a keywor
d.
(Bundled) cc: "helpers/dummy.c", line 3: error 1000: Unexpected symbol: "char".
(Bundled) cc: "helpers/dummy.c", line 4: warning 5: "const" will become a keywor
d.
(Bundled) cc: error 2017: Cannot recover from earlier errors, terminating.
*** Error exit code 1
Stop.
What is this and what i have to do to get this working??
Thank you
2 REPLIES
Tom Maloy
Respected Contributor

Re: Apache 1.3.26 installation

Well, the errors indicate that Apache is looking for features that do not exist in the compiler (cc) that you are using.

Is there another compiler on your box? Can you use gcc?

Tom
Carpe diem!
benoit Bruckert
Honored Contributor

Re: Apache 1.3.26 installation

Hi,
I confirm what Tom said,
You try to compile Apache the the K&R C compiler from HP, but you need an ANSI C compiler.
If you don't have the HP one (you should know if you have it because you have to pay for this product !)
you can download gcc + binutils from a portal center (http://hpux.cs.utah.edu/ for example), install it, add in your PATH gcc, and it will work !!! (This is the way I do it !)

Regards
Benoit
Une application mal pansée aboutit à une usine à gaze (GHG)