cancel
Showing results for 
Search instead for 
Did you mean: 

Apache 1.3.26 installation

serguey kavafian
Occasional Advisor

Apache 1.3.26 installation

Thank you Benoit and Tom.
Installed Apache.

Now have problem using Apache bin/apxs to configure php 4.2.2.

After installation Apache/bin/apxs was pointing to /usr/contib/bin/perl. But when I ran PHP ./configure script I got following errors:

The output of /u03/Apache/bin/apxs follows
syntax error in file /u03/Apache/bin/apxs at line 67, next 2 tokens "use strict"
syntax error in file /u03/Apache/bin/apxs at line 74, next 2 tokens "my $CFG_TAR
GET "
syntax error in file /u03/Apache/bin/apxs at line 99, next 2 tokens "my $opt_n "
syntax error in file /u03/Apache/bin/apxs at line 125, next 2 tokens "my ("
syntax error in file /u03/Apache/bin/apxs at line 198, next 2 tokens "my $rc"
syntax error in file /u03/Apache/bin/apxs at line 201, next 2 tokens "1 and"
syntax error in file /u03/Apache/bin/apxs at line 202, next 2 tokens "not $opt_q
"
syntax error in file /u03/Apache/bin/apxs at line 211, next 2 tokens "my ("
syntax error in file /u03/Apache/bin/apxs at line 214, next 2 tokens "my ("
syntax error in file /u03/Apache/bin/apxs at line 216, next 2 tokens "$var and"
/u03/Apache/bin/apxs has too many errors.
configure: error: Aborting
I have also perl in $ORACLE_HOME/Apache/perl/bin/perl. When I changed apxs to point there i got different errors:
The output of /u03/Apache/bin/apxs follows
Can't locate strict.pm in @INC (@INC contains: /project/hpux/apache/install/perl
/lib/5.00503/PA-RISC2.0-thread /project/hpux/apache/install/perl/lib/5.00503 /pr
oject/hpux/apache/install/perl/lib/site_perl/5.005/PA-RISC2.0-thread /project/hp
ux/apache/install/perl/lib/site_perl/5.005 .) at /u03/Apache/bin/apxs line 67.
BEGIN failed--compilation aborted at /u03/Apache/bin/apxs line 67.
configure: error: Aborting

What is the problem? Is it perl?

-->In /usr/contib/bin/perl there is only one file
--> In $ORACLE_HOME/Apache/perl/
there is a tree
perl/bin; perl/lib ; perl/man

Or it is something else?
I'm installing Apache/PHP as a user if this matters.

Thanks again for the response!
Serguey
1 REPLY
benoit Bruckert
Honored Contributor

Re: Apache 1.3.26 installation

Hi again,
Check first the perl version you have :
perl -v

version 5.6.1. is working well,
You can install it from the application CD from HP. Warning , you have got it also on the portal center, but some features seem to not work properly, Then use the CD (it's better).
After it,
change the /usr/contib/bin/perl file, and create a link to the installation (/opt/perl/bin/perl).
Then try to compile php....

hope this help..
Benoit
Une application mal pansée aboutit à une usine à gaze (GHG)