cancel
Showing results for 
Search instead for 
Did you mean: 

Apache version upgrade

Sanjiv Sharma_1
Honored Contributor

Apache version upgrade

Hi,

I have L3000 with HP-UX 11i-OE-MC (HP-UX Mission Critical Operating Environment Component) which consists of Apache ver 1.3.19.20. I have been advised to upgrade the Apache to the latest version as it is velnerable.

From where can I get the latest version of the Apache Software and the procedure to install.

Thanks,
Raje.
Everything is possible
8 REPLIES
S.K. Chan
Honored Contributor

Re: Apache version upgrade

You can it from HPUX porting center.
http://hpux.cs.utah.edu/hppd/cgi-bin/search
OR
http://httpd.apache.org/
The latter has all the documentation you need.
Hope it helps ..
Michael Tully
Honored Contributor

Re: Apache version upgrade

You can get the latest version here. It comes with it's own instructions on how to load it. It is version 2.0.39 which has the security problem fixed.

http://www.apache.org/dist/httpd/#binaries
Anyone for a Mutiny ?
Michael Tully
Honored Contributor

Re: Apache version upgrade

The version from the porting centre has not got the security problem rectified. Get the latest version from the link I posted earlier.
Anyone for a Mutiny ?
Sanjiv Sharma_1
Honored Contributor

Re: Apache version upgrade

Hi Chan/Micheal,

Thanks dor your reply.

I got the software at
http://hpux.cs.utah.edu/hppd/hpux/Networking/WWW/apache-1.3.26/

The the apache s/w available is for HP-UX 11.00 and HP-UX 11.20.
My HP-UX version is 11.11.

Which one should I use? Simply swinstall will help or I need to do further compilation after installation?

Thanks,
Raje.
Everything is possible
benoit Bruckert
Honored Contributor

Re: Apache version upgrade

Hi Raje,
I prefer on my side, compiling it, because you can select all the parameters you want (path and so on),
The easiest way to compile GNU tools is to use gcc+binutils, you can get it from any portal center (or gnu.org). gunzip is also required.
Once installed, place gcc in your path, and download latest Apache source software (from APache.org).
Once you gunzipped the tar ball, untar it : you have the source software.
In this directory, run ./configure --help to see all the options.
The most important option is --prefix=.
Run then ./configure .
After it makefiles are ready :
#make
To create all the binaries,
#make install
to create paths and install binaries..

IT's not difficult and you select all the options you want.
If you have Ansi CC, you can use it instead of gcc..

Hope that help, and good compilations...
Benoit
Une application mal pansée aboutit à une usine à gaze (GHG)
Darren Prior
Honored Contributor

Re: Apache version upgrade

Hi Raje,

If you're after HP's Apache based web server please have a look at this doc id on the ITRC knowledge database HPSBUX0207-197 it contains further info and an ftp site for downloading the depot.

regards,

Darren.
Calm down. It's only ones and zeros...
Sanjiv Sharma_1
Honored Contributor

Re: Apache version upgrade

Hi,

I got the software at
http://hpux.cs.utah.edu/hppd/hpux/Networking/WWW/apache-1.3.26/

The the apache s/w available is for HP-UX 11.00 and HP-UX 11.20.
My HP-UX version is 11.11.

I binary files in http://www.apache.org/dist/httpd/binaries/hpux/
are also for HP-UX 11.00 and HP-UX 11.20.

Which one should I use? Or from where can I get the Apache ver 1.3.26 for HP-UX 11.11?

Thanks,
Raje.


Everything is possible
Bill McNAMARA_1
Honored Contributor

Re: Apache version upgrade

I prefer to download precompiled/supported builds from hp's software server:

http://www.software.hp.com/cgi-bin/swdepot_parser.cgi/cgi/displayProducts.pl?group_name=HP%20Apache-based%20Web%20Server&group_image=cat_featured.gif&group_type=family

If you go to www.software.hp.com, it's ususally on the top 10 list.

Later,
Bill
It works for me (tm)