Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

kris77
Occasional Visitor

Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

I am trying to upgrade my application DB from Oracle 9.2.0.6 to 10.2.0. I am getting the following error during compilation.

/usr/ccs/bin/ld: Unsatisfied symbols:
Class tables [Vtable] dependent on key function: "std::exception::~exception()" (first referenced in /oracle10/app/oracle/10.2.0/lib32/libxml10.a(lpxdom.o)) (data)
typeid<:exception> (first referenced in /oracle10/app/oracle/10.2.0/lib32/libxml10.a(lpxdom.o)) (data)
std::exception::~exception() (first referenced in /oracle10/app/oracle/10.2.0/lib32/libxml10.a(lpxdom.o)) (code)

Am using aCC: HP ANSI C++ B3910B A.03.63.
Can anyone help me?

Kris
5 REPLIES
Peter Godron
Honored Contributor

Re: Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

Kris,
maybe a compiler specific optione like (-AA) is missing.
Have a look at the Session log file which should show the command the conversion is trying to execute. This should give you more of an idea where the problem is.
Sivakumar TS
Honored Contributor

Re: Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0


Hi,

Did you check the PATCH requirements for oracel 10.2.0? that could be a cause for this error.

Nothing is Impossible !
Yogeeraj_1
Honored Contributor

Re: Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

hi kris,

i would also recommend that you go through the preinstall procedure for oracle 10.2.0.1 first and ensure that your environment is READY to run Oracle 10g release 2.

there is also the "validate" script which is available on metalink that can help you identify all the stuffs that are currently missing on your server as well as the configuration parameters and enviroment variables required.

hope this helps too!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
SteveKirby
Frequent Advisor

Re: Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

A quick search on the metalink site says you need to upgrade the OS:
10.2.0 HP ANSI C B.11.11.12 & HP aC++ A.03.60

Look for note: 43208.1
kris77
Occasional Visitor

Re: Appl. DB upgrade from Oracle to Oracle 10.2.0 on HP-UX 11.0

Found a solution.

I have added std_v2 & Csup_v2 to LIB_LIST in mk file. The problem is resolved.

Thanks to all.

-Kris