Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Building perl 5.6.1, hp-ux 11.11, 64 bit with mod_perl, DBI and DBD-Oracle

RichardG
Occasional Visitor

Building perl 5.6.1, hp-ux 11.11, 64 bit with mod_perl, DBI and DBD-Oracle

Hello

4 days later....................
I am still trying to build perl 5.6.1 on hp-ux 11.11 using 64 bit kernel and Oracle 9.0.1
Using CPAN I have attempted to install the following modules, but various failures have led to me flagging for HELP !
As a consequence I have the following software resident on my server;
Apache 1.3.26.
mod_perl 1.27
DBI 1.28
DBD::Oracle 1.12
Apache::DBI 0.89
XML::Parser 2.31
SOAP::Lite

1) What flags and libraries shall I use when building perl ?
I believe I need 64bit perl for the DBI and DBD Oracle.
I have read the READMEs for DBI, perl...etc and they all seem suggest different ways of building perl, i.e -Ubincompat5005 -Uuse64bitall
Some say build thread perl, whereas DBD Oracle README states not to build threaded perl, but linked with lcl and lpthread.
Some say include ccflags +DD64.........etc

2) What order shall I build the modules/Apache ?

Thanks
Richard
MIS Unix Team
Keep it simple and enjoy life