Databases
cancel
Showing results for 
Search instead for 
Did you mean: 

Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Henrique Silva_3
Regular Advisor

Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

I am using these files on a K580 running hpux 64 bit, as you can see from the output below :

HP_IA64_server_9.2.0.2.0_Disk[123].cpio

# model
9000/800/K580
# uname -a
HP-UX SERVERNAME B.11.00 A 9000/800 894337431 two-user license
# /usr/sbin/swlist |grep -i runtime
HPUXEng64RT B.11.00.01 English HP-UX 64-bit Runtime Environment
# getconf HW_32_64_CAPABLE
3 ( not sure what 3 means )
# getconf KERNEL_BITS
64

When I try to run the runInstaller, I get the message :

$ /Disk1/runInstaller
$ /Disk1/runInstaller: ./runInstaller: Execute permission denied.

Looking for this error, I see that it usually happens when you try to install 64 bit oracle on 32 bit )S, which is not the case here.

Any other ideas ?

Thanks,

Henrique
"to be or not to be, what was the question ???? "
13 REPLIES
Victor BERRIDGE
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Hi,
Who are you when you execute runinstaller?

All the best
Victor
Henrique Silva_3
Regular Advisor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

oracle9i account, part of the dba group :-(

Henrique
"to be or not to be, what was the question ???? "
Jeroen Peereboom
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Henrique,

Some trivial issues:
* Check permissions of runInstaller. Is it something like oracle dba r-xr-xr-x?
* You may also try: sh runInstaller.
* Did you FTP the files from windows to UX with / in BINARY mode.

JP

(did you copy your CD's to the hard disk? If not , do NOT use ./runInstaller because you won't be able to change the CD if requested.)
Steven E. Protter
Exalted Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

1) That box runs either 32 or 64 bit OS. You should get a better answer to your getconf command. Or maybe not.

[5810#] getconf HW_32_64_CAPABLE
2

From a D320 with 32 bit installed.

getconf KERNEL_BITS
32


So, I'd say you have a 64 bit installation.

I'd say the problem lies elsewhere.

1) is the system patched to Oracle's latest spec/list for the os(metalink.com)

2) You may have the gron version of CPIO installed.

3) You may not have enough space in /tmp to unpack the files.

4) Your kernel might not meet specifications.

I would say if you went through the pre-installation section f the guide very carefully and checked each minute point, you would find your answer.

Can I see swapinfo -tam output please.

SEP
Jerusalem(meaning I don't have access to my tricks and only an old D320 server).

Also meaning I'm on vacation, might not follow up but the information might be useful to others.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Hein van den Heuvel
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit


You are using IA64 (aka IPF aka Itanium) bits for a PA box. That is not going to work!


So you used the download - gunzip - cpio way to get teh install disks no?

You loaded from from:
http://otn.oracle.com/software/products/oracle9i/htdocs/hpia64soft.html
Targets:
http://download.oracle.com/otn/hp/oracle9i/9202//HP_IA64_server_9.2.0.2.0_Disk1.cpio.gz
?


You should be getting:

http://download.oracle.com/otn/hp/oracle9i/9201/server_9201_hpunix64_disk1.cpio.gz

and upgrade later...

hth,
Hein.
Henrique Silva_3
Regular Advisor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Yup, that seems to be the problem.

I did not downloaded this myself, so, when I went back, I noticed that the Itanium version also says HPUX/IA64, and I can see why there is some confusion.

So, 9.2.0.2 will not run on PA-RISC ? I think Oracle could change the description of the file, so that people would not make such mistakes. They should say HPUXforIA64 or something like that !! :-(

Downloading the 9.2.0.1 instead. will let you know how I do !!!

Thansk for the help,

Henrique
"to be or not to be, what was the question ???? "
R. Allan Hicks
Trusted Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

I'm running 9.2.0.2 on a K460. My install CDs have part number A99149-01 written on it.

Oracle 9i Database (64-bit)
Release 2 (9.2.0.1.0)
for HP 9000 Series HP-UX
CD 1 of 4
A99149-01

On the other 3
A99150-01
A99151-01
A99152-01

I patched to 9.2.0.2
"Only he who attempts the absurd is capable of achieving the impossible
David Bell_1
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Henrique,

We are running 9.2.0.4 on our rp7400 (N-Class). We upgraded from 9.2.0.1 but I'm unsure if the code was from download or from CD. We are running this on HP-UX 11.00 64 bit.

HTH,


Dave
Henrique Silva_3
Regular Advisor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit


Can you guys send me the link for the patch to bring it up to 9.2.0.4 ?

I am still downloading the 4 files :-( It took all night on my VPN broadband connection ( download to pc first then to hpux server ).

Thanks,

Henrique
"to be or not to be, what was the question ???? "
David Bell_1
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Henrique,

It appears that the latest is 9.2.0.5 from the table at:

http://otn.oracle.com/support/patches.htm

The location of the patch is at:

http://metalink.oracle.com

Select "patches" on the left column, then "Quick Links to latest patch sets", run your mouse over the "Oracle Database" link and select HP-UX PA-RISC (64 Bit). There you can download the patch bundle for 9.2.0.4 or 9.2.0.5 if you prefer.

HTH,

Dave
Yogeeraj_1
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

hi henrique,

better download the latest one available for HP-UX. i.e. 9.2.0.5.

You should proceed as follows:
Metalink (http://metalink.oracle.com)->Patches->Simple Search then enter 3501955 for "Search by"->Patch Number.
NB. Platform or language should be "HP-UX PA-RISC (64-bit)"
then click on "GO"

Then you should be able to download:
Patchset 3501955
Description: ORACLE 9I DATABASE SERVER RELEASE 2 - PATCH SET 4 VERSION 9.2.0.5.0
Product: Oracle Database Family
Release Oracle 9.2.0.5
Select a Platform or Language: HP-UX PA-RISC (64-bit)
Last Updated 02-APR-2004
Size 567M (595387250 bytes)

The filename is: p3501955_9205_HP64.zip

hope this helps!
regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)
Henrique Silva_3
Regular Advisor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit


Thank you everyone.

I finally got the proper bits, and was able to install 9i. I am downloading the latest patches now, to apply them, before I attempt to upgrade our production like instance on this test box, to see how long it will take and if CBO works better on 9i then on 8i, as everyone seem to be claiming.

thanks again,

Henrique
"to be or not to be, what was the question ???? "
Hein van den Heuvel
Honored Contributor

Re: Can not install Oracle 9i ( 9.2.0.2.0 ) 64 bit

Thanks for the update. Be sure to have the proper stats in place before evaluating the cbo. re-read sql ref man for 'analyze tables' and check out the recommandation to use dbms_stats in its place. Get statspack installed and use it. If you can, get some statspack data both for the old 8i and the new 9i setup to be able to compare. In both cases enable be careful with STATISTICS_LEVEL then default is 'typical' which may be too costly. 'basic' seems to be enough for day to day work.

Enjoy,
Hein.